Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. FredWst

    OpenCore Discussion

    Hi, Main difference is that OpenCore is an UEFI driver (DXE) and Clover is an application over UEFI. Correct me if I'm wrong. Fred
  3. Why do you post about this here rather than at Niresh ??? It's their distro after all...
  4. Thanks a million a million a million a million! This also helped me.
  5. m13939

    Mac'os Mojave 10.14.5 is OuT

    same issue with my RX 480
  6. Sherlocks

    Clover General discussion

    not at all. it'not affect the about this mac. it is just record for check of smbios model 나의 SM-N960N 의 Tapatalk에서 보냄
  7. As the title states, I need help fixing this, the song is irritating and mute doesn't work.
  8. If I remember correctly, yes, I used BIOS optimized defaults + modified memory profile setting. Just in case I made Command-Option-P-R and PRAM reset procedures at the beginning. Also works with two 4K displays, both 3840 x 2160@60 Hz, DP
  9. DSA2

    High Sierra su MSI coffee lake

    Salve a tutti Dopo un po di tempo , avendo avuto necessità di più potenza hardware , ho tralasciato hackintosh . Adesso vorrei ripartire avendo fatto upgrade hardware e qualcosina in più a breve ... soprattutto per la ram . Ho riletto i post e le risposte che mi avete dato . Come sempre professionalissimi ^^ Adesso mi sono creato una chiavetta di installazione Mojave. Ho anche i file post installazione : Lilu / FakePCIID / invidia WebDriver / Mentre nella chiavetta creata ho in Kext / Other / RealtekRTL8111.kext / VoodooHDA / WhateverGreen / AppleHDADisabler / e tutti i i FakeSMCP sensor scaricati da cloverconfigurator Come posso essere sicuro che funziona bene alla prima installazione ? Principalmente avrei bisogno di avere l' ethernet funzionante ed il wifi , dopo aver finito l' installazione, perchè avrei solo un sistema operativo dopo l' installer. Posso copiarvi il file di testo del config.plist quì in modo che mi ci date un' occhiata ? Aspetto info. grazie Come sono sintetico ^^ ... Premetto cmq. che l' installare usb mi parte benissimo senza riavvii o kernel panic di alcun tipo
  10. telepati

    Clover General discussion

    Does Clover affect the processor type under the About This Mac? If it is, that's why all 9900K users seeing own processor type as an i7 then.
  11. Hervé

    Bug Reporting

    @ailitasy, please stop such messages (especially THAT reply to THAT post) and stop resurfacing dead threads! Here, again, do you realise you're posting a reply to a 6yr old post and to someone who has not visited the forum for over a year ? Looking at your (short) posting history, it seems you've opted to specialize in this since joining on May 10th... Are you just trolling?
  12. Hey Community, I've read through these pages a lot in the last days and I'm now convinced that I would like to build my own Hacintosh! I'm a lot in Photo Editing and Programming but have little to no Hardware experiences (except from disassembling old computers and reassambling them). But scince my old MacBook Pro is slowly getting outdated and the new ones do not really offer the performance i am hoping for regarding the budget i have. Additionally i would probably start Gaming again with this kind of computer which is why i would also like to be able to run windows and need good performance. So i was looking around the last few days and came up with this setup: - Processor: Intel Core i7-8700K Processor (https://www.amazon.de/gp/product/B07598VZR8/?tag=tonymacx8603-21) ~ 395 € - Mainframe: ASUS ROG Strix Z390-E Gaming Mainboard Sockel 1151 (https://www.amazon.de/gp/product/B07HS7C63T/?tag=tonymacx8603-21) ~250 € - RAM: Ballistix Elite BLE2K8G4D26AFEA 16GB (8GBx2) (https://www.amazon.de/gp/product/B00RCGJLIM/?tag=tonymacx8603-21) ~135€ - GPU: Asus Dual-RX580-O4G Radeon Gaming Grafikkarte (https://www.amazon.de/gp/product/B071NS93PH/?tag=tonymacx8603-21) ~200€ - SSD: Samsung SSD 860 PRO 512 GB (https://www.amazon.de/gp/product/B078WQL6XF/?tag=tonymacx8603-21) ~130€ - HDD: Seagate ST2000DM006 HDD Barracuda 2000GB (https://www.amazon.de/gp/product/B01IEKG402/?tag=tonymacx8603-21 ~70 € - CPU-Cooler: Nzxt Kraken Wasserkühlung X62, 280mm (https://www.amazon.de/gp/product/B06XS9QNPS/?tag=tonymacx8603-21) ~144€ Or maybe some air cooler but i don't know which would fit in my Case... - PSU: Corsair TX650M (https://www.amazon.de/gp/product/B06W9G6H11/?tag=tonymacx8603-21) ~85€ - Case: Sharkoon TG5 ( https://www.amazon.de/gp/product/B0747VRXB2/?tag=tonymacx8603-21) ~70€ But any other case which looks good and does the job would be ok too? Total Cost = 1.479€ That would be totally fine scince i only wanted to stay below 1.500 So my questions are: 1) Do you think there would arise some problems with one of the Components when installing / running MacOS? 2) Do you know if all these parts work togehter properly? 3) Do you know if its possible to install MacOS and Windows (maybe some linus dist. as well) all on the same SSD? 4) Do you have any suggegstions for different components regarding my needs and budget? (Especially the CPU Cooler) 5) Do you think it's possible for a hardware noobie to assamble the whole computer whithout destroying some parts? 6) And Last but not least do you have any suggestions regarding displays? I would like to have a 2 display setup and would currently go with two of these: https://www.amazon.de/gp/product/B01CFTTXDS/?tag=tonymacx8603-21 Thanks in advance for any help! And thanks already for the greate Community here scince it already helped a lot in deciding if i want to go that way! Cheers Fabian
  13. jsl2000

    Opcode Emulator (OPEMU) Plug-in Project

    Unfortunately this patch can not work in my Ryzen 1700X hackintosh at all: It can boot to desktop at 10.14.1 & 10.14.5 only, but open any 32-bit app got instant reboot. At 10.13.6, 10.14.3 & 10.14.4 it got reboot before login desktop. So it seems only working partially in my FX-6300 hackintosh at present. BTW Shaneee: did you get your ALC-1220 working with audioid=11 ?
  14. Hi real3x do you know how I can extract a vanilla IOPlatformPluginFamily.kext. Been searching everywhere for one, can't find my backup either. I'm on 10.14.5 as of this morning.
  15. Today
  16. I see first post EDIT and the new script is much more better then the one I modify Moderator Please clean all the thread and stay focused with the first post now
  17. i think i have to install again on m2.ssd and dual boot from there? maybe.... i'm waiting for the new amd graphics card to change my 1070..... wait or no?
  18. CMMChris

    AMD Radeon Vii in macOS Mojave

    @ITzTravelInTime No, this iMac uses the 9900K with IGPU. The SMBIOS is totally optimized for IGPU rendering which is a shame because IGPU is slower than RX580 encoders. Thus for Hackintoshes it is the best to turn IGPU off and use iMacPro1,1 for best performance. Otherwise encoding will be done by IGPU. @Picasso Something is wrong with your configuration then. Otherwise it would work. Please make sure you have renamed your ACPI devices properly.
  19. - Mobo: Supermicro X10DAI- CPU: Dual 14 core Xeon E5-2690v4- Graphics: Radeon Vega Frontier- Crucial MX500 500GB as a boot drive- Mojave 10.14.5Everything works fluidly expect the sleep. I did a clean install of Mojave on my Hackintosh (and updated to 10.14.5). Everything seems to be working as far as I can tell, except when the system wakes from sleep, it causes a restart. Not critical for functionality, of course, but frustrating nonetheless. (Putting the computer to sleep, as well as shutting it down, is not an issue.)I worked with @MaLd0n to solve the sleep problems and we reached a dead end that is why I'm asking for help.What I did:1- I unlocked MSR registers to have native power management.2- I mod my bios to get full NVMe support using this GuideWhat @MaLd0n helped me with:1- fixing my DSDT file and added the proper patches.2- adding my devices to the PCI list.3- Add plug-in type in DSDT, so we can remove SSDT for pm.4- testing all the darkwake=10 boot config.5- Patch DSDT with following patches Code: -FIX ERRORS AND WARNINGS -HPET -SATA -sSATA -DMAC -SLPB -DARWIN -LPC -XHCI -EHCI -PLUGIN TYPE -ALZA to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN #1 -LAN #2 -SPSR -WIFI -EC -PNLF -HDMI -NVME If someone can have look in my debug files and maybe point me in what I'm missing I will be super grateful.I can provide any extra debug files if needed. Send me Idriss-iMac-Pro.lan.zip
  20. balag59

    AppleALC — dynamic AppleHDA patching

    Hi, Here are my laptop specs: HP Spectre X360(2015) Intel Core i7 5500u + Intel HD Graphics 5500 I think my soundcard is Realtek ALC 286(not sure though). I've installed Lilu and AppleALC kexts to L/E(repaired permissions and rebuilt kext cache). My audio devices tab under Hackingtool is completely empty as shown below: A search for HDEF turns up empty in IORegisteryExplorer as expected(see below). But the funny thing is that I can find HDEF in MaciASL( can't find HDAS or AZAL).(see below) Here is a copy of my debug report. I can get the sound to work only via bluetooth and internal speakers and normal headphones don't work. I was told that I would require some form of DSDT patching and this is the best place to find some help with that. I would appreciate any guidance on this matter. Please let me know if you need anything else from me. Thanks in advance! debug_10688.zip
  21. ---------------------------------------------------------------------------- UPDATE 2 - [SOLVED!] ---------------------------------------------------------------------------- So the problem seems to lie within whatever version ApfsDriverLoader-64.efi I was using prior to update, or perhaps the OS needed to load one last time to enable some sort of permission for accessing the apfs.efi file from the /usr/standalone/i386/ folder that I am unaware of??? Either way, I am marking this solved at this point- just update your ApfsDriverLoader-64.efi in your drivers64UEFI folder with the latest (2.0.7 release as of this post) https://github.com/acidanthera/AppleSupportPkg/releases I just dumped all the files in the Driver folder within the latest zip into my drivers64UEFI and removed apfs.efi from my previous "Update 1" edit, and it booted with no issues.
  22. OK, so based on Apple's EULA only Snow Leopard Server can be virtualised so the functionality is disabled in Workstation. However Donk removed the functionality to support Snow Leopard Workstation in the latest unlocker 302, but a separate utility is available to allow Snow Leopard Workstation to install and run, see link to thread below:
  23. MacFriedIntel

    OpenCore Discussion

    Clover is full of broken code and bloated, OC is a fresh approach to a Bootloader which is based mostly from the Osmosis Bootloader. Opencore is lightweight and only uses drivers and kexts and patches you put into the config.plist. The Manual gives clear instructions and is constantly updated.
  24. There's no need to duplicate your script for the "Beta" and "Release" statement. #!/bin/bash # Vars apptitle="makeLegitApp" version="1.1" # Set Icon directory and file iconfile="/System/Library/CoreServices/Installer.app/Contents/Resources/Installer.icns" current_date_time="`date "+%Y-%m-%d %H:%M:%S"`"; echo $current_date_time; echo "Starting makeLegitApp" # Select response=$(osascript -e 'tell app "System Events" to display dialog "Welcome makeLegitApp Select a choice to create your Install macOS Mojave.app" buttons {"Cancel","Beta","Release"} default button 3 with title "'"$apptitle"' '"$version"'" with icon POSIX file "'"$iconfile"'" ') action=$(echo $response | cut -d ':' -f2) # Exit if Canceled if [ "$action" == "Cancel" ] ; then osascript -e 'display notification "Program closing" with title "'"$apptitle"'" subtitle "User cancelled"' echo "User cancelled" exit 0 fi # Conditions based on user's selection if [ "$action" == "Beta" ] ; then APPNAME="Install macOS Mojave Beta" MOUNTPOINT="/Volumes/OS X Base System" URL_PATH="34/47/041-03369/rsbnsn82mun7a480ipgu4r7inb0307i5sq" else # We can only assume that the user selected "Release" ... APPNAME="Install macOS Mojave" MOUNTPOINT="/Volumes/macOS Base System" URL_PATH="21/07/041-59913/m210y0lkn7bsiqsi98vfuyk08x2z4to1qk" fi osascript -e 'display notification "Program makeLegitApp" with title "'"$apptitle"'" subtitle "User Selected '"$action"'"' Sleep 1 # Remove BUILD if exist if [ "/Private/tmp/src" ]; then rm -rf "/Private/tmp/src" fi if [ "/Private/tmp/Install macOS Mojave Beta.app" ]; then rm -rf "/Private/tmp/Install macOS Mojave Beta.app" fi if [ "/Private/tmp/Install macOS Mojave.app" ]; then rm -rf "/Private/tmp/Install macOS Mojave.app" fi if [ "/$HOME/Desktop/makeLegitApp" ]; then rm -rf "/$HOME/Desktop/makeLegitApp" fi osascript <<EOF tell application "makeLegitApp.app" activate end tell EOF # Root location of file #-------------------------- srcDir="/Private/tmp/src" # Create Source folder #---------------------- mkdir -p /Private/tmp/src echo "PROGRESS:0" echo "Build Install ${APPNAME}.app" sleep 1 printf "${RED}Script created by Hanger1${NC}\n" printf "${GREEN}Script adapt and modify by chris1111${NC}\n" printf "${GREEN}Spacial thanks to @fusion71au from insanelymac for guide.${NC}\n\n" printf "Download following files from Orignal Apple server\n\n" printf "1) BaseSystem.dmg\n" printf "2) BaseSystem.chunklist\n" printf "3) InstallInfo.plist\n" printf "4) InstallESDDmg.pkg\n" printf "5) AppleDiagnostics.dmg\n" printf "6) AppleDiagnostics.chunklist\n\n" printf "${BLUE}Catalog link: https://swscan.apple.com/content/catalogs/others/index-10.14seed-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz${NC}\n" printf "\n\nPut Above files into \"src\" folder\n\n\n" Sleep 3 echo "PROGRESS:10" sleep 1 echo "PROGRESS:20" sleep 1 echo " " sleep 1 echo "PROGRESS:30" sleep 1 echo " Build Start " Sleep 3 echo "DETAILS:SHOW" Sleep 2 # Check for Source files exist or not. #---------------------------------------- if [ ! -f $srcDir/BaseSystem.dmg ]; then # Check for BaseSystem.dmg echo "Downloading: BaseSystem.dmg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/BaseSystem.dmg" -o "/Private/tmp/src/BaseSystem.dmg" echo "Download: Complete ➣ Done!" fi echo "PROGRESS:40" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/BaseSystem.chunklist ]; then # Check for BaseSystem.chunklist echo "Downloading: BaseSystem.chunklist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/BaseSystem.chunklist" -o "/Private/tmp/src/BaseSystem.chunklist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:50" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/InstallInfo.plist ]; then # Check for InstallInfo.plist echo "Downloading: InstallInfo.plist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/InstallInfo.plist" -o "/Private/tmp/src/InstallInfo.plist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:60" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/InstallESDDmg.pkg ]; then # Check for InstallESDDmg.pkg echo "Downloading: InstallESDDmg.pkg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/InstallESDDmg.pkg" -o "/Private/tmp/src/InstallESDDmg.pkg" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:70" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/AppleDiagnostics.dmg ]; then # Check for AppleDiagnostics.dmg echo "Downloading: AppleDiagnostics.dmg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/AppleDiagnostics.dmg" -o "/Private/tmp/src/AppleDiagnostics.dmg" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:80" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/AppleDiagnostics.chunklist ]; then # Check for AppleDiagnostics.chunklist echo "Downloading: AppleDiagnostics.chunklist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/AppleDiagnostics.chunklist" -o "/Private/tmp/src/AppleDiagnostics.chunklist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:90" sleep 1 echo "DETAILS:SHOW" Sleep 2 # Taking ownership of downloaded files #------------------------------------------------- chmod a+x /Private/tmp/src/BaseSystem.dmg chmod a+x /Private/tmp/src/BaseSystem.chunklist chmod a+x /Private/tmp/src/InstallInfo.plist chmod a+x /Private/tmp/src/InstallESDDmg.pkg chmod a+x /Private/tmp/src/AppleDiagnostics.dmg chmod a+x /Private/tmp/src/AppleDiagnostics.chunklist # Mount 'BaseSystem.dmg' #------------------------- $(hdiutil attach /Private/tmp/src/BaseSystem.dmg -noverify -nobrowse 2>&1 >/dev/null) echo "Make sure \"macOS Base System\" volume is mounted" Sleep 3 # Pull 'Install macOS XXXX.app' from 'BaseSystem.dmg' #----------------------------------------------------- findApp(){ for file in "${MOUNTPOINT}"/*; do # Find XXXX.app in mounted volume if [[ $file == *.app ]]; then let index=${#name_array[@]} name_array[$index]="${file##*/}" fi done echo ${name_array[0]} } installAppName=$(findApp) printf "\n\nCopying $installAppName to out folder...\n" cp -R "${MOUNTPOINT}/$installAppName" /Private/tmp # UnMount 'BaseSystem.dmg' #------------------------- $(hdiutil detach "${MOUNTPOINT}" 2>&1 >/dev/null) printf "Copying Files to SharedSupport folder... Wait!\n" sleep 3 echo "DETAILS:HIDE" sleep 1 # Create SharedSupport folder inside 'Install macOS XXXX.app/Contents' #---------------------------------------------------------------------- SharedSupportDir="/Private/tmp/$installAppName/Contents/SharedSupport" if [ ! -d "$SharedSupportDir" ]; then mkdir "$SharedSupportDir"; fi # Copy All contents of src folder to 'Install macOS XXXX.app/Contents/SharedSupport' #---------------------------------------------------------------------- # cp -R /Private/tmp/src/* /Private/tmp/Install\ macOS\ Mojave\ Beta.app/Contents/SharedSupport cp -R "/Private/tmp/src/BaseSystem.dmg" "$SharedSupportDir" cp -R "/Private/tmp/src/BaseSystem.chunklist" "$SharedSupportDir" cp -R "/Private/tmp/src/InstallInfo.plist" "$SharedSupportDir" cp -R "/Private/tmp/src/InstallESDDmg.pkg" "$SharedSupportDir/InstallESD.dmg" cp -R "/Private/tmp/src/AppleDiagnostics.dmg" "$SharedSupportDir" cp -R "/Private/tmp/src/AppleDiagnostics.chunklist" "$SharedSupportDir" # Replace <string>InstallESDDmg.pkg</string> to <string>InstallESD.dmg</string> in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/<string>InstallESDDmg.pkg<\/string>/<string>InstallESD.dmg<\/string>/g' "$SharedSupportDir/InstallInfo.plist" # Remove these lines from 'src/InstallInfo.plist' #------------------------------------------------ # <key>chunklistURL</key> # <string>InstallESDDmg.chunklist</string> # <key>chunklistid</key> # <string>com.apple.chunklist.InstallESDDmg</string> sed -i "" '30,33d' "$SharedSupportDir/InstallInfo.plist" # Replace <string>com.apple.pkg.InstallESDDmg</string> to <string>com.apple.dmg.InstallESD</string> in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/<string>com.apple.pkg.InstallESDDmg<\/string>/<string>com.apple.dmg.InstallESD<\/string>/g' "$SharedSupportDir/InstallInfo.plist" # Replace InstallESDDmg.pkg to InstallESD.dmg in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/InstallESDDmg.pkg/InstallESD.dmg/g' "$SharedSupportDir/InstallInfo.plist" echo "PROGRESS:95" sleep 1 echo "DETAILS:SHOW" Sleep 2 mkdir -p /$HOME/Desktop/makeLegitApp Sleep 1 mv /Private/tmp/"{APPNAME}.app" $HOME/Desktop/makeLegitApp/"{APPNAME}.app" echo $current_date_time; sleep 1 Open /$HOME/Desktop/makeLegitApp sleep 2 osascript <<EOF tell application "makeLegitApp.app" activate end tell EOF echo "DETAILS:HIDE" sleep 1 echo "Build {APPNAME}.app ➣ Done" echo "PROGRESS:100"
  25. Yes, I used nv_disable=1. I wonder if I can add that to boot-args in defaults instead? Ok, I tried with the defaults posted above and updated values from clover configurator. I will post Defaults again when I'm home. Thank you! I apparently remembered wrong, I meant "BIOS Features" and not System... :S These settings look pretty much like optimized defaults, I have followed the instruction from the wiki and tried changing stuff with init first GPU and UEFI/Legacy for GPU, but that info might not be applicable anymore.
  1. Load more activity
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×