Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. i think i have to install again on m2.ssd and dual boot from there? maybe.... i'm waiting for the new amd graphics card to change my 1070..... wait or no?
  3. CMMChris

    AMD Radeon Vii in macOS Mojave

    @ITzTravelInTime No, this iMac uses the 9900K with IGPU. The SMBIOS is totally optimized for IGPU rendering which is a shame because IGPU is slower than RX580 encoders. Thus for Hackintoshes it is the best to turn IGPU off and use iMacPro1,1 for best performance. Otherwise encoding will be done by IGPU. @Picasso Something is wrong with your configuration then. Otherwise it would work. Please make sure you have renamed your ACPI devices properly.
  4. - Mobo: Supermicro X10DAI- CPU: Dual 14 core Xeon E5-2690v4- Graphics: Radeon Vega Frontier- Crucial MX500 500GB as a boot drive- Mojave 10.14.5Everything works fluidly expect the sleep. I did a clean install of Mojave on my Hackintosh (and updated to 10.14.5). Everything seems to be working as far as I can tell, except when the system wakes from sleep, it causes a restart. Not critical for functionality, of course, but frustrating nonetheless. (Putting the computer to sleep, as well as shutting it down, is not an issue.)I worked with @MaLd0n to solve the sleep problems and we reached a dead end that is why I'm asking for help.What I did:1- I unlocked MSR registers to have native power management.2- I mod my bios to get full NVMe support using this GuideWhat @MaLd0n helped me with:1- fixing my DSDT file and added the proper patches.2- adding my devices to the PCI list.3- Add plug-in type in DSDT, so we can remove SSDT for pm.4- testing all the darkwake=10 boot config.5- Patch DSDT with following patches Code: -FIX ERRORS AND WARNINGS -HPET -SATA -sSATA -DMAC -SLPB -DARWIN -LPC -XHCI -EHCI -PLUGIN TYPE -ALZA to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN #1 -LAN #2 -SPSR -WIFI -EC -PNLF -HDMI -NVME If someone can have look in my debug files and maybe point me in what I'm missing I will be super grateful.I can provide any extra debug files if needed. Send me Idriss-iMac-Pro.lan.zip
  5. balag59

    AppleALC — dynamic AppleHDA patching

    Hi, Here are my laptop specs: HP Spectre X360(2015) Intel Core i7 5500u + Intel HD Graphics 5500 I think my soundcard is Realtek ALC 286(not sure though). I've installed Lilu and AppleALC kexts to L/E(repaired permissions and rebuilt kext cache). My audio devices tab under Hackingtool is completely empty as shown below: A search for HDEF turns up empty in IORegisteryExplorer as expected(see below). But the funny thing is that I can find HDEF in MaciASL( can't find HDAS or AZAL).(see below) Here is a copy of my debug report. I can get the sound to work only via bluetooth and internal speakers and normal headphones don't work. I was told that I would require some form of DSDT patching and this is the best place to find some help with that. I would appreciate any guidance on this matter. Please let me know if you need anything else from me. Thanks in advance! debug_10688.zip
  6. ---------------------------------------------------------------------------- UPDATE 2 - [SOLVED!] ---------------------------------------------------------------------------- So the problem seems to lie within whatever version ApfsDriverLoader-64.efi I was using prior to update, or perhaps the OS needed to load one last time to enable some sort of permission for accessing the apfs.efi file from the /usr/standalone/i386/ folder that I am unaware of??? Either way, I am marking this solved at this point- just update your ApfsDriverLoader-64.efi in your drivers64UEFI folder with the latest (2.0.7 release as of this post) https://github.com/acidanthera/AppleSupportPkg/releases I just dumped all the files in the Driver folder within the latest zip into my drivers64UEFI and removed apfs.efi from my previous "Update 1" edit, and it booted with no issues.
  7. OK, so based on Apple's EULA only Snow Leopard Server can be virtualised so the functionality is disabled in Workstation. However Donk removed the functionality to support Snow Leopard Workstation in the latest unlocker 302, but a separate utility is available to allow Snow Leopard Workstation to install and run, see link to thread below:
  8. Today
  9. MacFriedIntel

    OpenCore Discussion

    Clover is full of broken code and bloated, OC is a fresh approach to a Bootloader which is based mostly from the Osmosis Bootloader. Opencore is lightweight and only uses drivers and kexts and patches you put into the config.plist. The Manual gives clear instructions and is constantly updated.
  10. There's no need to duplicate your script for the "Beta" and "Release" statement. #!/bin/bash # Vars apptitle="makeLegitApp" version="1.1" # Set Icon directory and file iconfile="/System/Library/CoreServices/Installer.app/Contents/Resources/Installer.icns" current_date_time="`date "+%Y-%m-%d %H:%M:%S"`"; echo $current_date_time; echo "Starting makeLegitApp" # Select response=$(osascript -e 'tell app "System Events" to display dialog "Welcome makeLegitApp Select a choice to create your Install macOS Mojave.app" buttons {"Cancel","Beta","Release"} default button 3 with title "'"$apptitle"' '"$version"'" with icon POSIX file "'"$iconfile"'" ') action=$(echo $response | cut -d ':' -f2) # Exit if Canceled if [ "$action" == "Cancel" ] ; then osascript -e 'display notification "Program closing" with title "'"$apptitle"'" subtitle "User cancelled"' echo "User cancelled" exit 0 fi # Conditions based on user's selection if [ "$action" == "Beta" ] ; then APPNAME="Install macOS Mojave Beta" MOUNTPOINT="/Volumes/OS X Base System" URL_PATH="34/47/041-03369/rsbnsn82mun7a480ipgu4r7inb0307i5sq" else # We can only assume that the user selected "Release" ... APPNAME="Install macOS Mojave" MOUNTPOINT="/Volumes/macOS Base System" URL_PATH="21/07/041-59913/m210y0lkn7bsiqsi98vfuyk08x2z4to1qk" fi osascript -e 'display notification "Program makeLegitApp" with title "'"$apptitle"'" subtitle "User Selected '"$action"'"' Sleep 1 # Remove BUILD if exist if [ "/Private/tmp/src" ]; then rm -rf "/Private/tmp/src" fi if [ "/Private/tmp/Install macOS Mojave Beta.app" ]; then rm -rf "/Private/tmp/Install macOS Mojave Beta.app" fi if [ "/Private/tmp/Install macOS Mojave.app" ]; then rm -rf "/Private/tmp/Install macOS Mojave.app" fi if [ "/$HOME/Desktop/makeLegitApp" ]; then rm -rf "/$HOME/Desktop/makeLegitApp" fi osascript <<EOF tell application "makeLegitApp.app" activate end tell EOF # Root location of file #-------------------------- srcDir="/Private/tmp/src" # Create Source folder #---------------------- mkdir -p /Private/tmp/src echo "PROGRESS:0" echo "Build Install ${APPNAME}.app" sleep 1 printf "${RED}Script created by Hanger1${NC}\n" printf "${GREEN}Script adapt and modify by chris1111${NC}\n" printf "${GREEN}Spacial thanks to @fusion71au from insanelymac for guide.${NC}\n\n" printf "Download following files from Orignal Apple server\n\n" printf "1) BaseSystem.dmg\n" printf "2) BaseSystem.chunklist\n" printf "3) InstallInfo.plist\n" printf "4) InstallESDDmg.pkg\n" printf "5) AppleDiagnostics.dmg\n" printf "6) AppleDiagnostics.chunklist\n\n" printf "${BLUE}Catalog link: https://swscan.apple.com/content/catalogs/others/index-10.14seed-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz${NC}\n" printf "\n\nPut Above files into \"src\" folder\n\n\n" Sleep 3 echo "PROGRESS:10" sleep 1 echo "PROGRESS:20" sleep 1 echo " " sleep 1 echo "PROGRESS:30" sleep 1 echo " Build Start " Sleep 3 echo "DETAILS:SHOW" Sleep 2 # Check for Source files exist or not. #---------------------------------------- if [ ! -f $srcDir/BaseSystem.dmg ]; then # Check for BaseSystem.dmg echo "Downloading: BaseSystem.dmg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/BaseSystem.dmg" -o "/Private/tmp/src/BaseSystem.dmg" echo "Download: Complete ➣ Done!" fi echo "PROGRESS:40" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/BaseSystem.chunklist ]; then # Check for BaseSystem.chunklist echo "Downloading: BaseSystem.chunklist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/BaseSystem.chunklist" -o "/Private/tmp/src/BaseSystem.chunklist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:50" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/InstallInfo.plist ]; then # Check for InstallInfo.plist echo "Downloading: InstallInfo.plist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/InstallInfo.plist" -o "/Private/tmp/src/InstallInfo.plist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:60" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/InstallESDDmg.pkg ]; then # Check for InstallESDDmg.pkg echo "Downloading: InstallESDDmg.pkg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/InstallESDDmg.pkg" -o "/Private/tmp/src/InstallESDDmg.pkg" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:70" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/AppleDiagnostics.dmg ]; then # Check for AppleDiagnostics.dmg echo "Downloading: AppleDiagnostics.dmg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/AppleDiagnostics.dmg" -o "/Private/tmp/src/AppleDiagnostics.dmg" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:80" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/AppleDiagnostics.chunklist ]; then # Check for AppleDiagnostics.chunklist echo "Downloading: AppleDiagnostics.chunklist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/AppleDiagnostics.chunklist" -o "/Private/tmp/src/AppleDiagnostics.chunklist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:90" sleep 1 echo "DETAILS:SHOW" Sleep 2 # Taking ownership of downloaded files #------------------------------------------------- chmod a+x /Private/tmp/src/BaseSystem.dmg chmod a+x /Private/tmp/src/BaseSystem.chunklist chmod a+x /Private/tmp/src/InstallInfo.plist chmod a+x /Private/tmp/src/InstallESDDmg.pkg chmod a+x /Private/tmp/src/AppleDiagnostics.dmg chmod a+x /Private/tmp/src/AppleDiagnostics.chunklist # Mount 'BaseSystem.dmg' #------------------------- $(hdiutil attach /Private/tmp/src/BaseSystem.dmg -noverify -nobrowse 2>&1 >/dev/null) echo "Make sure \"macOS Base System\" volume is mounted" Sleep 3 # Pull 'Install macOS XXXX.app' from 'BaseSystem.dmg' #----------------------------------------------------- findApp(){ for file in "${MOUNTPOINT}"/*; do # Find XXXX.app in mounted volume if [[ $file == *.app ]]; then let index=${#name_array[@]} name_array[$index]="${file##*/}" fi done echo ${name_array[0]} } installAppName=$(findApp) printf "\n\nCopying $installAppName to out folder...\n" cp -R "${MOUNTPOINT}/$installAppName" /Private/tmp # UnMount 'BaseSystem.dmg' #------------------------- $(hdiutil detach "${MOUNTPOINT}" 2>&1 >/dev/null) printf "Copying Files to SharedSupport folder... Wait!\n" sleep 3 echo "DETAILS:HIDE" sleep 1 # Create SharedSupport folder inside 'Install macOS XXXX.app/Contents' #---------------------------------------------------------------------- SharedSupportDir="/Private/tmp/$installAppName/Contents/SharedSupport" if [ ! -d "$SharedSupportDir" ]; then mkdir "$SharedSupportDir"; fi # Copy All contents of src folder to 'Install macOS XXXX.app/Contents/SharedSupport' #---------------------------------------------------------------------- # cp -R /Private/tmp/src/* /Private/tmp/Install\ macOS\ Mojave\ Beta.app/Contents/SharedSupport cp -R "/Private/tmp/src/BaseSystem.dmg" "$SharedSupportDir" cp -R "/Private/tmp/src/BaseSystem.chunklist" "$SharedSupportDir" cp -R "/Private/tmp/src/InstallInfo.plist" "$SharedSupportDir" cp -R "/Private/tmp/src/InstallESDDmg.pkg" "$SharedSupportDir/InstallESD.dmg" cp -R "/Private/tmp/src/AppleDiagnostics.dmg" "$SharedSupportDir" cp -R "/Private/tmp/src/AppleDiagnostics.chunklist" "$SharedSupportDir" # Replace <string>InstallESDDmg.pkg</string> to <string>InstallESD.dmg</string> in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/<string>InstallESDDmg.pkg<\/string>/<string>InstallESD.dmg<\/string>/g' "$SharedSupportDir/InstallInfo.plist" # Remove these lines from 'src/InstallInfo.plist' #------------------------------------------------ # <key>chunklistURL</key> # <string>InstallESDDmg.chunklist</string> # <key>chunklistid</key> # <string>com.apple.chunklist.InstallESDDmg</string> sed -i "" '30,33d' "$SharedSupportDir/InstallInfo.plist" # Replace <string>com.apple.pkg.InstallESDDmg</string> to <string>com.apple.dmg.InstallESD</string> in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/<string>com.apple.pkg.InstallESDDmg<\/string>/<string>com.apple.dmg.InstallESD<\/string>/g' "$SharedSupportDir/InstallInfo.plist" # Replace InstallESDDmg.pkg to InstallESD.dmg in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/InstallESDDmg.pkg/InstallESD.dmg/g' "$SharedSupportDir/InstallInfo.plist" echo "PROGRESS:95" sleep 1 echo "DETAILS:SHOW" Sleep 2 mkdir -p /$HOME/Desktop/makeLegitApp Sleep 1 mv /Private/tmp/"{APPNAME}.app" $HOME/Desktop/makeLegitApp/"{APPNAME}.app" echo $current_date_time; sleep 1 Open /$HOME/Desktop/makeLegitApp sleep 2 osascript <<EOF tell application "makeLegitApp.app" activate end tell EOF echo "DETAILS:HIDE" sleep 1 echo "Build {APPNAME}.app ➣ Done" echo "PROGRESS:100"
  11. Yes, I used nv_disable=1. I wonder if I can add that to boot-args in defaults instead? Ok, I tried with the defaults posted above and updated values from clover configurator. I will post Defaults again when I'm home. Thank you! I apparently remembered wrong, I meant "BIOS Features" and not System... :S These settings look pretty much like optimized defaults, I have followed the instruction from the wiki and tried changing stuff with init first GPU and UEFI/Legacy for GPU, but that info might not be applicable anymore.
  12. AlMoselly

    HP EliteBook 840 G3 / macOS Mojave

    I hope this will help SysInfo02.txt
  13. SardusX86

    Clover Themes

    Hi All, Is this version of the "embedded" Clover theme available for download? Thanks in advance for Your reply
  14. Hello I think these are ASMedia USB ports it's not a problem, it's going to stay that way thanks for your help
  15. [SOLVED TEMPORARILY - SEE END OF POST] Upgrading from Mojave 10.14.4, I did not make any changes to my Clover EFI folder. The version BEFORE upgrade was r4920, and latest necessary kexts to boot 10.14.5 were already installed and working for me on 10.14.4, so everything was ready to go. 10.14.4 worked fine with no issues for a while now, with the latest Clover and kexts. Upon installing macOS update, after completing the grey progress bar / apple logo screen, the computer rebooted and now Clover is not loading, and I am greeted with this screen: It's just a black screen with a solid cursor. No mouse input, no keyboard input, nothing else loads. Left it there for a while- no progress. to be clear: CLOVER DOES NOT LOAD if I select the UEFI 'Clover HDD' entry on my boot selection list. it shows the screen above I then created a bootable USB via my hackintosh laptop using the Mojave Installer and installed Clover UEFI on the ESP of the bootable USB, and then overwrote the EFI folder with my known good EFI folder backup. result: CLOVER DOES NOT LOAD if I select 'UEFI: Bootable USB' entry on my boot selection list. it shows the same screen above. I then attempted to create a bootable legacy CLOVER USB via windows: result: CLOVER BOOTS as LEGACY USB. The resulting Clover is indeed r4920 as it should be, but it does NOT list any of the MacOS partitions, I am trying now again with APFS loader for legacy . I cannot boot into UEFI Shell either on USB or on Clover drive. I tried EasyUEFI to redirect the UEFI entries to the SHELL-X64.efi file so that I can perhaps inspect the UEFI boot table to see if there is something wrong: result: Shell does not boot. Same screen as above. What is the possibility that the UEFI table in my bios suddenly corrupted? If possible, why does my Windows Boot Manager entry seem to work fine? Anyone ever experience something similar? ---------------------------------------------------------------------------- [SOLVED TEMPORARILY] The problem lies with ApfsDriverLoader.efi I managed to fix the issue by doing the following: Boot into Windows 10 Used UFS Explorer Standard Trial version to browse the newly updated, but unbootable MacOS 10.14.5 to retrieve the apfs.efi file from /usr/standalone/i386/apfs.efi Used Explorer++ opened with Administrator Privileges to access EFI partition on MacOS drive: Remove ApfsDriverLoader.efi Replace with apfs.efi from macOS drive in previous step. Reboot using MacOS EFI partition that was just modified Successfully booted and typed this post update It seems there may be an issue with ApfsDriverLoader-64.efi. Has anyone experienced anything similar? I am going to try again now with the latest version, which I believe I tried already- but perhaps it needed to do one final last load for some reason before being able to use the loader file and report back.
  16. Anyone updated to 10.14.5 ? This will be my first update so want to make sure I don’t miss anything. Clover and kext update first needed?
  17. I also ran into the same problem with sound when I tested EFI folder on a test install of macOS, the solution I found was to update config.plist with a new pciidevices.plist export and sound was resolved.
  18. Juvanta

    Donation related query

    Thanks for sharing
  19. Is this error going to be fixed in script? Status: gettext-latest.tar.xz not found. % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:-- 0 curl: (22) The requested URL returned error: 404 Not Found
  20. @BSouza Tutorial will work with i7-9700k
  21. Matgen84

    Clover problems report & features request

    Hi @Slice Clover r4928: I've a problem with Windows partition name (see pictures below). One in french language: é is not recognized, another is blank no name at all. I don't understand why?
  22. Very interesting, but I can't access the internet. I can't even install my network driver. Can you help me?
  23. telepati

    Clover General discussion

    @Sherlocks why are you using i7 for 9900K? Isn't this i9?
  24. telepati

    OpenCore Discussion

    What are the differences, OC and Clover? And what are the benefits of the OC?
  25. telepati

    Mac'os Mojave 10.14.5 is OuT

    It is common problem who update to 10.14.5 and no fix yet.
  26. Yesterday
  27. BWR

    APFS support is coming!

    Any Updates? I am still not seeing any code submitted to forge.voodooprojects for any APFS read support.
  1. Load more activity
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×