Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. jsl2000

    [pre-release] macOS Mojave 10.14.5

    I think Apple had changed Intel/Nvidia/AMD related graphics kexts during the update which resulted in some incompatibility of video play with Firefox and Safari browsers.
  3. Hi guys, My build is: i5-8500, Gigabyte z370n wifi (ALC1220) and the rest can be seen here: https://pcpartpicker.com/list/mXqNtg I've followed this post to install Mojave: everything was working very good using BIOS F1! last week received an update to OSx now when wake up from sleep - I have no sound. a reboot fixes the issue immediately. Any ideas how to solve that?
  4. Today
  5. corint1

    AMD Radeon Vii in macOS Mojave

  6. @LeonPhythian inside the patch-nvme-master folder
  7. IMPORTANT: I COPIED THE ENTIRE FORMATTING FROM rtke333 ! ACER LAPTOP R5-571T-59DC Mobo: Not Sure Bios: Not Sure CPU: Intel Core i5 6200U (2.30 GHz) (Skylake) GPU: Intel HD 520 Ram: 8 GB DDR4 (One 8GB Stick) Wifi: Qualcomm Atheros QCNFA344A Ethernet: USB Wifi Adapter Amazon Link Audio: ALC255 Card Reader: Realtek HDD: 120GB Samsung EVO SSD Working: Apple Appstore Integrated webcam (native) Touchpad and Keyboard: Touchpad doesn't work with gestures. Touchscreen Not working: Original Wi-Fi: Qualcomm Atheros QCNFA344A unsupported. iMessage Card Reader: Unsupported Audio: ALC255 Battery Indicator Brightness: Seems to be at 50% brightness. Haven't Tested: Facetime iCloud HDMI Port Audio/Mic Ports USB-C Port For WiFi: You can choose an external USB WiFi dongle (EX: TP-Link Archer T1U (5GHz support), TP-Link have official macOS drivers. (OR) Replace your M.2 Qualcomm Card with a compatible BCM94352Z card. Current Goals: Get a BCM94352Z Card and/or USB WiFi. (Not sure if internal wifi is needed for iMessage functionality) Get Audio working. Get iMessage working. If you have any suggestions or any ideas to help me continue to make my Hackintosh better, please let me know.
  8. Wackymac

    [pre-release] macOS Mojave 10.14.5

    so strange, how something so random can break on an update...
  9. LeonPhythian

    Patch for using NVMe under macOS Sierra is ready.

    Have a question I followed this...sort of to create a patch and help my OS (EL Capitan) see my NVM e drive, I got this message in Terminal ... Leons-MacBook-Pro:patch-nvme.git Drex-Guru$ ./patch_nvme.sh Determined patch automatically from vanilla IONVMeFamily: 10_11_6_15G22010 Creating patched HackrNVMeFamily-10_11_6_15G22010.kext from /System/Library/Extensions/IONVMeFamily.kext Vanilla MD5 matches expected MD5 entry (9b1349964b4d0d757c35189ca9f6ea9a) Patched MD5 matches expected MD5 entry (d2d5c10907bf0d159d58e496b48d245e) Leons-MacBook-Pro:patch-nvme.git Drex-Guru$ so ....well, where is the created patch to pop into Kext Utility? please excuse my ignorance I'm spinning here my drive died the other day and I have a major hand in next week that my lap top simply will not edit. I am by no means a programmer, and this might as well be in Martian. Kind regards, Leon.
  10. 38nic

    Mojave su pc in firma

    Inoltre spegnendo si ravvia e al desktop da un messaggio che il pc si é spento in modo inatteso..
  11. I haven't ever tried Sierra on this laptop, only Mojave but here is my latest clover HP_840_g3.zip
  12. 38nic

    Mojave su pc in firma

    ok, fatto, stesso risultato, pc non si spegne e appena stacco fisicamente la chiavetta usb del wifi si ravvia..posto nuovamente la cartella CLOVER (EFI troppo pesante).. Grazie Nic CLOVER.zip
  13. I made exactly the same mistake. Honestly, just gently bend the overlapping metal back out - it doesn't seem to make any difference to how the port actually works.
  14. Yesterday
  15. jsl2000

    [pre-release] macOS Mojave 10.14.5

    My Z370 & Z87 hackintoshs had the same issue with Firefox and Safari in which green screen interfered video play, but audio output was normal. No such an issue with Google Chrome or at 10.14.5 beta2. GPU GTX-680, GT-730, Intel HD 4600 & Intel UHD 630 were involved. No problem in P6TSE hackintosh with R9 290X GPU alone. I'll check whether it can be fixed by different versions of Whatevergreen.kext or not. At present only roll-back to 10.14.5 beta2 can fix it now.
  16. Hello all. First up thank you Chris and everyone for this amazing resource. I've learned a ton about this installation through here and I think I'm pretty close to getting a successful install but I keep hitting the same brick wall. I've performed this 3 times over the last few days, erasing the SSD each time and re-creating the install media too. I created the installer USB using my existing Hackintosh. Does this matter? I followed the Tutorial_10.14.md on github and managed to get all the way through to the end of step 3 installing Mojave on a three year old DELL XPS 9550, i7 6700HQ, 16GB RAM, with 2.5inch Kingston SSD. Intel HD graphics 530. I connected to the internet and everything seemed to be working perfectly - please see attached image of completed install. I created the EFI folder on the system drive and copied across the clover file from the installer. The problem comes when I attempt to reboot and I get the dreaded runtime area allocation problem. I have attached this error and my memmap output. The error comes from when I try and boot off the internal SSD. At this point I've also tried booting off the USB installer again and failed. I've then edited the UEFI64 drives on that USB drive with all variables suggested within the readme file (CLOVER/drivers64UEFI/other) concerning this. I've also read the various suggestions in the 58 pages of this post and tried the suggestions where others have had success. I feel like there must be something obvious I've missed but I can't see it. BTW I have updated my BIOS to the latest version supplied in the repository. I have also adjusted all the settings in my BIOS as per the guidelines in the installation doc. I have a few questions: 1. Do you think the best option would be to use the slide value of 73 (I calculated this based on the two screenshot figures) together with the OsxAptioFixDrv2. Is this correct and how would I go about editing the config.plist and copying the driver files to that folder? Are you doing this within shell? 2. Do I need to clear my CMOS / Reload custom BIOS settings each time I want this USB stick to boot/make changes as one other person has suggested in this post. 3. Should I try an earlier BIOS 4. Should I try installing High Sierra or earlier? Are any earlier versions more likely to work? I'm currently running Yosemite on my desktop so El Capitan or higher would already be a step up for me! Many thanks for your help everyone
  17. C.Frio

    macOS 10.14 Mojave Betas (DP's)

    ola.. feito...apos uma odisseia nessa minha internet vaaaggaaarrroosaaa...e em hdd externo c.frio
  18. Set that up with Clover Configurator app: simply specify your desired default boot volume. It does not have to be the "last booted volume" at all. This presumes that the disk setup with Clover is your primary boot disk of course (BIOS boot order)...
  19. headkaze

    Pin Configurator

    Pin Configurator v2.1.7 Released - Updated audio codecs
  20. Thanks for the link to the guide. My audiocodecs.txt and DPCIManager show my codec as ALC1220, within the ALC1220 folder there are several layouts. Each I loaded one by one in Clover configurator Devices; (reboot, try the next one etc.) but none would enable sound in the Line Out (Front) of the back panel. I deleted my AppleALC.kext after exhausting those options just to see if that would make a difference, and redownloaded it into my Other kext folder on my EFI partition. No change. Some would disable Line Out altogether, some other layouts would show three Line Out options so I tried each one, unfortunately the wasn't any sound from the speakers either. Next I plan to boot into windows to verify that the output works and not a problem with the board itself. Interesting problem, as the OS sees them and otherwise all other audio works (Headphones, LG monitor). Update: I now have an option for "internal speakers" in the Sound/Output Pref pane. When I selected that, sound started coming from my speakers... not line out, but sound is there at least in some respect.
  21. Hi! I tried to search for this question but I've found nothing I have a Windows 10 desktop with two hard drives: one with Windows and another with Clover + Mac OS X (High Sierra, for the moment). Both systems are listed in Clover, so I usually boot with the Mac OS hard drive and I choose the system I want. I use Windows as main OS and Mac OS X for some tasks; the main one: as "compatibility tool" (like Microsoft now defines Internet Explorer ) to test my websites with Safari and/or with the iOS Simulator. My problem: I need to connect remotely to this computer with TeamViewer. Since I mainly use it with Windows, and Clover remembers the last OS I chose, I have no way to Wake-On-LAN and go to Mac OS X because I can connect only after the OS has started. I know I can set Mac OS X as default boot option, but since I use Windows in the 95% of my time with this desktop, I'd like to skip OS selection each time. I tried with AMT, but unfortunately the i5 CPU doesn't seem to support full KVM remote operations, so I can't see the boot process before OS starts Is there a way to modify the OS to boot with Clover from Windows? Thank you in advance
  22. brousseau6933

    [pre-release] macOS Mojave 10.14.5

    Known bug since beta 2 with AMD dGPU's. Same for me (purple lines before white flash) with RX560 or 580. But like @CMMChris told me, not a big deal...
  23. Thanks @Hervé. I'm still not entirely sure what the correct DevicePath for devices like RP08.PXSX should be. I'm guessing the path generated by gfxutil is correct so I'm currently using the same method. @glasgood @steve3d and others please try Hackintool v2.3.4 which will now export PCI info directly to Clover config.plist and dsl format. The dsl I'm generating will not compile to aml without modification so this obviously needs more work. Anyway I appreciate feedback on this.
  24. headkaze

    Hackintool v2.3.4

    Hackintool v2.3.1 Released - UI Updates Hackintool v2.3.2 Released - Monitor PCI hotplug Hackintool v2.3.3 Released - Extract DSDT (phpdev32) - Auto update PCIIDs (MuntashirAkon) - Export PCI list in JSON format Hackintool v2.3.4 Released - Updated audio codecs - Export PCI list in Clover and dsl format - Now dumps all ACPI tables and decompiles to dsl
  25. Meowthra

    Opcode Emulator (OPEMU) Plug-in Project

    How to support AMD: Migrate source code content to (opemu.c for AMD) Rebuild xnu
  26. El'Xsanori Leo

    Opcode Emulator (OPEMU) Plug-in Project

    Very good project! But does not work on my AMD RYZEN CPU running Mojave 10.14.4, I got KP while starting 32-bit apps (Maybe AMD or Mojave is not supported by this OPEMU? So, can you start supporting it? Or can you tell, how to make it work with AMD?)
  27. New approach. Changed SMBIOS to iMac17,1 just to get rid of error "iMacPro board-id is not compatible with Skylake processor" when generate SSDTCpuPm in SSDTPRGen.sh script. After that generated freqVectors without error for iMac17.1. Restarted with no FakeCPUID and only bootstrap patch. Unfortunately no XCPM and no FV. Any ideas? DarwinDump.zip
  28. apianti

    Clover General discussion

    fdisk440 is not needed because you can just use dd, which is already available, so I'm pretty sure that is just a script. You need to preserve the last 72 bytes of the master/partition boot record, the first 440 are for boot code and the last two are the bootable flag, 70 bytes give a description of the format of the disk/partition beyond that boot record sector. fdisk will just modify that information for the master boot record, (i.e. the four primary partitions for the disk). Because actually there is no such thing a FAT12/FAT16/FAT32 anymore it's actually VFAT and the number of total clusters determine the actual type that is used. So you had to reduce from 4096 to 2048 bytes per cluster to get less sectors per cluster giving you more clusters so that it probably became FAT32 like you specified instead of FAT16 like it would expect when being read after it checked the cluster count. FAT filesystems are not case sensitive. Yeah, I wouldn't really worry about the messages if you still have everything working, unless you have a really old machine I very much doubt it has LPC, let alone anything actually connected to it. Far more likely that it is using GPIO (i2c and SMBus) or SPI if it's newer. It's probably a bug in the beta, this frequently happens in the betas, at least the image is there and not just a black screen for the first part like last time.....
  1. Load more activity
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up