Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

All Activity

This stream auto-updates     

  1. Past hour
  2. Today
  3. Cheers, I had Lilu ver 1.2.3 there but had removed NvidiaGraphicsFixup as people were reporting it working well without it. I'll give 1.2.6 and 1.2.7 a try. Note since I rebooted, the problems hasn't cropped up again yet BUT I didn't try recreating the problem again.
  4. AGGIORNAMENTO: installato il kext passatomi da @gengik84 per il wifi in S/L/E: tutto ok. L'audio invece non viene rilevato. Per gli artefatti video, sto seguendo questo post: https://www.insanelymac.com/forum/topic/319112-hd3000-freezing-in-sierra/ Gli artefatti per ora si presentano alla schermata di login, sotto forma di tre linee nere orizzontali. Oppure c'è un ritardo nella comparsa della schermata di login. Ho aggiunto il flag a SLIDE=0, come suggerito nei primi post, ma al login il problema rimane. Non so se sarò in grado di provare la modifica consigliata in questo post: https://www.insanelymac.com/forum/topic/319112-hd3000-freezing-in-sierra/?do=findComment&comment=2354226
  5. HWSensors3

    Good. The following is working as well? public func temperature(_ unit: TemperatureUnit = .celsius) -> Double { var temperature: Double = 0 if let prop = IORegistryEntryCreateCFProperty(service, Key.Temperature.rawValue as CFString!, kCFAllocatorDefault, 0) { temperature = prop.takeUnretainedValue() as! Double / 100.0 } switch unit { case .celsius: // Do nothing - in Celsius by default // Must have complete switch though with executed command break case .fahrenheit: temperature = Battery.toFahrenheit(temperature) case .kelvin: temperature = Battery.toKelvin(temperature) } return ceil(temperature) } No optional value, just initialize the temperature variable. This framenwork was a swift 3.2 converted to 4 by me, also I've made similar corrections. Later I'll send to the mantainer a pull request with our changes. EDIT from the same dev I found this: https://github.com/beltex/SMCKit, later I'll take a look if there's something suitable for us.. EDIT II Slice please tell me if you have Xcode 9.3 ... some changes I want to do for newer version of Swift... a step to be ready for the incoming Swift 5
  6. How are you ? here is my another one , plese! https://drive.google.com/open?id=1xY1DOsUprcpfefIFfhNjpPj--iVb7c32
  7. I have no seen before your edited message. You can also avoid patched bios and use original one if now, you see in 0603 bios version new tab with cfg lock feature
  8. Cheers @fabiosun I will test further. Keep you updated when I have anything new. And once more thank's for your help.
  9. try to read from solution 2 of this thread I don't know if those Patches are working now in HS Also with latest clover you could achieve same result applying kernel patch fla on KernelXCPM But you have to test by yourself in your "unique" system!;) @SammlerG related Patches of solution two are usefull to have also cmotion undemotion and C3 set...but no difference in real use life
  10. HWSensors3

    Hi @vector sigma, I made the follow change compared to rev 121 public func temperature(_ unit: TemperatureUnit = .celsius) -> Double { var temperature: Double? if let prop = IORegistryEntryCreateCFProperty(service, Key.Temperature.rawValue as CFString!, kCFAllocatorDefault, 0) { temperature = prop.takeUnretainedValue() as! Double / 100.0 } else { temperature = 0 } switch unit { case .celsius: // Do nothing - in Celsius by default // Must have complete switch though with executed command break case .fahrenheit: temperature = Battery.toFahrenheit(temperature!) case .kelvin: temperature = Battery.toKelvin(temperature!) } return ceil(temperature!) } That way if prop=nil then temperature=0 It is not good way but the way there is no crash at as! unwrap. The better will be to keep temperature to be optional Double.
  11. Can you elaborate that a little bit further? I'm trusting you 100% @fabiosun but I thought that this patch was obsolete with the MSR 0Ex2 unlocked. And thank's for your help I really appreciate your input.
  12. you don't trust what i am saying to you from +++++++++++ stage....it is a different deal..not locked or not related..maybe xeon or not xeon related
  13. Yea I've just saw that in my bootlog. The funny thing is that I still can't boot without "xcpm_program_msrs (c) Pike R. Alpha-patch"?
  14. You suppose bad Now you MSR 0Ex2 is unlocked MSR_PMG_CST_CONFIG_CONTROL.......(0xE2) : 0x402 ------------------------------------------ - I/O MWAIT Redirection Enable......... : 1 (enabled, IO read of MSR(0xE4) mapped to MWAIT) - CFG Lock............................. : 0 (MSR not locked) in this condition you can try different way to achieve also c3 states...
  15. FileVault 2

    Accepted to 4445.
  16. There was a new tab in bios. So this is with MSR lock disabled in the new patched bios. But I suppose here was no change in MSR 0xE2? AppleIntelInfo.rtf config.plist Bootlog.rtf
  17. TINU: The macOS install media creation tool - Mac app

    for all of you guys: do you have suggestions for specific clover installer settings and config settings? i have to offer something which will work on most systems as pre-made clover templates
  18. ThunderBolt Drivers

    Unfortunately no: When a device is connected: IOPCITunnelL1Enable = false When a device is not connected: IOPCITunnelL1Enable = true However there are other missing entries that I'm trying to implement. One of the biggest differences is that Apple uses: Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If (OSDW ()) { If (Arg0 == ToUUID ("a0b5b7c6-1318-441c-b0c9-fe695eaf949b")) { Local0 = Package (0x02) { "PCIHotplugCapable", Zero } DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } Return (Zero) } While our SSDTs use: Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If (LNot (Arg2)) { Return (Buffer (One) { 0x03 }) } Return (Package (0x02) { "PCIHotplugCapable", One }) }
  19. FileVault 2

    Sources on their way. Seems like not much request for PS2 filevault anymore. Let's give it some time. I'm leaving in 3 hours for a month. I'll have my newly encrypted PS2 laptop with me, so I'll be the first tester of what I did. I'll be able to answer email, but not doing all what I can do on my desktop with a 4K screen and 56GB of memory !. If there is some interest in that, will see when I'm back. @Slice Thanks for having pointed me in the right direction in November. I tried Ps2MouseDxe-64.efi, but trackpad not working. I remember to have correct VoodooPS2Controller for my hackintosh 3 years ago. Looking into that I was able to correct Ps2MouseDxe-64.efi, but mouse pointer is moving very very very slow. Enough to click on the filevault user though. An other thing that will be finalize when I'll be back to my desktop computer. Just for information : I spent quite some time to setup source level debugging with eclipse and VMWare (see picture, when I was looking for a crash in Clover launched in VMWare. It's linux because of a bug in gdb mac.). That is so much easier than putting trace log everywhere ! So, if anyone interested I'll be happy to share to knowledge. The bug I found is : in smbios.c GetTableType16(), at the end, add : // VMWare report 64 memory slots !!! MAX_RAM_SLOTS is currently 24. Crash is PatchTable17. if ( TotalCount > MAX_RAM_SLOTS ) TotalCount = MAX_RAM_SLOTS;
  20. then post again Appleintelinfo output and your config.plist
  21. Hi if you want try to rename patched one according your flashback bios name and flash it if you want included original 0603 and patched one To start you can also visit issue section of UEFIPATCH GitHub and use one tool like UBU to separate bios sections and find correct location and fix.. not simple at all
  22. GTX 760 OpenCL

    OPenCL usage of OpenCL in real Apps - other than benches - is an addon. Means, the GPU (OpenCL) is used for some work, but not - as an cpu - for all work. So, the cpu has work to do - even OpenCL is working beside the cpu. Only on some OpenCL bench apps cpu load is less and GPU load maximum. On real Apps (video, etc) using OpenCL cpu load is at least medium to high - to do the main work and put work to gpu and receive results from the gpu. So CPU speed does matter / is under load even OpenCL is used.
  23. Thank's for your input @fabiosun. My system is rock solid for the moment with working sleep/wake. I will test more and see if I can fine-tune a little bit more. It should be very nice to have my MSR 0xE2 register unlocked from bios. Do you have any ideas how to do this. I used to use Ozmosis for many years so I have some experience in patching bios but I need to know what to do! Is there any guides out there?
  24. Try again I think it had to be OK'd by Mods. I just downloaded it and saw it.
  25. ThunderBolt Drivers

    Yes it might , but there are various other settings that are configured by the SSDT and loaded at startup. At this point we are trying with @lelet , @Matthew82 and others to improve and perform Hot-plug on all ports.
  26. Nice! Tempted to update my system couldn’t see the video
  1. Load more activity
×