Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


ALC888 Audio Tearing

3 posts in this topic

Recommended Posts

I'm using the Leo4all package on an AMD system (4400+ X2, 2GB RAM, NForce Chipset)

Whenever I play any audio, the sound keeps skipping and tearing. Any fixes?

The system profiler under 'Built in Audio' shows that there is no built in Audio.

Share this post

Link to post
Share on other sites

Well, the 2nd thing (display nothing in the systemprofiler) is normal.


You could search on the forum for the ALC888 driver (which works fine on my system). Use "kexthelper" which comes with Leo4All (afaik) to install this easily. Reboot and hope it works fine <_<


PS. Be sure you have exactly THIS chip!

Share this post

Link to post
Share on other sites

I'm absolutely certain i have an ALC888 chip. I've tried two distributions so far, Zephyroth and Leo4All. Choosing the ALC888 package during install in Zephyroth gives me kext loading error. However in Leo4all, choosing the ALC888 package makes the audio work fine. In Zephyroth, I did use the ALC888Audio.mpkg which I got from this forum, but still the same skipping / tearing problem exists.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.