Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Patcher gets stuck after SPDIF detection

3 posts in this topic

Recommended Posts

Sorry, I never would have thought this card had its own forum so I also posted this in the general SigmaTel thread.


I used PuppyLinux to get the attached dump, which works more than other dumps that I've tried but I'm still not having any success. I have a SigmaTel 9200 (HDAUDIO\FUNC_01&VEN_8384&DEV_7690&SUBSYS_102801C2&REV_1022) and when I throw this dump into the patcher, I get as far as:


Patching AppleHDA.kext to 0x83847690 Done

* Checking AppleHDA for patch Done

0001f4a7 cmpl $0x83847690,%eax

0002058b cmpl $0x83847690,%eax

* Checking for SPDIF Out Detected

* Checking for SPDIF In Not Detected


Using other dumps I've found, it won't even detect SPDIF Out. No matter what, it never progresses past this point.


Any ideas on how to fix this?


Other info:

I'm using Kalyway's Leopard

I've tried just about every recent version of the patcher, from 1.10 on

I'm on a Dell D620

I miss sound :blink:


Share this post

Link to post
Share on other sites
This specific issue is resolved: I had to move the codec dump off of my flash drive prior to running the patcher ;)


Thanks for sharing! I'm having the same issue... gonna try your solution now!


edit : yep, that was the problem ;)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.