Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Broadcom 440x & Leopard GM...

3 posts in this topic

Recommended Posts

Hey All,


Posting this from my shiny Leopard GM install using my Wireless LAN - Got to say, I love Leo so far!

I'm using a Dell Inspiron 6400 - well, if you can still call it that, i've replaced pretty much every component in it... even upgraded the CPU! Anyway Wireless Works (out of the Box - DW 1500), Sound Works after some removal of kexts, replacement of kexts etc. Graphics work (GMA 950), only problem I have is the Wired LAN.


Now my problem is the Broadcom 440x LAN - which has always seemed to just work "out of the box" for as long as I can remember under Tiger.


Unfortunately... there seems to be no support for it under Leopard I tried copying IONetworkingFamily.kext from 10.4.10 but that broke the wireless, tried copying just the BCM440x kext from the plugins folder of it to the plugins dir of the Leo IONetworkingFamily.kext... but that didn't fix it either - it was recognized, but didn't work it just said it was in an error state.


Any suggestions are much appreciated!



Share this post

Link to post
Share on other sites

Managed to solve my own problem... copied AppleBCM440XEthernet.kext from an older ( 10.4.8 ) IONetworkingFamily.kext to /System/Library/Extensions - not the plugins folder of the Leo IONetworkingFamily.kext as I did last time - repaired permissions and chown'd it.


Connected it to the LAN... still the same error state. Unloaded the kext and loaded it again... and now it works. Weird.


Bleh, the X key on my laptop keyboard is almost non-functional now! :thumbsup_anim:



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.