Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Broadcom bcm43xx wireless driver [beta]

860 posts in this topic

Recommended Posts

devs should help us to to find a way yo enable BCm43142 Wifi kext as this is a new card all  new lap top that has broadcom chip are coming with it and theres a lot of osx user who have that chip but nobody able to enable it they is a raw linux driver for Arch linux don't know if that can be helped https://bbs.archlinux.org/viewtopic.php?id=145884&p=2

i am not an expert on this area but guys who are expert should help us we made possible to boot OS X on IBM machine and this is just a wifi chip i am sure there is someone who can help us  :yes:  :yes:

who has this chip give a +1 for the post

we need your support for this guys  ^_^

Share this post

Link to post
Share on other sites



Hopefully you are still following this thread - Just turned my old laptop into a nice hackintosh for OS 10.5.

Unfortunately WiFi doesn't work. Did everything as described in the post but can't turn the card on. Also followed all the solutions you wrote.

Can't turn it on neither in the menu bar or in the WiFi settings.


Would really appreciate any help since I really need WiFi!


Regards from Vienna,



Btw: The enabler script made my audio work xD

Solved the problem.

WiFi was disabled in the BIOS, whyever.

Share this post

Link to post
Share on other sites

Hi all!


I have Powermac G5 Quad and try to install wifi card BCM94322HM8L with adapter PCI-E to miniPCI-e.


Mac OS 10.5.8 has native support to this card, but wifi not work - "Driver loaded: No". Whats problem?


Sorry for my bad english, im from russia.


I have the same problem. Gives a solution for this "PPC" problem?

Share this post

Link to post
Share on other sites

Guys, I tried everything here. 

My device is well listed (device ID) and everything should work but it does not.

My device is a belkin F5D7001 with Broadcom 4306...


I see it using DPCI manager.

However the wifi is not working. It keeps on searching.
I did all the "advices" under the first post... no luck.

I am testing this on 10.11. Is the issue coming from the OS version?

Which "updated" version of the OSX will it work. I am OK to downgrade...

Thanks for your time

Share this post

Link to post
Share on other sites

Some know issue on High Sierra :


Unable to have my BCM4311 working and the kext is loaded , strange :


Share this post

Link to post
Share on other sites



You need old BCM4311.kext and "Aerodrome2.app" to connect to Secure networks.

Thanks partial sucess : just enable conecting wifi on my box : i ' m working for... ;-)

Share this post

Link to post
Share on other sites

Not working : i removed it and put an half mini PCI-e Atheros AR5B97 AR9287 (168c 002e) : works fine.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.