Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

How I got AMD QE/CI Nvidia Jas 10.4.6 + 10.4.8 Update

1 post in this topic

Recommended Posts

This explains the process I took to get 10.4.8, Semthex 8.8.1 kernel, and Nvidia working.


Here is my hardware

Athlon 64 X2 3800 +

Nforce 410 mATX based motherboard

PCIe Geforce 7600GT


Here is what I started out with:


Jas 10.4.4 + 10.4.6 DVD installed


Here is what I used:


JaS.10.4.8.AMD.SSE3.Only.Combo.Update - to bring to sort-of 10.4.8

MAC OS X 10.4.8 Intel Only Jas re-seed - To obtain real 10.4.8 kexts and OpenGL Framework

Semthex kernel grabber script found HERE


Here is my process.


0. Installed JaS.10.4.8.AMD.SSE3.Only.Combo.Update onto my 10.4.6 install


1. I installed the real 10.4.8 Intel Only onto a real SSE3 Intel machine

- This was the easiest way for me to grab the folders




2. Set this install up as a slave drive on my AMD 10.4.6-> 10.4.8 sort-of machine and booted


3. Moved /System/Library/Extensions/ to /System/Library/Extensions.pre8/ and

/System/Library/Frameworks/OpenGL.framework/ to /System/Library/Frameworks/OpenGL.framework.pre8/


4. Copied Extensions folder from real 10.4.8 Intel install (slave drive) to /System/Library/Extensions

and OpenGL.framework from real 10.4.8 to /System/Library/Frameworks/OpenGL.framework/


5. Removed /System/Library/Extensions/AppleIntelCPUPowerManagement.kext as this will kernel dump

on AMD Cpus when trying to boot real 10.4.8 (8.8.1) Kernel


6. This step is only because I use an Nforce based motherboard and the kexts for the IDE controller

isn't included in the real 10.4.8 Intel Only. I deleted IOATAFamily.kext out of /System/Library/Extensions

and copied over the one from Extensions.pre8 ( this adds AppleGenericPCATA.kext in the Plugins in IOATA...)


7. Copied over other Extensions pertaining to 3rd party hardware.. Like I copied over forcedeath.kext from .pre8

to ensure networking still worked.


8. I installed Titan.kext into the Extensions folder


9. I followed the guide here: HERE to add my Video card VenID to the proper kexts in /System/Library/Extensions


10. I ran Semthex's kernel script to go grab the latest version of his kernel build and rebooted.


Came back up with QE/CI enabled on my PCIe Nvidia card running kernel 8.8.1.


Hope this helps some of you out there.



Edited by letni

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.