Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

usb audio not working alesis io 2

11 posts in this topic

Recommended Posts

i recently bought an alesis io 2 off ebay and it works great in xp but when in osx 10.4.7 hackintosh the audio is never recognised

but the midi function is recognised under the audio and midi setup panel (its an audio and midi usb sound card, the midi shows up but not the audio part)


i have other usb devices attached to the computer that all function properly and tried it with all of them removed but still only midi is being recognised

i've installed the soundblaster.usb.audio.support.pkg but it seems it hasn't done anything


the device is supported by os x and doesn't need any drivers and so far alesis haven't been able to help



anybody got any ideas? this is killing me now!

Edited by him

Share this post

Link to post
Share on other sites

got exactly the same problem on leopard - the card is detected in the sound properties

but it says it has no output or input controllers so you cant get any sound from any headphones you plug in


hopefully someone will post a solution here

Share this post

Link to post
Share on other sites

a) download the 10.4.9 combo update


:) MOUNT the 10.4.9 combo update (i.e. double click the dmg file)


c) download and launch Pacifist


d) choose the package INSIDE the mounted 10.4.9 combo update


e) navigate the 10.4.9 combo update file system to: System/Library/Extensions/AppleUSBAudio.kext


f) instal the AppleUSBAudio.kext by selecting this and only this kext and choosing Instal (when prompted, allow Pacifist to overwrite existing files). I made a backup of the existing kext just in case.


g) quit Pacifist


h) download and launch OnyX


i) on Startup, allow OnyX to perform verification tests


j) choose Cleaning (main menu)


k) choose Caches


l) in addition to selected items, select System and Kernel caches


m) choose Execute


n) choose Maintenance (main menu)


o) choose Optimize


p) choose Complete Optimization (this forces pre-binding)


q) choose Execute


r) quit OnyX


s) shutdown system


t) unplug USB Audio device


u) startup system


v) after startup completes, plug USB Audio device back in




Share this post

Link to post
Share on other sites

i followed the same operations having the same soundcard and it worked to me in my osx 10.4.10....maybe you have done something wrong...repeat the operations.

Share this post

Link to post
Share on other sites

just downloaded the tiger version of onyx and it has the extra features thats not in the leopard version gunna try it with this version of onyx and ill post once iv done



update - tried with tiger version of onyx and still doesnt work

Share this post

Link to post
Share on other sites

it just dawned on me ur using the 10.4.9 combo update - what if i use the 10.5.2 combo update instead ill try that and post back in abit



still dont work must be a problem with leopard - it detects the usb sound card just comes up saying theres no input/output controllers all the time so its useless

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.