Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[How To] Solutions for Video Problems

66 posts in this topic

Recommended Posts

Hello everyone. I am in the process of getting my Dell XPS to dual boot WinXP and Mac OS X . I have installed JAS 10.4.8 on my hard-drive and when it loads up I see the grey apple and the loading symbol and when it goes away the screen just stays blank white. Also I can hear music and I guy talkin in my USB headset about setting up my installation with voice commands. I am assuming that since I cant see anything that this might be a video issue. I have an ATI radeon 9800 XT and I dont see this specific card listed anywhere on the osx86 site. So I was wondering if katana or something would work and if so how I could install the drivers without being apple to get into the OS. I do have winXP working properly on another partition. Thanks in advance.




When you install OSX, don select any auxiliary graphic driver from the install list and then it should start with default resolution and no QI/CE. Like that you will be able to search for a compatible driver and to install it from GUI. However you can press F8 while darwin bootloader starts and then boot in single mode (type "-s" @ boot option) but you will get just a text terminal and it's not easy to debug from there your graphic driver.

Share this post

Link to post
Share on other sites

I have the (Club brand.) ATI x1950 pro with 250megs..


is there an easy (heh i know) way to have it working on leopard (from ToH rc3 flat image)..


I need to know which is the best for x1950 pro.. Boris/NeoPheus/Natit or other..


i'd appreciate the help!

Share this post

Link to post
Share on other sites

The Bronya 7280 id installer worked for me like charm..


Now i have qe/ci and full rez with all refreshes plus both dvi's ... damn thats wonderful !!!

Share this post

Link to post
Share on other sites

i have ati radeon hd2600 mobility in an acer travelmate 5720g. I have search in the forum but i don't have find a solution. What driver? I'm italian sorry for my english

Share this post

Link to post
Share on other sites

GEFORCE Series 8 solution!!! :D


Anyone who is having trouble getting an NVIDIA series 8 Geforce card to work should go to this site.




What I did was install Kelway 10.5.1 with Vanilla and no Video drivers, then ran the installer (v3.1 as of today) from normal OSX (running in default driver mode).


It worked like a charm.


I get full resolution, no "tearing or clipping" and HDTV looks awesome!


I have an 8600GT 256MB ram, but there are people reporting no problems with 8800GT/X etc etc with more RAM.


Woohoo! :thumbsup_anim:


I must have spent 4 hours looking for something.


People who have other problems may do well to check out ;


they have some great forums there also.


Cheers and Good luck!

Share this post

Link to post
Share on other sites

hey, i use an ATI radeon2600 HD mobility,

ive been told the card works with the 9200 (i think) drivers,

it does, but only when using an external moniter, not my laptop screen :)

we spent a long time getting this card to work, and its a bummer it doesnt work on my screen,

any solution that you know of?

thanks :D

Share this post

Link to post
Share on other sites

to_post_off.gif Jun 15 2007, 09:31 PM

Post <A title="Show the link to this post" onclick="link_to_post(386198); return false;" href="


midorihibiki pp-blank-thumb.pngrating_0_mini.gifgender_mystery.pngView Member Profile friend_add_small.pngAdd as Friend send_pm_small.pngSend Mssage find_posts.pngFind Member's Topics find_posts.pngFind Member's Posts ipsmenu.register( "post-member-386198", '', 'popmenubutton-new', 'popmenubutton-new-out' );


user-offline.png InsanelyMac Protégé




Group: Members

Posts: 1

Joined: 14-June 07

Member No.: 114,431



Hey after I had installed Mac OS X 10.4.8,everything was ok except few things bother me are:Sound onboard with Soundmax AC97,refresh rate.


Problem with sound that I have solved with help of topic 99% works with....... in this forum (I thanks so much for that ^^)


But now my last problem is how can I change my refresh rate.Current setting now is 1280x1024x32@60. I have read that can change at boot.list (sorry can't not remember clearly) by add key Graphic mode and key string and I type it excactly as this

<key>Graphic mode</key>

<string>1280x1024x32@85 </string>


(because my monitor can support that resolution & refresh rate) result is the resolution was changed like I want but the refresh rate was 60Hz.I can't make it higher to 85Hz.Anyone can help me with this,I thank so much !


My computer uses Pen4 Northwood no HT 2.4GHZ,Main P4P800-X,sound onboard AC 97 soundmax,512MB Ram,Ati Radeon 9550 GE 256MB.

Hope everyone can help me!



actually u can try using 60 hz refresh rate,normally lower hz the better..

Share this post

Link to post
Share on other sites

Hi, I'm loking for ATI Mobility Radeon xt 2400 hd (PCI\VEN_1002&DEV_94c8) solution for my Acer Aspire 4920 Gemstone...


Share this post

Link to post
Share on other sites

My GPU FAN is not running - kalyway 10.5.1

NVidia laptop (the one you can choose when installing Leopard kalyway 10.5.1 in setup).

GPU = Geforce Go 7900GS 256mb

look on signature...

plz help

Share this post

Link to post
Share on other sites
Is the only resolution the castillo v3 works with for the x200 is 1280 x 800 or can I get it to work with 1280 x 1024???? Because im going to attempt an install.
1280 x 1024 is supported without callisto :D so nothing stopping you from tryingI have an x200 card. Before installing callipso system profiler said i had 256 mb of VRAM. After installing it went down to 48... Can anything be done to shange this??? I tried watching a movie and it lagged horribly. I changed resolution from 1280x800 to 1280x786 and it worked just fine :D . But still lags on for example screen saver ;) is this because of the QE/CI issue or the low VRAM?

Share this post

Link to post
Share on other sites



im running leopard 10.5.2 with netkas 9.2.0 speedstep kernel and a nvidia geforce fx 5200 pci 128mb card and everything runs fine exept s-video/tv out, does anyone know a solution to this problem? ive tried nvinject, titan and natit none of them seems to work. help please!!!

Share this post

Link to post
Share on other sites

For all of you who have an Intel GMA 900 chipset, (like me on my Fujitsu Siemens Amilo M6450G) and the "Tricks" (2-Wire, 1-Wire) doesn't work when you have a blue screen on Boot / Install, try this:


It's a simply modified One-Wire Trick (IMHO wrong GND was used)


Simple make a connection between Pin 12 (Display Data Channel), and Pin 5 (Display Data Channel GND) and you should be able to start your hackintosh without an external Monitor.


One-Wire-Trick (doesn't work for me, I had to plug in ext. monitor):



Modified One-Wire-Trick (works fine for me):




Maybe somebody should add this to the Bluescreen solutions.

Share this post

Link to post
Share on other sites

A piece of software that should be part of this thread, that helped me with resolutions: DisplayConfigX. On 10.5.2 with an nVidia 7300GT on a GA-P35-DS3P, my second monitor is slightly defective and was not recognized. I was only able to drive it at 1600x1200. But DisplayConfigX let me whack up up to its native 1920x1200x32@60. In fact I have dual 1920x1200x32@60. Viewsonic Optiquest q241wb's with the PVA panel, before they did the switcheroo to TN panels like Westinghouse did. Says QE is supported. Am I missing something, what is the big fuss about QE, does it just help Time Machine look cool?

Share this post

Link to post
Share on other sites





This is a solution that I coded for people who when they run games can't see them because the screen goes blank (screen turns off , monitor goes black , etc) aka they have a x3100 graphics chipset and like what I have on my Dell Inspiron 1525.


The application is called GameSleepX, when you run it you have 20 seconds to start your game, then when the game starts you simply press the space bar on you keyboard wallah you screen is back up and ready to play those games. I created this because of a void that existed for our problem so please show you support buy emailing Cerieti@gmail.com to let me know if this has worked for you!


If your an avid game player you might want to add this app to your dock for quick access, now without further ado here is the link to the app ENJOY!


If the added file doesn't work you can download this app at my website address, just be sure to RIGHT CLICK AND SAVE AS






Atkos - Kalyway sleep/wake cycle resolution black out fix for Dell and any other computers with this problems


-Ariel Ruff

Cerieti ink

(We Do Not Condone Piracy)


Share this post

Link to post
Share on other sites

It should also be noted in this page (to avoid mountaints of topics about it) that up till today, most or all Sony VAIO laptops' internal screen will not work. Only two workarounds are:


1. do not install any video drivers (graphics performance will be terrible, no QE/CI, res stays at 1024x768) or

2. install a video driver and have an external monitor ready (kills portability, but have max res/QE/CI).


This has been an ongoing issue, and no solution exists as of yet. Some have speculated to be NVCAP's fault.


This should be noted at the top of the topic. Basically a "DO NOT BUY SONY VAIO, IF U DID, SELL IT AND GO TO THE WIKI TO SEE WHICH BRAND WORKS" kind of advertisement. :)


I should know. I own one. ;);;

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.