Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Mac 10.13.1 DSDT help needed

17 posts in this topic

Recommended Posts

I have an HP Elitebook 8460P running High Sierra 10.13.1


I'm trying to get battery status working and if I'm understanding it right I need to patch my DSDT.aml to get it working.

I have attempted this and can't seem to get it to compile, always an error. 


Also i have managed to brick the system a few times attempting edits. I cant seem to figure it out


I need to patch the DSDT to get battery status working even before patching, if attempting a compile with MaciASL I have 2 errors.


Im fairly new to getting Mac running on Intel Based PCs. 

any help would be greatly appreciated.


Attached is my DSDT.aml file pulled from: EFI/Clover/ACPI/origin/DSDT.aml 

generated by using clover bootloader help menu, via the F4 option. 


I used MaciASL to attempt the edits.

using battery patches from here: https://github.com/RehabMan/Laptop-DSDT-Patch


Is it possible for someone to patch the file for me, or is it something i have to do?

As i said im fairly new to mac and would like to get this working



Share this post

Link to post
Share on other sites

I installed the .Kext and put the DSDT in EFI/Clover/ACPI/patched/

I downloaded the newest kext. that had a high number of downloads. not sure if its the right one or what one i actually need.


Rebooted in verbose mode boot didnt hang but when getting to the system i still have no battery icon or battery detected.


attached in a pic of the battery settings...


am i doing something wrong or does it just not work?

do i need to do something special to load the modified dsdt or does it do it automatically when in the patched folder?



sorry for the stupid questions but im new to mac and have no clue what im doing.



Share this post

Link to post
Share on other sites

The kext is loaded correctly. Maybe, there something wrong in your DSDT. I don't have time to look at it right now.

Share this post

Link to post
Share on other sites

I rebooted again and I have the battery icon and no percentage using the first dsdt




ill try the second dsdt when I get back home.

I got working battery status with the second dsdt.


thank you very much.

Share this post

Link to post
Share on other sites



second test




good hack



Bad new. My battery percentage is gone! I dont know why or how.

Turned off the laptop was working, Next morning Turned back on... nothing.


Not sure if an update or something broke it but i have all automatic updates off i though.



Tried refreshing the origin dsdt files (f4 in clover), tried recopying the dsdt to patched in my efi.

Tried reinstalling the battery kexts.

Tried updating the os to 10.13.3 . (currently running this now if that makes a difference)


Still i have no battery percentage, everything else is working like it was before, just my battery is gone again. 



here is output of kextstat -i for the battery kext. not sure if it helps. but tell me what commands to run and i can post their outputs.



Share this post

Link to post
Share on other sites

I did try the newest kext, downloaded  RehabMan-Battery-2017-1001.zip   and still doesnt work...





I reinstalled macOS10.13.1 on another hdd.

got battery working and my sound, after a few reboots, its goes away again too. 

and so did my sound this time.

Share this post

Link to post
Share on other sites

New info:


This is what i have happening and can reproduce...



Boot > No battery icon > Install newest battery kext > Reboot > Have battery working > Shutdown > Boot > No Battery...


Then if i reinstall the kext, reboot, i have battery until i shutdown. then on next boot up i have no battery again. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.