Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Installing Kext on clover EFI

4 posts in this topic

Recommended Posts

Hi Everyone,


Hoping someone can help me, so i managed to update from sierra to high sierra on my hackintosh however, after the update installed my usb ports do not work so neither do my keyboard or mouse, now i know this is because i did not place the usb kext file into the efi clover folder, is there anyway to do this through the initial clover bootloader screen? or do i have to reinstall sierra again and go through the whole process, reason i dont want to do this is because i would have format the ssd and i did not back up some files which i dont want to lose, if any one can give me some advise please, id really appreciate it. Thanks.

Share this post

Link to post
Share on other sites

Hi Mkizle,


put the kext on a fat formatted usb pen-drive.

Boot to efi shell. Type something like that:

cp -r fsX:\name-of-usb.kext fs0:\EFI\Clover\kexts\Other

X has to be the number of your pen drive.



Share this post

Link to post
Share on other sites

  • Check BIOS settings (these names from a Gigabyte board): XHCI Mode=Smart Auto, EHCI Handoff=enabled, XHCI Handoff=enabled

On a 5-series board set FixUSB_1000 in config.plist (or Clover Configurator / ACPI / DSDT / Fix USB)

Try plugging into different USB ports. USB2 ports might be the best bet.

On P55/H55 boards, many things to try, no single solution for everyone:

  • Disabling USB3 in BIOS might help

Try these config.plist settings

Try in Clover Configurator / ACPI / DSDT check the box for Fix USB

Try using a completely different procedure

A compatible add-in USB2 PCI card is reported to work.

Using an external USB2 hub is reported to work.

There's this procedure to install with USB working

Edited by gengik84
Please read the rules. link removed

Share this post

Link to post
Share on other sites

Thanks for your answers, i found a way easier way to do it if you have windows running on the same machine also:


1) You dont need to install paragon HFS, just mount efi partition of disk, which is FAT32, unlike system itself...


1.1)run/open diskpart as admin (either from start or from cmd, or from windows(or system32) folder

1.2) In diskpart - list disk, then select disk X(use correct number)

1.3) In diskpart - list partition, then select partition X (correct number)

1.4) In diskpart - assign letter=x

1.5) Efi is now mounted, but explorer wont allow you open it(stupid windows rights). Open notepad AS ADMIN, File ->open ->navigate to efi/clover/kexts (yes, this will trick windows rights, lol)

1.6) Paste kext files (still in notepad open window)


The issue was that after the update it did not recognise the USB ports so nothing worked (keyboard / mouse), following the above steps i mounted the EFI and placed 


USBinjectall.kext into efi/clover/kexts/other


Rebooted the computer and the usb worked, so now i could use the keyboard and mouse and complete my set up.


Everything is now working apart from sound, but ill find a way to fix that as i have done before.

Can a moderator change the title to something more specific like "Installing Kext on clover EFI - USB not working after High Sierra Upgrade" thanks.

Just a note:


i did this in order to get FCPX 3D text working as on sierra it didnt, i installed the updated Web Drivers by NVIDIA and now everything is working perfectly.


for anyone wondering my set up is:


Intel Core i7-6700 Skylake

Asus H110M-A/M.2 Motherboard

NVIDIA GeForce GTX 1060 6GB

16GB DDR4 2133MHz

250GB SK hynix SL301 SSD (Windows)

Seagate 1TB BarraCuda (Extra Storage)

Samsung 850 EVO 1TB (OSX)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.