Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Now Fully Working MOUNTAIN 10.8.2 LION ON AMD 1090T M4n98TD eve

7 posts in this topic

Recommended Posts

Hi, HELP!! haha



System Specs are as follows:


ASUS M4N98TD EVO Motherboard with Nvidia MCP78 and NF200 chip - VIA 1708S sound


AMD 1090T X6 at 3.9GHz


MSI GTX 660 Gaming 10de 11c0


8GB DDR3 1600mhz Ram


I have successfully installed Snow Leopard but cant seem to update it past 10.6.3 without Kernel Panics, I also believe that support for the GTX 660 is not good.


Using my snow leopard install, I created a Mountain Lion USB installer with the amd_kernel - using the boot flags:


amd_kernel cpus=1 busratio=18 npci=0x2000 USBLegacyOff=Yes PCIRootUID=0 -v -f


I managed to get the installer to run and install, it completed and said installation successful.


I haven't been able to boot into the OS as yet however.



All seems to be going well, with the kexts loading and SUCCESS coming up everywhere, then after macosx_swapon which is OK the loading seems to grind to a halt, it loads NVGK100Hal and also finds my Bluetooth dongle, assigns an internet address but just gets no further, it seems to be stuck just before it would normally say DSMOS has arrived....


Any ideas would be most gratefully received....Many Thanks


Share this post

Link to post
Share on other sites

you sure that FakeSMC.kext in S/L/E ? you have a Folder Extra in the root of your HD  with smbios and org.chameleon.boot.plist ? to the first boot try this flag.


-f -x -v npci=0x2000 

Share this post

Link to post
Share on other sites

Hi, yes I have a Plist and a SMbios Plist! I will check the fake SMC kext!


I tried those boot flags, I also edited my AGPM kext for my card, although in NVGK100hal it is already listed, so no edit required there.



Just looked and for some reason have no kexts in the Extra folder, what should I have in there please?? I seem to remember there being two

Share this post

Link to post
Share on other sites

Hi, I reinstalled the Mountain Lion OS and then used these boot flags:


amd_kernel cpus=1 busratio=18 npci-0x2000 PCIRootUID=0 -v


I have a fully booting install, however I have no internet and have no sound, I tried using Voodoo HDA 2.8.2 which worked on SL but it doesn't on ML.


I have full graphics support and full resolution, the RAM is fully detected at 8GB, just the important Internet and sound!!


Any advice on particular kexts I need... Its a Nforce 980A (MCP78) Board



Share this post

Link to post
Share on other sites

Went into IONetworkingFamily Kext and under the plug ins I deleted the NVENET.kext and replaced it with one that worked in Snow Leopard and my internet is up and running once more, typing this on OS X 10.8.2 - Still having issues with sound however, If I select my SPDIF in VoodooHDA, the Sound settings in Preferences still only gives me the options of HDMI out, the HDMI out is the sound on my Video Card i think.... I need the onboard sound to work!


Share this post

Link to post
Share on other sites

Found a kext for Via VT1705 audio, a modded VoodooHDA and although mine is a VT1708S chipset, am happy to report that sound is up and running too! 


Wow, took me four days of faff, but ML 10.8.2 on M4N98TD EVO with AMD 1090T X6, 8GB Ram and a MSI GTX 660 is fully up and running...


thanks to the AMD kernel, the Mountain Lion Boot Installer package, the Modded VT1705 VoodooHDA, a bit of manipulating of kexts, I deleted all the ATI kexts and Intel HD Graphics as I wont ever need them! 


Share this post

Link to post
Share on other sites

Going for the 10.8.4 Combo Update now - urghhh, back up done, hate this bit!!


Well, after much butchering of kexts have got full functionality back, no Kernel panics so that is something, but then, I am using the and_kernel so shouldn't be affected by updates.


Tried putting the NVSMU and Networking kexts back in and installed the VoodooHda, but no go, so installed the voodooHDA again, installed the NVSMU and IONetworking again, from my back up, then also from backup reinstalled the dependencies, like IOPCIFamily, IOFirewire, IOplatformexpert, etc, etc, about 10 kexts in all, probably over kill but wanted to make sure, as I knew my back up was fully functioning, taking the kexts from there should mean back to function again and so it proved, 10.8.4 - Job Done

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.