Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[Fixed] Dell Inspiron 1525 won't boot SL

4 posts in this topic

Recommended Posts

Alright, I am gonna be as straight forward as possible. I have got 10.5.8 working perfectly on my 1525, and was looking to go Lion. I am gonna hop from 10.5.8 to 10.6 to 10.6.3 to 10.6.8 then finally to 10.7.X. I followed these guides 








I got everything done, no problem. I am using a 16 GB SD card and I am using a SD card reader (USB) to r/w to it (The card reader is not supported for me in 10.5.8), and right at step 1 for installation, I hit my problem. I can't boot from the external card reader. Then I tried to boot from the internal card reader, with no luck. Does anyone know what the issue could be? If so, how do I get it to boot? Also, I am all for going straight to (Mountain)Lion or Mavericks!



1. Grabbed a copy of iPC 10.5.6, burned it to a DVD at 8x burning speeds

2. Booted into iPC on the Dell, installed 10.5.6 without any issues

3. Grabbed the 10.5.8 Software update, no issues there

4. Got a copy of the retail version of 10.6.0 and followed the above guides. I used MBR, ill go ahead and try GUID

5. Tried booting into the SD card reader from *all* the USB ports, I even tried using the onboard reader to no avail.

6. Messed around with the BIOS (Reset defaults, changed boot sequence), to no avail.

7. Tried re-doing EVERYTHING, with no success.


I REALLY hope its a setting I can change, or something related, because my Dad won't let me use the USB Thumb drives he has, because he won't allow OSX on it due to the fact its technically illegal. I am using a IOGear GGFR209 with a Kingston 100X Class 10 16GB SD card. Guys, I really need help with this, I was looking to have at least Snow on the Dell before school on Monday. If there is anything I need to do, please respond!

Share this post

Link to post
Share on other sites

Okay, so I reinstalled everything, its not the way I prepared it, so what else could it be? I have tried it in both the "Locked" and "Unlocked" modes that you can put a SD card in. I might just post what I did step by step.

Share this post

Link to post
Share on other sites

Ok, I got it past mainly using GRUB 2. Cheers to smx for helping me up to this point. It appears I am stuck at Still waiting on root device (yes, I am in AHCI), any solutions? Im on rev A17

GUIDE For grub in my case http://pastebin.com/kfziNHeM

Alright, I fixed it up and It booted to 10.6. :D smx deserves almost ALL the credit, he is a BIG help. Im Combo updating to 10.6.8, and I'll post any bugs here.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Deltac0
      I'll just clarify that this section isn't for "omg how to get mountain lion / lion / snow leopard running on AMD".
      The section is named "AMD Development". This basicly means that this section is dedicated to developing, not asking help.
      I know I've done this even by myself, but now it's kinda out of control, everyone asking about installing ML on AMD etc.
      The 3 threads (SL / L /ML) should be dedicated to development of kernels and other related stuff and reports of the developments, not asking "how to get it running i get error".
      If you need help with AMD on SL for example, you should post on the installation help or if you followed a tutorial, ask the tutorial thread.
      However, I do not suggest asking with PM, because then other people can't get the same information as easily, and it's not funny to see inbox full every minute.
      Also, if you need help with the test kernels for SL / L / ML, you can post on this thread, I'm sure there are people ready to help you with your errors.
      Let's just keep the "development" threads clean of the "spam" / stupid questions (even if there isn't any).
      For real-time help, download an IRC client and join us:
      chat.osx86.hu #LegacyKernel
      And when you get your build running, please post here!
    • By dom1202
      I have a strange behavior. Sure somebody can help me???...
      I have a hackintosh, working well since several month.
      Configuration: Snow-Leopard OSX 10.6.8 / Gigabyte GA-H67MA-UD2H (Rev. B3) F8 / i3-2105 sandybridge 3.09 GHz
      / sapphire-radeon-hd-5450-1go / 8GB Corsair CMX8GX3M2A1333C9 XMS3 DDR3 1333 Mhz CL9
      I added several hards disk to clone the hackintosh itself or some other mac.
      However when I add another internal hard disk making backup with rsync scripts of another snow leopard mac, I cannot boot anymore. (the script is making a sort of Time Machine backup).
      I am stuck after 'Load Operating System…' . Sometimes several "boot…" appears very quickly and disappears. Keyboard is not active. The hack is stuck and … me too.....
      But if I disconnect back the hard drive, the hackintosh boot very nicely again.
      I change Hard disks, making new 'clones' several times, same problem : no booting.
      So I don't understand.
      Here is my question :
      What can prevent from booting my hackintosh when I add a hard disk with a 'clone' of a mac on it. ???
      It looks like when the clones contains only ordinary files, it is OK, and that the problem arise when 'system' files are copied/cloned.
      In other words what is changed on my 'good hack hard disk' which prevents booting when the 'new' hard disk is connected. What happens when the hack is started?
      NB: Of course with 'F12' each time I am choosing the right hard disk with the hackintosh system which has been all the time working. I am not trying to start from the added hard disk, but from the same 'good hackintosh'.
      Thanks a lot for your ideas of cause
      Sorry excuse me for my english.... Hope I am clear.
    • By Andy Vandijck
      It's built and tested on my ML system...
      Source is included...
      This kext will work always on AMD... replacement for Dont steal Mac OS X.kext (move somewhere after install AppleDecrypt.kext)
      Again thx to Sinetek for the decryption algo's
      Watch closely in the screen cap... (no Dont steal Mac OS X lol)
      I've made kexts for Lion and ML
      EDIT: ML version should work for Mavericks too...
      EDIT2: New version, Mavericks optimized.
      This one (under Release Mavericks) is code signed. (no more nag screen stating unknown kext etc...)
      EDIT3: New version, Yosemite optimized.
      This new version does not use OpenSSL anymore but instead loads up Apple's corecrypto.kext and uses that.
      I found the proper way to use Apple's corecrypto interface and it's much faster
      Also the code is built with Xcode 6.1 and fully optimized for running really fast.
      The Yosemite optimized version is in the V2 zip file and source, as usual, is included.
      It should be possible to recompile the kext on other systems as well because the corecrypto interface is still at 1.0, so no change. (Lion / 10.7 or better).
      EDIT4: Added github repo.

    • By TheNuutti8
      Can SnowLeo be installed on this:
      Processor Intel Pentium 4 3.0 GHz SSE, SSE2, SSE3, HyperThreading Memory / 4.0 GB Hard Drive 1000 GB Operating System SL ? Optical Drive ASUS Blue-Ray Graphics Processor ASUS EAH6850 V2 Cache Type L2 cache Cache Size 1.0 MB Which distro, which kexts etc.
    • By Tyler Worth
      I have 2 computers and I am in a Mac OSX class (learning about it basically)
      My teacher said It would be interesting to see it work on my laptop or Desktop.
      (Would also Like to dual-boot! Win7 and Mac OSX SL (only Retail i have at the moment Lion and Mountain Lion are on there way)
      My Specs:
      Acer Aspire 7650-Sb416
      CPU: AMD A6-3400M (Quad-Core)
      Graphics: AMD Radeon HD 6520G
      Motherboard: Acer Je70-SB
      Chipset: AMD K12 bridge Rev 00
      SouthBridge: AMD A55/A60M Rev 11
      Ram: 8GB DDR3
      CPU-Z Screen Shot of CPU -Facebook picture but I have it set to Public so you should be able to see it.
      My Desktop:
      Custom built Desktop
      CPU: FX-8150 8 Core Processor
      Graphics: nVidia Geforce GTX 550 Ti Dedicated RAM:1 GB X2 (I have taken one out no worries!)
      Motherboard: ASUSTek Computer Inc. M5A97 Rev1.xx
      Chipset: AMD RD9x0 Rev 02
      SouthBridge:Amd SB910/950
      LPCIO: ITE IT8721 <=No idea what this is.
      Ram: 16GB DDR3
      CPU-Z Photo of CPU - Facebook picture set to public.
      Let me know I have been working on my laptop all week and i have gott as far as booting with nawcoms boot Cd with paramaters rd(0,0)/extras/modbin_kernel -force64 arch=i386 busratio=12 (dont even think thats right)
      Help me out I know the world of Windows but i want to learn more mac and My Girlfriend wont let me get one cus there expensive. Plus I want to do it for educational purposes and learn more about this stuff.
      I want to start developing. But i need to get this whole thing down first.
      On hand I have a Snow Leopard Retail disc/ ModCD by Nawcom/iATKOS S3 V2/EasyEfi V2.2 and have 55 black DVDs and 25 blank CDS lets do this!