Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

6 posts in this topic

Recommended Posts

Hi all,


I've had partial success with installing Mavericks onto my Lenovo Thinkpad T60p. However I've run into a few roadblocks for which I've been combing the web for solutions. I've found a few guides that could work but they are all 3-6 years old and any kext downloads are expired or gone. I'm posting out of desperation and semi-noobness in hopes that someone can help me and anyone else working with the same notebook. Here's a screenshot of my Device list from DPCI Manager. 


I know I need a new Wifi Card, I think I can manage to get the sound working, but the real trouble is that ATI Mobility FireGL V5250 Graphics. The computer is really laggy and the refresh rates are horrible. If I'm not mistaken I need to fully enable the Graphics. If anyone can lend a hand it would be AMAZING! Thanks in advance.


Share this post

Link to post
Share on other sites

Hi Dwors,


once I owned a T60p (14", 1440x1050, FireGL V5250) and had Lion beautifully roaring...


You will need a modded bios in order to change WiFi card because Lenovo withelisted them. Try e.g. http://www.bios-mods.com/forum/Thread-ThinkPad-t60

The FireGL V5250 is basicly a Radeon X1700, so you can use kexts for this model (just add device/vendor id to kexts plist). To get display fully working (changing screen resolution, wake up, back light etc) I had the mess with EDID - maybe auomatic detection is better now.

If there are ghosting windows then there is a problem with the syncing between the cpu cores - I fixed it with VoodooTSC.kext.


Good luck!

Share this post

Link to post
Share on other sites



Here are kexts I use for FireGL 5250. All is perfect. Try them, if it would not work for you, send me your ATIRadeonX1000.kext and I would try to hex it.

I am sending you three kexts, be carefull not to install all of them at once!

First of all isntall ATIinject.kext and ATINDRV.kext, reboot and install ATIRadeonX1000.kext

All works perfectly on Leopard!



Share this post

Link to post
Share on other sites


I'm running a T60p with 10.6.8 and ATI FireGL V5250, 64 Bit kernel, stock kexts (for video)

It was a mess to get it up and running, and sometimes (5-10%) the video isn't detected (wrong EDID pickup)


@Sentabrina: Lion and Mavericks are different beasts, the trick with the old Leopard drivers worked AFAIK till version 10.6.6

after that something changed (probably the OpenGL framework). ATINDRV comes from Leopard 10.5.


Will someday have a try with ATY_Init.kext 64 Bit, will report...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.