Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Custom DSDT for Dell Studio 1555, OSX 10.9

4 posts in this topic

Recommended Posts



I succedded in installing Mac OSX 10.9 in my Dell Studio 1555. Almost everything runs just fine. I made the DSDT from ground up, based on the original of my laptop and the retail macbook pro one.


My specs are:


Processor : Intel Core 2 Duo T6400. Speedstep OK.

Video : Ati Mobility Radeon HD4570, 256 MB, with QE/CI, via custom framebuffer and Clover Injection.

Wireless : I replaced the wifi card for a Atheros AR9285, which works OOB.

Audio : IDT 92HD73C1, working via patched AppleHDA.

Ethernet : BCM5784M, working with custom kext.

CardReader : working with VoodooSDHC.

Webcam : Working OOB.


The only things missing are:




Some Videocard Features:

HDMI works, but if I unplug it the duplication icon remains in the menu bar (system thinks it is still connected).

VGA doesn't work.

The internal laptop screen, suddenly goes off every apron. 20 seconds, like trying to sleep, with mouse click or key press it wakes up. (I realized that if the HDMI were connected previously, i.e.. if the duplication icon is still on, this does not happen).


Battery appears as not installed.


Brightness slider appears but does't work, and keyboard keys does't control it either.



I suspect every missing thing are dsdt-related, but I don't realize how to go on from this point.


Can you please help?


In the attachments is my dsdt.



Thank you very much!!!





Share this post

Link to post
Share on other sites

I also have a Dell studio 1555 with a ATI 4570 Radon Mobility but cant get QE/CI to work under 10.9 how did u create your custom framebuffer/Clover injection? is it possible for you to upload your modified Kext for this and also for the Audio as i have searched everywhere but cant get either of these to work!

I did find the network kext you mentioned and now have internet!! 

thank you


Share this post

Link to post
Share on other sites

Hi, I have a dell studio 1557 with same graphics card, but cannot get audio and QE/CI to work in 10.8 and 10.9, I also read about famebruffer stuff, but it seems very complicated, I tried it but did not succeed. I hope you have some tips.



Share this post

Link to post
Share on other sites

Using Niresh's Mavericks 10.9 build I was able to get Mavericks installed onto my Dell Studio 1569.  After using the QE/CI kext fix also by Niresh and the VooDoo battery kext files and replacing my wifi card I have almost a 100% working HackBook.  The only thing I'm missing is sleep.  It'll somewhat go to sleep (the screen turns off) but the fans don't turn off and I can't get the screen to turn back on if I don't catch it right after the screen goes off.  The reason I'm posting this is two fold; one maybe it'll help you guys to get your studios installed with 10.9 and two maybe you guys can help me out with my not being able to wake from sleep issue.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.