Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

No sound from ALC883 on 10.8.2

6 posts in this topic

Recommended Posts

First of all, Hi!

I've just started my adventure with OSX86. The distro i had chosen was iATKOS ML2. Mostly because i'm a newb when it comes to hackintosh and it was said to be easy-peasy.

Installation went well, just had to add kexts for ethernet (L1) and exotic patch for Radeon 4850. Those are working perfectly.


Unfortunately i can't make my sound card work. It's really weird because many people reported sound working with this distribution on my exact MoBo, without installing anything.


I've tried every kext i found for ALC883 on 10.8.2 and none worked. Of course i always repaired rights and rebuilt cache after deleting previous ones.


It somehow started working with this http://www.osx86.net/files/file/841-applehda-kext-ml-patched-for-alc883/ which some people recommended.

There are 4 files:






So i installed AppleHDA and after reboot there was still no sound, but the Intel HD Audio appeared in system report. I was frustrated so with a wild guess i installed HDEFInject, rebooted and... the sound was working perfectly. Unfortunately after next reboot it disappeared forever, even tried to replicate these steps but to no avail.


I also tried VoodooHDA, but the sound quality was horrible, so there's no way i'm going back to it.



Would love some help on that matter from more experienced users.



My setup:

C2D e6750

Asus P5K(ICH9/ALC883)

Ati Radeon 4850




Share this post

Link to post
Share on other sites

@mirone23 -  I guess i tried this one yesterday, but anyway gave it a shot and still nothing. Not even Intel HD Audio in system report. Again some weird thing is happening because after install & reboot there were 2 kexts running: 2hxvp6d.jpg



but after another reboot they disappeared. I mean AppleHDA is still in S/L/E but not running.


@nutric - As i said i installed the newest Voodoo (2.8.4) and it worked, but the sound was completely distorted. Of course i'll try this one too thanks, but i don't know if it's gonna be any better.


EDIT: Ok, the Voodoo works, but again the sound is very distorted  at times. Maybe there are some suggested settings for Voodoo to make it sound loud & clear. In windows i'm using half the volume and here 100% with the same volume on my amplifier. I know there are fixes that can be found in Voodoo contents, but when i used the half volume fix earlier it only artificially made it louder(like in VLC 200%) so it only made it terrible to listen.


I may be overreacting here because i'm eventually gonna use a USB/FW audio interface for home recording, but i'm trying to get a grasp on stability and managing workarounds for problems with osx86.

Share this post

Link to post
Share on other sites

I finally made it work fine with VoodooHDA, but...

I realized i made a rookie mistake and installed OSX on a case sensitive partition and some applications can't be installed on those, so i had to format and reinstall. As it appeared this time the sound is working from the beginning. I believe earlier the reason was that i had a creative X-fi card which i knew wouldn't work on OSX so i ignored it but system probably detected it anyways. During this install the card was out, cause it was pointless to keep it installed and as it appears that fixed the problem. Just to be clear the one that was now automatically installed by iATKOS for my card is VoodooHDA 2.7.2 and it works perfect even without prefpanel.


Thanks for all responses, topic closed for me.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.