Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Installing Mac OS X L2 on Dell Latitude D830 – the system freezes

2 posts in this topic

Recommended Posts


First of all I would like to thank you for the efforts you deploy by bringing the Mac OS X experience to Intel based PCs.


I spent last weekend trying to install Mac OS X Lion on Dell Latitude D830 and it always freezes when arriving to the [Custom/install] interface, all things go well but suddenly the mouse, trackpad freezes and the Keyboard too, here is the different combinations I tried:


In the BIOS :




Enabling all core 2 Duo futures.


Virtualizalion : Enabled








I disabled all things related to Wireless and Bluetooth, because it doesn't let the installer to boot.


 When the system boots from the DVD, I hit F8 here I tried hundred of combinations:


-v -x USBBusFix=Yes -f -F graphicsEnabler=No/Yes UseKernelCache=Yes/No ...




and the only ones that goes to the graphical interface are:




npci=0x3000 USBBusFix=Yes UseKernelCache=No cpus=2 -v


with this last I can reach the install interface and chose Language, create HFS+ partition, and if I don't do it quickly  (and have to move mouse pointer continuously) the system freezes at all suddenly, then I have to reboot  :(


I have to mention that I read a lot of topics before to post this thread, and none of them resolved my issue.



Here is my Laptop configuration



Dell Latitude D830


CPU : Intel Core 2 Duo T93000 2.5 Ghz 6Mo Cache L2 (Originally shipped with T7250)


RAM : 4 Go DDR2 (Sumsung 2  Go + Hynix 2 Go)


Chipset : Intel 965GM with Intel  onboard graphics


Graphics : integrated Mobile Intel GMA X3100 ( Ven_8086&dev_2A02&subsys_01ff1028&rev_0c )


Wirless : Intel Pro Wirless 3945ABG ( Ven_8086&dev_4222&subsys_1021886&rev_02 )


Ethernet : Broadcom NetXtreme Gigabit Ethernet B5755M ( VEN_14E4&DEV_1673&SUBSYS_01ff1028&REV_02 )


Sound :  SigmaTel High Definition Audio CODEC ( VEN_8384&DEV_76A0&SUBSYS_102801FE&REV_1002 ) STAC 92XX C-Major HD Audio (Present on Latitude D830 - D630 & and Dell Precision M4300))


Smartcard Reader : O2Micro OZ776/777 USB CCID Smartcard Reader ( usb\vid_0B97&pid_7772&rev_0110 )


Fireware IEEE 1394 Open Host Controller Interface ( Ven_1217&dev_00F7&subsys_01FE1028&rev_02 )


Trackpad : ACPI\PNP0F13



One last question, I read on a lot of forums that ML2 won't work with this config, is this true, or my I try?


Thanks again  :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.