Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

AGPM problem with MSI Nvidia GTX 570 on ML 10.8.3

3 posts in this topic

Recommended Posts

Hi everyone,


I'm new to the hackintosh scene and this was my first attempt to install OS X.


I've successfully installed ML 10.8.3 on my computer couple of days ago, here's the spec;


Mobo: ASRock Z68 Extreme4

CPU : Intel Core i5 2500K 3.3GHz

GFX : N570GTX Twin Frozr III Power Edition/OC


I'm using Macmini5,1 SMBios and everything runs smoothly from what I can tell, however console spits out the following:


[AGPM Controller] unknownPlatform
kernel[0]: GFX0: Not usable


But I can see GPU changing it's state on HW monitor.

When it's idle it shows




and when on load




Did some benchmarking,









Temperatures when idle between 30-37 Celsius and when loaded like when doing Heaven benchmark it's between 61-65 Celsius.


is it working properly? is this the full potential of it? I'm worried that I might burn my card with no PM.


I've tried to fix AGPM by using Macpro5,1 smbios and editing the agpm.kext, AGPM work but with that GPU does not change states at all and benchmarks reports awful fps, in heaven I've gotten like 17fps max. Also tried inserting macmini section but that didn't work either.


I've also installed the latest Nvidia's own drivers. Not sure if it's working or not as it defaults the OSX driver upon boot.


I've been searching and searching for the last couple of days, trying the suggestions I can find on all over the web but nothing works. I'm so confused as to what to do, what to edit or what's the correct values are for my card. What's the next step? Do I ignore the AGPM controller issue? or is there a fix without taking a performance hit?


Thanks in advance.

Share this post

Link to post
Share on other sites

I've managed to switch the drivers from default to web, I've tested it with GuildWars 2 and good FPS there, I think I'll be set once the AGPM properly working as well.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.