Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Black screen on boot after graphics card upgrade

8 posts in this topic

Recommended Posts

Hi people,


Recently I have made an upgrade from my 9600GSO(8800GS) DDR3 384MB to a more faster GTX 295 GDDR3 1792MB as it was cheap when I brought it from the internet and offers significant increase in performance without me investing on a fortune. It turns out that after this switch OS X does not boot for some reason so I would like to ask about this. Below are the specifications of my rig. Also note that the card is fully functional therefore not hardware problem. I have tested it in Windows 7 on furmark for half an hour straight and played many games for countless hours fine. I would also take my time to give more detail on the situation to make it more easier to help.


Intel Core 2 Quad Q6600

8GB DDR2-800 (2GB*4) memory


Samsung 830 Series 128GB SSD(That I use to boot Mac)

Seagate 7200.12 500GB(For storage, probably not too relvant to the situation)

Seagate 7200.14 1TB(For storage, probably not too relvant to the situation)


As for bootloader I am currently using Chameleon v2.0-RC5 r1096 running Mac OS X Lion 10.7.5


My friend who also run using a GTX 295 told me that his card boots OS X Lion out of the box although I believe he runs a earlier version of Lion. He said that if I install the Nvidia GeForce and CUDA drivers from their official website for Lion I should get full support. Of course I have done a bit of research my self and many of the HCL I read did note that.


Therefore I went ahead and tried the method that many of those agreed. Prior to upgrading my graphics card I have installed drivers for 10.7.5(The version that I am currently running) and shut down to install the new card and switched the rig back on. On boot that apple logo was there with the usual wheel spinning however once the sequence was over I was then lead to a black screen. But I know that the OS is still running as the HDD activity light is flashing and that when I press the volume buttons it makes a sound making me believe is the problem with the new card I installed that the driver does not want to make it work.


I read many threads in the forum regarding to this problem but many of them only refer to older version 10.6 therefore not very helpful. One of the post suggest to change display output due to GTX 295 nature to not have dual GPUs enable in OSX. So i tried that on my other DVI port still black screen.(Note that my GTX 295 is a single PCB with only two DVI outputs)


Then I did some self testing of different boot commands my self to try get the card to display. Below are the out comes I have got by booting with the commands below that I hope it should save some time.


GraphicsEnabler=No -v (Black screen)


GraphicsEnabler=Yes -v (Able to boot to login screen with Apple logo and nothing else)




-x -v (Black screen)


-x -f -v (Black screen)


-x -f -s -v (Black screen)


GraphicsEnabler=Yes -x -v (Able to boot with login screen and to use desktop. However freezes shortly after use.)


GraphicsEnabler=No -x -v (Black screen. Knowing that setting GraphicsEnabler would not even let the card to display I continued testing with GraphicsEnabler=Yes)


GraphicsEnabler=Yes -x -f -v (Able to boot with login screen and to use desktop. However freezes shortly after use.)


GraphicsEnabler=Yes -x -f -s -v (Presented with option screen>typed exit as shown images below. Boots but as above freezes after shortly after use.)






At the end it turns out the enableing the GraphicsEnabler gave life to display but however freezes shortly after or simply just shows the login screen without option to do anything else. At the moment I am very stuck on what to do so I would like to know what the experienced people think in the forum? Would be quite helpful for those who got it working on the GTX 295.


Many Thanks,

Share this post

Link to post
Share on other sites

You are using old release candidate of Chameleon, get newer 2.1 for starters

-v -f GraphicsEnabler=Yes PCIRootUID=1 npci=0x2000


@eep357 I updated to Chameleon v2.1svn r2069 and it still didnt seem to make a difference at all on boot. although now when I boot it shows a grey background with cursor and freezes shortly after :/


@iFIRE I just tried the boot command u mentioned gives me a black screen, however after chameleon update with the same command it displays something but only grey screen with cursor and freezes shortly after.


Personally I made the effort to reinstall the Nvidia drivers namely GeForce 295-1.00.05f03 for 10.7.5 and CUDA 5.0.36 which still makes no difference at all but grey background with cursor then freezes shortly after. looks something like this btw http://imageshack.us/photo/my-images/221/imag0418p.jpg/


So any idea whats preventing it from displaying? I meant booting from safe mode works but it freezes after some 3-5 minutes of use after flickering on the screen which fortunately gave enough time to install the Nvidia drivers thanks to SSD. As a note when booting from safe mode under -v I recongize a line going by very fast saying NVDAsomething recongized and loaded so the driver should be loaded but some how decides to freeze either in safe mode or not to display anything at all seemingly weird.


Again thanks for those who helped btw :)

Share this post

Link to post
Share on other sites

Hi, i think i have the same issue.

I have a GT 520 and Lion 10.7.5 installed. When i Install the latest GeForce drivers (not the CUDA ones, but i guess i don't need those since they would be to run CUDA enabled apps) my monitor says "no signal", when i roll back to previous GeForce and NV kexts it boots well. I've tried to boot with several combinations of -f -x GE=No GE=Yes GraphicsMode npci=0x2000 npci=0x3000 and PCIRootUID but allways the same happens.

Any idea of what could be happening?


P.S. I use Chimera Bootloader

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.