Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

iCloud/FaceTime/App Store/iMessage Don't work

5 posts in this topic

Recommended Posts

I installed ML on my Lenovo G580 laptop.


I now i need to have Ethernet as en0 to make these work.


But my ethernet card is an Atheros AR8162 which is unsupported.


My wifi is also unsupported (Broadcom BCM4313) so I bought a D-Link DWA 131 WiFi adapter, which works perfectly.


The thing is, I can't use any of the apps listed on my title, iTunes works fine thankfully.


When i try to log in the App Store, it says An Unknown Error Occurred


If I check my system properties, this is what I get for my internet adapter


Share this post

Link to post
Share on other sites

remove all adapters from network prefs and delete network preference files from /Library/Preferences/SystemConfiguration. reboot, add ethernet. Use ethernet to sign into icloud, appstore, etc., then add wifi.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.