Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Dell M6300 Successful LION clean install method

4 posts in this topic

Recommended Posts

This is to let the diehards who don't want to let go of there killer m6300's yet that there is hope for them for a little while longer. I am running 10.7.4 currently using Lion from the app store + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + a few files. This is a method to allow a legitimate install of your purchased download installer but because of the method I had to use I can't give all the details here. I don't want to violate any rules on this great sight and even though this has allowed a legitimate install it is not without some slight tinkering with the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] files. A search over at osx86 downloads for m6300 will take you to my guide - http://www.osx86.net...do=file&id=3275 the files you need are there. I have tried so hard to do this for the past 6 months and had this m6300 over a year, but was really about to give up. Questions everywhere go unanswered as people can't seem to be bothered to help with an older machine or they just don't have the answers (always just seems to be the same old "try this or that boot flag" response) and I just hope this will help those that still have one of these boxes get some more time out of it. I would love it if some HT Guru could take the time to figure out how I did this and discover a better way to make it happen not to mention that I would love to install ML on the m6300 but it appears that changes in the installer since lion make this very hard to figure out for someone like me. Been a silent viewer here over a year and learned so much from all the great minds, best of luck to all.


UPDATE: Decided to try to get to 10.7.5 and was successful - I had to do some fixing to make it happen: rolled back 8 kexts to be safe (most likely more than needed) which were new ones from the update + the IOUSBFamily, IOUSBMassStorageClass & IO80211Family from my 10.6.7 image with permission repair - a couple flag boots and then I replaced 5 of those kexts with ones from my 10.7.4 partition with repair and then all booted as normal... so far so good


UPDATE 2: After some more experimenting with boot flags been able to get it booting and stable at 64 bit 10.7.5 and changed my smbios.plist file to an iMac 7.1 from the MacPro 3.1 so I am going to try upping my RAM now to 8g and see how it goes.



This is the 2nd forum I have posted this to in hopes to get the word out to as many M6300 users as I can and to help further exploring methods to keep using these laptops




Share this post

Link to post
Share on other sites



I just picked up a M6300 & came accross your post. I have been doing Hackintoshes since 2007 and the M6300 looks to be a bear. Can you post or send you DSDT to me & what version of BIOS are you using.

Share this post

Link to post
Share on other sites



I just picked up a M6300 & came accross your post. I have been doing Hackintoshes since 2007 and the M6300 looks to be a bear. Can you post or send you DSDT to me & what version of BIOS are you using.





Honestly it can be very easy, and I used no DSDT (I tried but I can't get them to compile to an .aml again after I extract them) I have the latest A14 bios on both machines. I will lay out what I think is the quickest and easiest way to succeed (I recently set up another one and have settled on this method here) First go to:




And grab -


1. 2 Partition USB method.zip


You also need a USB stick of at least 8 Gb's


And best to have a USB keyboard and USB mouse handy (I really needed these)


Once you can successfully make a USB installer the rest is pretty easy:


Step one - Partition the USB stick into 2 partitions, the 1st a small 250Mg one named BOOT and the 2nd all the rest of the space named INS_LEO (names not important)


Step two - restore the boot image partition (from the zip file) to the BOOT partition on the USB stick (it is in the 2 Partition USB method.zip from the link above)


Step three - follow the instructions to make the INS_LEO Partition with a Lion installer image (that you must have) insert the replacement kexts into the system/library/extensions folder (just delete the ones that are there first then put these in their place)


You now have a stick that will boot an M6300 and it has the 2 most important kexts that you need to replace after the install to get it booting


If you plan on having WiFi and want the best easy solution buy an Apple BCM94321MC


I am using 3 of those cards, 2 in my M6300's and one in my desktop with an adaptor (get s:l:e kexts.zip from the link above and there is an IO80211Family kext for this card in there) all 3 work well and have no problems getting to the App Store (these cards can be bought used for around $10)


Boot the USB installer, choose a language, go to disk utilities and partition your hard drive with at least 2 equal size partitions (I chose 50 gigs each but it is up to you) I also made a 3rd partition of about 200 gigs to store image files and software


Perform the install onto the first partition - when the install is done do not restart! choose to open a terminal instead - from there you can replace the IOPCIFamily.kext & AppleACPIPlatform.kext


These are the only unix commands needed:


ls list contents

cd navigate

pwd Display absolute path to present working directory.

rm -rf DIRECTORY Same as rm -r but without asking for confirmations.

cp -rf DIR NEWDIR Copy DIR and all its contents to NEWDIR.


you need to navigate to /volumes/ and use ls to see all your drives including the Lion USB installer partition


if you named your new install something like OSX_01 (for example only, name whatever you like) then the remove commands will go something like this:


rm -rf /volumes/OSX_01/system/library/extensions/IOPCIFamily.kext


rm -rf /volumes/OSX_01/system/library/extensions/AppleACPIPlatform.kext


and if you named your USB Lion installer partition something like INS_LEO for example the copy commands go something like:


cp -rf /volumes/INS_LEO/system/library/extensions/IOPCIFamily.kext /volumes/OSX_01/system/library/extensions/


cp -rf /volumes/INS_LEO/system/library/extensions/AppleACPIPlatform.kext /volumes/OSX_01/system/library/extensions/


There may be typos so have a list of basic unix commands handy, pwd is handy as you can navigate deep and then enter pwd and get the entire path and copy it so you can paste it (less typing that way)


You can do the same for the WiFi kext at this point too if that is the route chosen.


Now you can quit the terminal and click the reboot button and boot, then F12 choose USB then when Chameleon starts up again choose the new Lion install partition and type these boot flags:


arch=i386 -f -v


That should boot the install where you can RUN [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] & install easy beast so you don't need the USB to boot (TIP - once to the desktop eject the usb)


I did exactly this and all went perfect, I only have LION 10.7.0 so after I did this I rebooted to make sure it was working then I used the USB stick to reboot the installer where I used Disk utilities to make an image file of the new install before I messed it up, I then restore the image to my 2nd partition to have two working installs I could boot (in case I mess one up also)


After that it gets a little tricky to upgrade all the way to 10.7.5


I then booted to the Hard Drive and chose the 2nd partition and upgraded to 10.7.4 but before I rebooted I replaced all 3 kexts (I used the 3 from my s:l:e kexts.zip) again because the upgrades mess up the install if you do not. I also kept track of a few other kexts that I rolled back which I believe are - IONDRVSupport.kext AppleBacklightExpert.kext IOGraphicsFamily.kext AudioAUUC.kext (you may want to copy the S/L/Extensions folder to the desktop or spare partition after you get the first Install booting, then you can compare and roll back from there)


I rolled back all 7 kexts I have now listed each time I ran an upgrade before rebooting (not sure if all needed this but I had no issues this way)


Once I finally had it to 10.7.5 I was able to get it to boot without the added boot flags and run at 64bit mode - I will attach my final org.chameleon.Boot.plist


It may take a few tries - Best of luck!



Share this post

Link to post
Share on other sites

same here installed iatkos L2 got successfully working but some items are not working...wifi dell1505 working out of the box, sounds are working, nvdia fx3600 working with QE/CI but no battery, network card, sd card reader..

my specs:

Dell Precision M6300

NVdia fx3600 512

4gb ddr2 ram

sigmatel soundcard



hope anyone can help me work battery , sd card reader and internal network card..

thanx in advance

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.