Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

[Solved] Mac OS X 10.8 and Windows 7 dual boot on separate drives

1 post in this topic

Recommended Posts


I've got a problem, which I couldn't find on google, nor here, or I did wrong search.

I installed ML on new hard disk on SATA3, in GUID partition table, and I've reinstalled windows 7 on my old hd on SATA2 in MBR partition table. I get Missing BOOTMGR error while trying to boot into windows 7. I tried bootrec fixmbr, fixboot, rebuildbcd, none worked. Is there a conflict between those two hard drives, because one is GUID n one MBR, but every time i try to boot into windows from bios boot menu (F12) i choose to boot from (WD320) hd for windows or (WD500) hd for Mac.


My specs are:


i5 2150 (Sandy Bridge)

4Gb transcend ddr3 ram

nVidia GTS 450



EDIT: I've set AHCI in bios. Also its UEFI mobo, but windows is 32bit.


EDIT: Used:

bcdboot X:\Windows /l en-us /s Z: /v

bootsect /nt60 Z: /force

then got /BOOT/BCD/ 0x0000c34 error

aslo bcdboot... command gave me error: failed


Nvm, unpluged mac os hd, installed windows, plugged mac os hd back, working excellent now.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.