Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Audio Issues/Potential fix for Audio stuttering in VMware and incompatibility with VoodooHDA if i could find someone more adept

3 posts in this topic

Recommended Posts

I've been scowering the forums for a fix for a couple weeks now, installed all forms of VoodooHDA, Ensoniq audio to fix the audio stuttering issues in Snow Leopard 10.6.8 on VMware, I ended up taking a break for a bit, and attempted to start the VM in Virtualbox, the audio works flawlessly without lag.


The problem is however, in Virtual box i have non of the benefits of VMware Additions for OSX (Video Drivers, Shared Folders About This Mac, etc... and quite a few other things don't work properly.

Is there possibly a way to use VMware additions on a virtual machine in Virtualbox or use Virtualbox Audio device in VMware?


If not is there some way to figure out the difference at boot/loading etc thats allowing Virtualbox to properly play audio, view USB connected items, and mounted CD Images? There has to be a way....after audio most every problem is solved and the install is flawless (USB/Mounted can be ignored because of VMware shared folders)



Possibly if i can get some more adept people to assist me, together we can provide a workaround for all the Audio Stutter woes that envelop the forums (at least from extensive googling past few days hello 150 tabs >.>)


Thanks in advance, even if i'm just plucking at straws, typing this relieves a bit of stress as i've been troubleshooting this for a week or so straight

Share this post

Link to post
Share on other sites

I'm struggling with this, too. Zenith432 explained it already here: http://www.insanelym...dpost&p=1252646


Meanwhile I think the problem lies even deeper iin either the kernel (I use nawcom), or at least the whole thing about vmware ws 9's HPET, rtc, etc emulation, or the lack thereof.

I even tried to put the Audio drivers out of the way by using Soundflower+Esound to stream to my host's pulseaudio server. Same issue. So I suspect there something going utterly wrong in CoreAudio's resampling/buffering/timing CPU-whise, even before the audio drivers matter.


Just out of interest: which kernel are you using?

Share this post

Link to post
Share on other sites

OK. I did a huge step forwards.


I've read that CoreAudio doesn't use HPET, but instead relies on the time stamp counters and some funny calculations with CPU bus speed etc. So, FSB speed does matter.


So, looking at dmesg output, nawcoms kernel seems to blindly double the reported FSB speed which seems to completely mess up the TSC.

FSB was reported as 201 MHz (which is correct actually), and corrected it to 437 MHz. WTF...


I now use AnV's 10.6.8 V8_2 kernel, which at first set the corrected FSB speed to 103 MHz and corrected it to 237MHz. Sound was already a lot less crackling, but still: too fast feeding samples. So I added following to my boot options:

fsb=200000000 busratio=16

And now:

TSC: Reported FSB: 200.0000MHz, corrected FSB: 200.866380MHz
TSC: Verification of clock speed failed. Fallback correction was performed. Please upgrade bootloader.
TSC: Frequency = 3213.862080MHz, FSB frequency = 200.866380MHz, bus ratio = 16


That looks better - and Sound is waaaaaaay more usable now. Still not enough to actually listen to music, though.

So I raised the sample buffer size of the ensoniq driver by using the boot parameter


(the default is 64). And now I'm almost getting there. It's still a bit glitchy but almost usable.

I'll try to get the FSB a little bit below 200MHz, because vmware states that the guest should run a tick slower than the host [1], and try to play with es_oso buffer size


[1] http://www.vmware.co...ualMachines.pdf - a little outdated, virtual HPET is available in Workstation 9/Fusion 5 meanwhile.


Hope this helps a bit.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.