Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[Guide] The all-in-one guide to Vanilla OS X (including Chameleon + DSDT) for beginners (updated for Yosemite!)

906 posts in this topic

Recommended Posts

I have this error at boot with usb when installing mountain lion with amd kernel:


USBF: 1.378 AppleUSBEHCI checksleepcapability controller will be unloaded across sleep.



Share this post

Link to post
Share on other sites

i followed this guide step by step but i get an error while its loading the installer. when i ran it regularly, i get a stop/prohibited sign right above the apple logo. Then i ran it with -v and i got the "still waiting for root device" error. I only have 2 usb 3.0 inputs.


my machine is a dell xps 14

intel core i5 3317U @1.7 GHz

intel hd 4000

4 gb ram

500 Gb hdd

32 gb ssd


its really similar to an apple macbook air.

im using a retail mac os x mountain lion 10.8.2

and i used the patcher to allow me to dual boot os x and windows, and possibly triple boot with linux in the future

Share this post

Link to post
Share on other sites

I got everything working up to the last step of 4 (adding back the ATI6000Controller.kext to extensionsfolder), when I rebooted I got the infamous white screen.. Now I can't seem to boot at all, not even with -x or GraphicsEnabler=No (had GE=No during the installation). I've got 2 HD6950 in crossfire with HD6970 bios, and when I checked the systemspecification when it was working it recognized two graphicscards (no info though, only that they were ATI's). I've seen this thread, how can I remove the ATI6000Controller and add the kexts from that thread? (http://www.insanelym...page__hl__ 6950)

Also, Im dualbooting with windows 8.




i7 930

Asus P6T-SE

12 gb ram


Intel 520 180gb

Share this post

Link to post
Share on other sites

For some reason i can run ML on VMware with this machine but I cant install for the life of me.


I followed this Tut Pretty Well. I am going to try and Start from the beginning. Maybe I missed something.

For some reason I am getting stuck at Still waiting for device. (picture attached)



My Rig:

CPU: Intel® Core™ i7-3630QM Processor

Graphics: NVIDIA® GeForce® GTX 670M with Optimus™ Technology 3GB GDDR5

Memory: 12GB DDR3 1600MHz memory

HDD: 1.0TB: 500GB (7200rpm, Serial ATA) + 500GB (7200rpm, Serial ATA)

Optical: DVD-SuperMulti drive (+/-R double layer)

Wifi: Intel® Wi-Fi® Wireless networking (802.11b/g/n + WiDi Capable)

Bluetooth: Bluetooth® V4.0

USB:4-USB (3.0) ports

Any one help me PLEASE!

Share this post

Link to post
Share on other sites

You're omitting your system board, Tyler... :)


I believe its insydh20 idk toshiba makes it. Ill know more when I get home.


Edit: insydh20 makes the bios ill know the more when I get home.

Share this post

Link to post
Share on other sites

Just wanted to say thanks for this guide. It took some work, but I think I have just about everything working.


The one tricky part was having to remove the video card, then install OS X, install the Mac NVIDIA drivers, and finally put the video card back, since the GTX 660 doesn't work out of the box -- I chose it for performance/value over compatibility. I also needed to look around the site for the ALC898 AppleHDA kext and then install it, but that was easy enough.


Hardware specs:


MB: Gigabyte Z77X-UD5H

CPU: Intel Core i5-3570K

RAM: 16GB DDR3 1600

GPU: GTX 660 2GB

SSD: Intel 330 120GB

HDD: WD Black 1TB

Optical: Asus DVD burner


Monitor: Asus VH238H

Keyboard/Mouse: Whatever I could find lying around, maybe upgrade later


I put Windows 7 on the SSD and OS X and Linux on the HDD, using Chameleon to chainload GRUB for Linux and using the UEFI BIOS's boot menu for multibooting.


I have to admit that the buyer's guide from the site that apparently shouldn't be named (?) was extremely useful for finding compatible parts (led to a last-minute change of MB), even if I didn't use any software from there. I do understand the strong feelings and strict policy about that issue, though.

Share this post

Link to post
Share on other sites

I don't quite know what to do here. I just assembled my (first) Hackintosh build, ready to install Mountain Lion now.

I'm torn between using TonyMac's software or following this guide. Which one would you recommend?


The issue is not that I'm a newbie. Yes, it's my first Hackintosh, but I've got a lot of Mac experience, have used the Terminal, read this guide and understood it.


I'd go the TonyMac route without hesitation just for convenience, but I'm a bit worried that his fire-and-forget approach is not for my system. I've got a Gigabyte Z77MX-D3H, so that's the VIA VT2021 audio onboard, which is reported to cause problems on the TonyMac forums, while others say it's fixable via post-installation.

Another thing is that I got the Gigabyte GTX 650 Ti already installed, and I don't want to un-install that bloody brick of a graphics card, since installing it in my small case was hard enough.


So, which route to go?

Share this post

Link to post
Share on other sites

Use this Guide, Bradamante, and ask for any assistance here in the topic. There's always someone willing to help.


Personally, i doubt you needed: i myself used it, and had 100% of success even with rather unsupported hardware (AMD, Intel Atom etc).


Best regards!

Share this post

Link to post
Share on other sites

Bradamante, about the 650 Ti, I dunno. Installing OS X (10.8.2) was seemingly impossible with the 660 installed and a total breeze with it removed, but of course YMMV.

Share this post

Link to post
Share on other sites

No idea. It's worth a try. Although Bradamante didn't say what CPU they had, so I don't know whether it has supported integrated graphics.


I got the impression from here and elsewhere that I had to take the card out completely and install OS X and the NVIDIA drivers before I could install it back. I also adjusted the BIOS settings to make sure that the HD4000 got used, something like changing "Init Display First" to IGFX.

Share this post

Link to post
Share on other sites

Yeah, that would have been my next question. My computer case is tightly packed, and removing cards is a pain. I had to disassemble the whole thing.


So, is pulling the power plug from the GTX 660 Ti the same as removing it? The CPU is a i5-3570K, so there's a HD4000. Which is working, when I chose this option in the mainboard BIOS.


Can't you just remove the power plug of the card, without removing the card itself, and use only the HD4000?

Share this post

Link to post
Share on other sites

Alright, I rebuild the case and made the Mountain Lion install (using Tony's tools). It's X.8.0 now and only the WLAN card installed. Now I'd like to install VoodooHDA 2.8.2. Using Tony's tools I did not install any VoodooHDA items.




- Should I first update to X.8.2 and then install VoodooHDA or install VoodooHDA first and then update to X.8.2?


- Same basically goes for the GeForce drivers.

Share this post

Link to post
Share on other sites

1. TMx86 is NOT supported here.

2. VoodooHDA is {censored} and buggy, look up the device ID's of your audio chipset and either install the correct AppleHDA you need or make the required DSDT edits (see DSDT section of this forum for advice on how to do so).

Share this post

Link to post
Share on other sites

Amazing Guide. Thanks. I was following step by step. Windows 7 + VM. When I'm trying to boot, screen becomes black with gray communicate which tells me to restart. After restart use -v command and:

https://www.dropbox.... 00.51.00.jpg?m

After another restart -f command and Apple logo appeared!. Unfortunately it stays freezed. Another restart + command UseKernelCache=No and again freezed logo.

I complete that guide 2 times, 1st with ,,dual boot files" 2nd without.

My config:

Intel Core i3 - 2310m



Edited by Molek

Share this post

Link to post
Share on other sites

Sounds like something is wrong at Step 2.C.1.

You should be copying NullCPUPowerManagement.kext and FakeSMC.kext to /System/Library/Extensions in this step.

It appears that you haven't copied NullCPUPowerManagement. Check those files are in that folder and boot with -v -f and show us a screenshot where it stops.


Although I would note I haven't attempted to install OS X in a virtual machine therefore I'm not sure what smbios you should be using...

Share this post

Link to post
Share on other sites

what vm software are you using?


looks like a graphics issue, try this:


Navigate to /System/Library/Extensions on your instal usb then delete any kexts / bundles which start with the following:











Then boot with -v -f


This should get you to the desktop, if it doesn't I suggest you try over here:


since I have no experience with OS X inside VM's so it may be an error I'm unfamiliar with...


Also note if you use VM Ware Fusion as your VM software (not free) it will allow you to install OS X as if you were installing it to a mac

Share this post

Link to post
Share on other sites

hi there

I have Snow Leopard Hackintosh on my PC ( look the sig),

but would like to try ML with this method!

So I made installation ML USB,on Chameleon Wizard I used iMac 11.1 and i created DSDT.aml with no errors

After starting the instalation the PC starts but it crashes after a sec without any kernel crash

I ve tried with usual {censored} -v ,-x ,GraphicsEnabler=No but still no joy.


These synthoms are usually caused by unsupported graphic card right?

Is there any options I could install ML on my PC

Share this post

Link to post
Share on other sites

I had to reinstall ML after deciding that I wanted to restore from a different Time Machine backup disk. Some observations and lessons learned:


(Hardware specs are a few posts up.)


- I had to use -x for a successful installer boot, also used -v because "why not".


- If you're getting the "still waiting for root device" error, try plugging your USB stick into a different USB port. For some reason, the OS X installer seems to like some ports on my machine but not others. Might have to do with the fact that some USB ports are connected through hubs on the motherboard.


- I had to completely remove the GTX 660 to be able to boot from the USB stick, although I didn't try super-hard to boot the installer with it installed. Just unplugging the PCI-E power cable didn't work, though. I couldn't boot the machine at all after just doing that. As always, YMMV.


- I got the warning "getCPUIDInfo: this is an unknown CPU model 0x3a -- power management may be incomplete" but it doesn't seem to have caused any problems so far.


- I used MacPro3,1 as my SMBios.


I'll update this post if I come across anything else.

Share this post

Link to post
Share on other sites

Because a hackintosh isn't a real mac? It's a different process. Also chameleon won't mount .dmg's so we have to do it ourself.

Basesystem.dmg is the recovery environment we use to install OS X, InstallESD contains the packages required to do so.





Try booting with: npci=0x2000 -v -x -f

If it still gives "still waiting for..." check your HDD isn't plugged into 6GB/s SATA. If you have different coloured SATA ports, try it in the different colours.


Failing that post a screenshot here if it still hangs.


P.S. -x is safe mode, -s is single user mode





Check out the above link. Still no joy.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.