Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Black Screen Issue on Lion with HD6870

10 posts in this topic

Recommended Posts

Hi everybody,


I build a Sandy Bridge hackintosh some month ago with components listed at tonymacx86 and everything worked nicely like a real mac.

I used the onChip Intel HD3000 Graphics so far.

Now I upgraded to a PowerColor Radeon HD 6870 1GB.

System boots well, playing games works also without any problems.


But when I surf the web, I get a black screen after about 10 minutes and I have to reset the Hackintosh to reboot.

I tried several AtiConfig Framebuffers, but nothing solves the problem.


As I saw that some users got this card working OOB, I dunno what I'm doing wrong.


I also installed Windows, no issues there.



Does anybody have an idea what causes this problem?


Thanks in advance!




System specs:

CPU: i5 2500K

Mem: 8GB DDR3-1600

Board: Gigabyte Z68X-UD3H-B3

Graphics: Powercolor Radeon HD 6870 1GB

System: Lion 10.7.4

Share this post

Link to post
Share on other sites

Hi, yes I tested both DVI and the HDMI Connectors, same problem on every port.

I didnt test the two Mini-DP Connectors as I dont have such a display or adapter.


EDIT: Just tried to reinstall Lion, Error still occurs, now I have a light grey screen with vertical lines

Share this post

Link to post
Share on other sites

I had the same problem with my 5870 posted in here some 3 months ago. I could not rely on either the 2 DVI nor the HDMI so bought a Mini-DP and tried it and it worked :)

Now why we are getting black screens I really don't have a clue tried to solve for almost a year and got it fixed with the Mini-DP cable. It may not be your case though, but from what you are saying is very similar to the problem I used to have.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.