Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

[SOLVED] "You must restart your computer" Grey screen of death after using Lion for awhile

12 posts in this topic

Recommended Posts

So after installing Lion on my new Hackintosh it works perfectly for awhile. But after about 20 minutes, or up to 30 minutes;


I get the error "You must restart your computer" the screen slowly fades to grey etc.


Any idea what's going on?


CPU: i7-2600

GPU: Nvidia GT 530 1GB

HDD: 1TB Caviar Green

RAM: 12GB DDR3 1333



Installed flawlessly and boots up without a problem. The only issue I have, is it doing this after a small amount of time? I can feel that I am almost there!

After crashing I sometimes lose my sound also, I have no idea why but it just doesn't initialise with the computer. This only happens after my PC has crashed :/


EDIT: This only seems to be really happening when I am torrenting something, using either uTorrent or Transmission. So it seems to be something to do with the hard drive... I have no idea what is going on...


Any ideas?

Share this post

Link to post
Share on other sites

Didn't realise discussing that was banned :o edited my post.


Minor edit: Very funny :P except that this has happened 25 times now.. and it stops me from being able to do anything :/

Share this post

Link to post
Share on other sites

booting in verbose mode by using -v also logs additional info while osx is running and if it kernel panics (which is what yours is doing) it will show the extension and back trace info that caused it on the screen, instead of just saying restart. So then you can take a picture and post it and finding the problem will be doable. I suggest always booting verbose, at least the first couple weeks.

Share this post

Link to post
Share on other sites

Thanks a ton for the info. I fixed the permissions and so far it's been about 5 hours and there hasn't been any crashes. It crashed once an hour after I fixed permissions but that was the moment I ran a 'firewall' program. So I think it may have had something to do with that. I'll reboot the machine and run it in -v verbose.


So running it in -v means that it will give me an error screen next time that the crash occurs and I can read what the problem is? I thought it only 'booted verbosely'


Thanks again for the info :) my PC seems to be a lot more stable now anyway. I'd say I'm 99% of the way there.


Ok it crashed again, and then I rebooted and it crashed again instantly.. Here is a picture I took:




Can you guys make anything of that?

Share this post

Link to post
Share on other sites

yup, it's your ethernet which explains why it happens when torrenting


what chipset is your ethernet?

Share this post

Link to post
Share on other sites

Ok.. so what can I do to fix it? If I use my wireless.. my speed is far, far less than if use my Ethernet.. is it just a case of what kext I am using for my Ethernet? Can I use a different one, will that fix the problem? This rebooting issue is the only negative thing I am dealing with when using this Hackintosh... I'd really like to be able to not have to worry about crashes.


EDIT: Apparently according to this: http://www.asus.com/...#specifications


My ethernet is a: Realtek® 8111E , 1 x Gigabit LAN Controller


I'm not 'usually' as dumb as I look but from that kernel panic it looks to me as if my Hackintosh is using the .kext RTL8169 for my Ethernet... am I right or wrong?

Putting 2 and 2 together would suggest that it's using the wrong .kext? Or am I barking up the wrong tree here...

Share this post

Link to post
Share on other sites

try replacing existing appleRTL8169 kext with one from here http://lnx2mac.blogspot.com/2010/09/lnx2macs-realtek-rtl81xx-driver-goes.html I think his installer will remove the old one for you


repair permissions and rebuild caches b4 reboot. can use kext wizard or terminal to rebuild the cache: sudo touch /System/Library/Extensions/

Share this post

Link to post
Share on other sites

Thanks for being so much help. I rebuilt permissions and deleted the cache. But after running the installer it didn't look like the .kext was removed... When I went to Apple > About this Mac > More Info > System Report > Ethernet cards, it was still the appleRTL8169 after the installation. So I would assume that i was still using the problematic .kext.


I then pulled up another terminal and ran: cd //system/extensions etc. etc. etc.

then I removed the .kext with: sudo rm -rf AppleExtensionEthernet.kext etc.


Now I'm going to do a reboot and try running the installer again because something tells me it didn't remove the .kext for me and I just did.


Apple > About this Mac > More Info > System Report > Ethernet cards, now shows an Ethernet card but no .kext is referenced.


EDIT: Ok rebooted and got a pretty uninformative kernel panic: nnptgh.jpg


Rebooted again, no problem. I didn't run the .kext installer and I'm going to try running it now..


EDIT AGAIN: Ok it still doesn't look like anything has changed in system settings.. there is still no .kext referenced. So I don't know if it's working or not. I'm going to do a clean install. Fingers crossed that this will be the last one I have to do.

Share this post

Link to post
Share on other sites

Did you just go from trying to install ethernet kext to redoing a clean install in the same post? Did you check date modified of kext in s/l/e to see if it changed, check loaded extension in system info while you were there for same info and kext version #? In terminal try: kextstat? Verify no copyright infringement on that avatar? Boot with -x if needed to get past KP, or even -s to remove kext from command line if need be?......I'll stop. But that was kinda funny. And I haven't had a board in a while that used that controller so honestly don't know if it should look different in sys info or not. Next time if you run the installer, then reboot, and it work's, don't do the rest of what you did :) If your worried it's the old one, remove it, reboot and verify no more ethernet (after dowloading replacement), run installer, reboot, if ethernet comes back, it's not the old one.


p.s. I assume you meant repaired permissions and rebuilt cache, but be very careful what you do in terminal, especially when using sudo, what's the etc. etc. part after that? To misquote a show about nothing, "there's no yada, yada sudo"

Share this post

Link to post
Share on other sites

I've been running Linux for a few years so I know the dangers of running the Sudo command. The installation is only a Hackintosh and can be rebuilt within about 20 minutes from my Lion USB with absolutely no trouble at all. I simply wiped the system and then reinstalled all of the .kexts properly the first time around. It's been 3 or so days now and I haven't had any problems with shut downs or anything. Though the PC did crash just once from going to 'sleep' and then never waking up. I just simply turned sleep off and haven't had the problem since.


Thanks for your help you were undoubtedly the one who found the fix for me and now I have a fully working Hackintosh, Linux and Windows 7 machine. I am very grateful.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mr.Darkwraith
      Is it possible to install/run Android TV/x86 on the 1st generation Apple TV?
    • By pepitillo
      Hi there,
      The title says everything, I got a perfect build, with everything I want, but when I shutdown my hack it turns into rebooting.
      The build is in my signature. I've tried fix_shutdown in clover, and other patches, and none seem to work.
    • By Angelo_
      Hi guys, i'm trying to help a friend of mine trying to install osx(possibly high sierra) on his pc with the following specs: 
      Amd fx8350 
      Asrock 990fx extreme 3
      8gb of fury Kingston ddr3 ram(2x4)
      Radeon hd 7950
      128gb ssd( crucial m550)
      A couple of hdds I don't remember the brand(maybe a seagate barracuda and a dumb old disk for data)
      We tried to install it using the regular clover+high showers installer but we couldn't get it to reach the installer, then we tried osx-amd(don't know if i can talk about it there, sorry if i can't) and we still couldn't get to the installer.
      Is there a guide i can use to install osx in that machin, i tried to search in the forum but i couldn't find it.
    • By lucasrm654
      Eu instalei o Hackintosh, porem uso um Cougar 200k, meu teclado, e a tecla shift, windows e alt não funcionam, não executam função nenhuma, já o Ctrl funciona como Shift, gostaria de saber como eu posso atribuir funções a essas teclas que não fazem nada e mudar a função do Ctrl.
    • By Dallastyle
      Hello Insanelymac,
      I've successfully installed Mac OS X Sierra on 2 32gb flash drives with them as a JBOD Raid. I can only get into the hackintosh if I use another USB flash drive with Clover installed on it. I've tried using a clover installer however that just installs on my Raid Disk. I've also noticed that when I open clover configurator, there are 2 EFI partitions but both of them were empty. I've tried moving the contents of the EFI on my Raid disk that clover installed but my BIOS does not detect it. Also when I use the other flash drive to boot into clover, there is another volume called "BOOT OS X" right next to my Raid Disk Volume that I use to boot from. I just want to install and boot off of my Raid usb flash drives. Really running out of options, Thanks guys.