Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


ML DP3 on Asus Rampage Gene II - help with boot delay

8 posts in this topic

Recommended Posts

I have ML DP3 running nicely on my Asus Rampage Gene II but I'm experiencing a long delay during boot.


Here's a the part of the log that shows the delay:


IOAPIC: Version 0x20 Vectors 64:87
IOAPIC: Version 0x20 Vectors 88:111 <- sit's here for 75 seconds then continues
ACPI: System State [s0 S3 S4 S5] (S3)


The system then continues to boot and so far as I can tell everything is working fine including sleep, network, and audio (with DSDT and kext for audio).


I was looking for advice as to how I might debug the cause of the delay, anyone?


A few details:

  • System specs in my footer.
  • The install method doesn't seem to be a factor, I've tried 3 different methods to install and they all succeeded (but with the above delay).
  • Everything boots without any additional kexts other than FakeSMC (Lacks audio, network, sleep and the disk icons are orange).
  • I have nothing enabled in my org.chameleon.Boot.plist
  • I created my own DSDT (from Linux) and patched it to enable audio (with kext), sleep and to fix the orange icons (it didn't effect the boot delay)
  • The delay is not present in my Lion 10.7.3 install.

Share this post

Link to post
Share on other sites


Thanks very much, replacing AppleACPIPlatform.kext did indeed solve the boot delay issues, boot time is around 10 seconds now :-)


I tried v1.4 initially (from my working Lion 10.7.3 install) but still experienced the boot delay, I then tried v1.3.6 and all was well.

Share this post

Link to post
Share on other sites

I've just noticed that this kext prevents the kernel cache from building successfully.


Can anyone outline how I might debug this problem?

Share this post

Link to post
Share on other sites

no problems with kernel cache on mine, did you try deleting them manually or use kext wizard to rebuild? At one point on DP2 when I was trying everything I could think of to find a fix for the boot time, I did get issue where console would show error trying to rebuild cache and all kexts would load on boot. Clean install with AppleACPIPlatform.kext rollback fixed it and no problems since. I am using 1.3.5

Share this post

Link to post
Share on other sites

OK, I installed 1.3.5.


Tried deleting the caches manually and rebuilding via kextwizard but it failed to generate caches.


Tried manually building cache using: sudo kextcache -update-volume /



kxld[com.apple.driver.AppleACPIEC]: The following symbols are unresolved for this kext:
kxld[com.apple.driver.AppleACPIEC]:  _AcpiHwRead
kxld[com.apple.driver.AppleACPIEC]:  _AcpiHwWrite
Link failed (error code 5).
Prelink failed for com.apple.driver.AppleACPIEC; aborting prelink.
Failed to generate prelinked kernel.
Child process /usr/sbin/kextcache[376] exited with status 71.
Error 107 rebuilding /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache.


Can you run that command successfully?


If I put back the original ML DP3 kext the cache builds fine, but I get the 75 boot delay.


This is by no means a show stopped, just a bit annoying have to either wait for the delay or have no kernel cache.

Share this post

Link to post
Share on other sites

Yes, no results- which only means no errors. I then ran it at -v 2 verbosity level and -v 4, only results are that caches are up to date and no helper partitions to update(but not running a RAID on ML so there are not suppose to be any). Did you try "touch" S/L/E?

Share this post

Link to post
Share on other sites

Nope, touch isn't helping either.


I'll live with it, the ML code isn't final yet so there isn't much point getting to involved I guess.


Thanks for your help.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.