Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

[Solved] Windows 7 can't hibernate.

11 posts in this topic

Recommended Posts

Hey guys, I have Lion working and Chameleon is set as the bootloader. I boot into Windows via Cham but Windows can't hibernate. I have it installed on one HD.


Here's how I installed it:

  1. Installed Windows 7
  2. Install Lion on top of it under a partition.
  3. Boot broke and I got boot0 errors so I had to manually install Chameleon. (I have one of those 4kb harddrives)
  4. So it all works now. When I turn it on boot0 flashes and Chameleon loads.

So what could I do? I am thinking to set the Windows partition active... but then Chameleon wont load and Ill have issues booting into Lion.


Kinda confused. Help?


Thanks :)

Share this post

Link to post
Share on other sites

Ah the joys of MBR, 4k sector drives and Windows requiring an active partition..


This is a known issue. In addition to not being able to hibernate, you will not be able to install Windows 7 Service Pack 1.


When installing Chameleon, use boot0md instead of boot0/boot0hfs.



Chameleon doesn't have to be on an active partition.

Share this post

Link to post
Share on other sites

Ah.. almost there.


So after installing Chameleon to boot0md do I set Windows partition as active? Or let it be..

Share this post

Link to post
Share on other sites

You should give it a try. Gets you heavy geek points among your friends ;)

Share this post

Link to post
Share on other sites

I too have been experiencing the same problem, hoping you guys could help.

Windows 7 won't go into hibernate, it just turns black for a bit then comes back on. This can be annoying if I forget, shut it into sleep, and 10-20 minutes later it goes from sleep to hibernate and just turns right back on.


I've restored the MBR to the default Windows 7 loader, and then Windows 7 successfully hibernates.

I then used a live CD to go into my OSX partition and used Chameleon Wizard to install the newest Chameleon to boot0md.

I then went back into Windows 7, tested hibernate, and it doesn't work again.

I've used Easeus partition master to check if windows 7 is active, but it's status is "boot" so for that reason I can't change it to active. Any other partition on my drive I can change to active.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.