Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

[SOLVED] nForce ethernet on iATKOS L2

4 posts in this topic

Recommended Posts

I recently installed iATKOS L2 on my Acer Aspire X1700, and so far everything is working well (graphics, USB, drives, etc.) except for LAN and sound (VoodooHDA was causing kernel panics, so I reinstalled with only Apple's and it failed). I have an NVIDIA nForce ethernet card, and it was supported in Snow Leo (iATKOS S3 v2), but in Lion, there appears to be an NVEthernet driver installed already, but it isn't working properly. Is this driver available?


SOLUTION: Replace Apple's nvenet.kext (inside IONetworkingFamily.kext/Contents/PlugIns) with nForceLAN.kext. It still stops working after a little while, forcing me to reboot or reload the driver, and kernel panics frequently.

Share this post

Link to post
Share on other sites

Ok, since nobody apparently knows anything about this, here's my solution: Go into IONetworkingFamily.kext and find the PlugIns folder. Replace the stock "nvenet.kext" with an nForceLAN driver, and you'll have unstable internet for a while, until it kernel panics to hell.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.