Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

neo sonic

4K Advanced Drives problem

1 post in this topic

Recommended Posts



To summarize the question: I'd like to know if there is an updated version of any bootloader (PC-EFI, Chameleon, etc.) that actually works with 4K drives.


Now, the full story:


I was wondering if the problem with 4k advanced drives was cleared. I did a search on the forum but didn't find anything. So, here goes.


When I was attempting to make a hackintosh out of my XPS M1530 lappy, I was able to run OSX when installed on a 1TB external drive. I was also able to install it on a 500GB internal drive that it had, plus I was able to dual-boot with Windows 7. The internal HD failed, so I went and bought a 750GB drive from Seagate, thinking, AHH, more space, I'll be able to dual-boot and not come up short in space. BIG MISTAKE.


The drive fit perfectly. It ran Windows 7 perfectly. It REFUSED to boot OSX. AT ALL. It was always a boot0 error or something. I installed it alone, tried dual booting, but it never booted. It would only boot if I used a chameleon usb stick or a boot cd to select the OSX partition. It ran perfectly. It just refused to boot on its own from the hard drive itself.


I searched for info here, but didn't find any at the moment (circa May 2011). I googled it, and I found out the problem: my Seagate hard drive was one of those new 4k sectors advanced format hard drives. Apparently all OSX PC bootloaders have problems with these drives. Used netkas' PC EFI, used Chameleon, even used another alternative (which happened to be a modified version of Chameleon, so the problem was still there... forgot the name... what was it...), but no-go. I even tried several troubleshooting steps others have mentioned, like, writing the boot0 (dunno if that's the file, but assume I'm mentioning the correct one, I was following instructions back then, now I'm just speaking from memory) manually using the console on OSX, and checking to see if it was there. ALL the time, it got wiped. And it was all the advanced drive's fault. I was told to make a smaller partition, same result. Didn't matter if the partition was the first or the second in the drive. I tried everything and the same result kept popping up, boot0 (or was it boot1h?) error. I am very knowledgeable in computers, and I can safely say I did everything correctly, but to no avail.


Unfortunately, I sort of overstressed my GPU and it got de-soldered (a recurring problem with nVidia GPUs, mine was the 8600M GT) and I lost my laptop. I can still fix it by buying a replacement motherboard and I'm good to go. But before I do, I'd like to know if there is an updated version of any bootloader that actually works with 4K drives. If there is, fine. If not, while I get the new mb, I'll sell the HDD and buy one that isn't 4K... hopefully there is something over 500GB like that that can fit inside the M1530...


I apologize if this has been discussed elsewhere. I did use the search and came up with nothing.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.