Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Lion on Asus X53SJ (mobo K53SJ)

1 post in this topic

Recommended Posts

This is my experience about installation of Lion on Asus X53SJ laptop (motherboard K53SJ)


Installation was made following this guide posted by MaLdOnhttp://www.insanelymac.com/forum/index.php?showtopic=256729, but to make it work I needed to put the MacBook Pro 8.1 extra pack onto the usb stick (overwriting existing files and re-building extensions.mkext with KextUtility), otherwise installation stucks on "DSMOS has arrived".

Boot first time with busratio=29 PCIRootUID=1 GraphicsEnabler=Yes arch=i386


Working (kexts are posted here by marcvaz http://www.tonymacx86.com/viewtopic.php?f=...amp;hilit=k53sj):

HD Graphics: out of the box

Battery: VoodooBattery.kext

Wireless: aterosfix.kext

Audio: AppleHDAdisabler.kext + voodooHDA.kext (not through [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], some error has occured)

Ethernet: Realtek 81xx from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

Keyboard: ApplePS2Controller.kext + AppleACPIPS2Nub.kext


Not working:

Webcam: works out of the box, but the image is rotate by 180° (someone has an idea to fix it?)

Trackpad: Elantech touchpad works only as mice with ApplePS2Controller.kext + AppleACPIPS2Nub.kext. I've tried different solution with no success (with voodooPS2controller doesn't work at all)


Nvidia GT520m (trick for GTX5xx series seems not work)


Boot time: is very long, about a minute. Ok, this is not my desktop machine that start in a half second, but I expect better from a i7 based laptop..


Hoping this help.


Many thanks to MaLdOn and marcvaz for their threads, downloads and informations

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.