Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

G4 mirror door 1.25 Ghz

2 posts in this topic

Recommended Posts

This is my first time to post a request for help. 70 yrs old, and know very little about my mac. I have a G4 mirror door 1.25 Ghz that runs excellent except if it is cold it will not start up. If I leave the wheel spinning for 20 min. it will then start and after starting it operates excellent, however if I put it to sleep, it will only wake up if I wake it within 15 min. if i wait longer I have to force quit it, then power up again, which works excellent after the restart. My first sympton was upon cold start in the morning the clock would be not set correctly, I would reset it and all worked fine, even the sleep mode, and it started correctly in the morning start. Then it didn`t want to wake up, then it had a normal start to the spinning wheel, but not go any further unless I left it in that state for about 15-20 min., then restart and it started and ran normal. so I replaced the battery and that fixed the clock problem but the rest still is the problem.


So here is how it happens. I make a cold start, computer comes on correctly, but I only hear a very few clicks in the processor, and there it hangs with the wheel spinning. I leave it in that state for now 20 min. and do a restart and it starts correctly, and the processor clicks right throu the complete startup, and all is normal. It`s like the processor just sits there waiting for power or something to tell it to run.

Does anyone have any idea how I can get it to do a cold start like it used to do<???


Thanks for any assistance and advice you can givG4 mirror door refuses to starte me

Share this post

Link to post
Share on other sites

Those are classic symptoms of a failing power supply. It's full of failing capacitors which work better when they're warm. The good news is that it's not too hard to replace the power supply. There's a good supply of refurbished power supplies on ebay, but they're not cheap. I would avoid a "used, but tested good" power supply since it's a ticking time bomb unless it's had the old capacitors replaced.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.