Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Help With an HP proliant server

2 posts in this topic

Recommended Posts

Greetings, I am having some difficulty getting osx to run on an HP DL580 G3 server.

I have tried several methods to boot including boot-132 and iAtkos v 7. Keep in mind that I am new to the osx86 community, and so I may have missed an important step. For instance, I havent really been able to get the kexts that I believe to be the correct ones on to a boot-132 disk, so mostly I have been using pre made iso's.


Currently, I can either boot and get it to freeze at the grey apple screen, or if I boot in verbose mode, it loads all of the kexts and then restarts the server.


My specs are

Intel e8500 chipset - I cannot fins much info on this, but I believe it is AHCI.

4x 3.66 Ghz Xeons. I have checked on wikipedia, and these appear to support sse3

EVGA Nvidia 8400 gs w 512 mb ram (PCI)

1 GB Ram


The kexts that I have been trying to put into a boot-132 CD are:

AHCIportInjector - for the chipset

ApplePS2Controller (im using a ps2 keyboard/mouse)

NVinject ( for the video card)


any help would be much appreciated.


Share this post

Link to post
Share on other sites

Alright, I have disabled hyper threading, and determined that it is an ICH5 chipset (apparently e8500 and ICH5 are very similar.)


I have assembled a boot CD, with the kexts that I had decided on but I still get the same error. I tried adding the cpus=1 argument, same thing. I did not use the kext for sata on an ICH5 chipset, the drive is sata but it goes through a controller, not the motherboard. Would it boot even without seeing the drive?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.