Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

G. Steel

Success! ECS 945GCT retail DVD modbin test 7 kernel

2 posts in this topic

Recommended Posts

I spent 80 hours until finally a fully working snow! Snow Leopard from retail DVD (buy it while its fresh) on my humble but awesome machine.


The key was following AMD install method even though this is an Intel board its a little dated now.


First, if you don't have one of those snazzy AHCI motherboards be prepared to read a lot of information and continuous trial and error.


With that in mind you need to reduce your cycle time, either a USB stick or external USB drive is highly recommended.


Setup Test environment


Get all the tools (OSX86Tools, MKext Tool, EFIStudio, DSDT Patcher GUI, ShowAllFiles etc.)



working 10.5.x (ext USB)


\---- snow (GUUID) 1st partition

\----- sninst (GUUID) 2nd partition


from your working Leopard (e.g. iPC 10.5.6) use Disk Utility to do the following:


i) create dmg image of retail dvd (google how), do not alter, you will use this to refresh sninst your Snow install disk

ii) restore dmg onto sninst


iii) Go to Folder shift cmd G (in the Finder) /Volumes/sninst/System/Installation/Packages/

iv) double click on OSInstall.mpkg; make sure it is the mpkg file

note: if you are using MBR partition you will need to alter or get an altered OSInstall.mpkg; so I went with GUUID


v) You will need the AMD install method bto use modbin test 7 kernel and boot file.

vi) Install Chameleon RC3. You can hit the tab key on the Chameleon splash page to see the boot messages.

vii) replace kernel and boot on snow with modbin test 7 versions

Caution: when running the various tools available (Thanks OSx86tools, MKext Tool, netkas.org, chameleon team)

make sure you are either booted up in snow or specifically target that partition, you don't want to hose your working machine.



Helpful links:

installing Snow Leo retail

Windows live helpful Kexts and topic

Vanilla install automated!

Revised LegacyAppleAHCIport.kext & LegacyJMicronATA.kext, For using Intel & JMicron SATA & PATA ports without conflicts

Desktop GMA950 fixed!


I use the arch=i386 kernel flag so that my SATA/HDD show up. Don't obsesses over 32-bit/64-bit get the thing working first.



Share this post

Link to post
Share on other sites

Thanks to you, I spent less than 2 hours installing my ECS 945GCt-M/1333.


Bought a boat load of these mobos at Fry's on sale a few years ago for cheap PCIe, LGA775 boards. But this was the cheapest build yet:


- ECS 945GCT-M/1333 v3 - $9.90 (2yrs ago price at Fry's)

- Celeron 2.5GHz Dual Core E3300 - $34.99 (microcenter - still going on sale - Fry's will match!)

- 2GB DDR2 Super Talent 667 Rigid - $29 (bought a while ago)

- IDE, NEC/Toshiba DVD-R/RW burner - set as primary w/ ribbon ($18 NewEgg from years ago)

- 160GB Maxtor 3.5 inch SATA 3.0 HD - connected to 1st SATA port ($29 Refurb )

- Antec NSK1380 shoe box case (Free - junk pile at work! 80plus 350Watt PSU!)


that's about $120 of supplies plus tax and shipping.


1. Mobo settings - had to search and download/flash latest BIOS on the board to recognize E3x00 series of 45nm Celeron Dual Core processors. Hints: I searched and found a USB DOS formatter for USB sticks on WinXP. Used a cheap, old 512MB stick, and once it booted to DOS, I then put that on any system and added a set of flash tools. ECS site has latest BIOS (11/2008?) for 945GCT-M/1333 v3 board. Once done, I loaded BIOS defaults, then set boot device to CDROM first, HD second. Set fixed size instead of DVMT for graphics, and set to 128MB. Enabled C1E, Virtualization, Core Multiprocessing. Checked boot and power management to enable PME and to allow USB keyboard wake.


2. SW needed - Used TonyMacx86 [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] latest and burned it to iso. Had stock Mac OS X 10.6.3 install DVD media, plus [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], VoodooHDA-2.7.2.pkg, GMA950 ECS945 version of DSDT.aml. And I downloaded latest kext utility.


3. Installation - wow. Easy. Stuck [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] disk into optical drive and booted to [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] icon on screen. Eject, stick Snow Leopard 10.6.3 media into drive, close, hit 'F5' to refresh, then typed '-v arch=i386' hit return.


4. Mac OS X installer came up in stretched-out (no Quartz) 1024x768 on my wide LCD screen. Ran disk utility, named the drive and Erased/formatted the SATA HD as single MacOS Extended and Journaled filesystem. Exited, then went directly in the same session into the installer. Installation completed, I rebooted, ejected Mac OS X installer disk and then inserted the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. When the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] select appeared, now it sees a bootable GUID volume where I just installed. Select and boot from the just-installed HD. Network comes up automatically, the audio also seems to come up with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] boot disk first.


5. Post install - I used the network (Realtek 81xx) 10/100BaseT which works out of the box with stock drivers. Copied over a bunch of apps, and kexts (mostly not needed) . I then ran [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] installer. This is where it got a little weird. After removing [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] disk and rebooting with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], system comes up and I lost audio and still have GMA950 issues, even though the System Profiler knows the type of graphics support. I went to /Extra and looked in smbios.plist to no available. I looked in com.Apple.Boot.plist and removed the GraphicsEnable lines (including the line below -Yes-)

and I set the Timeout on the boot to 5 seconds (rather than 1 second) so I have some time to actually hit the keys and not automatically boot. Set boot args to "-v arch=i386". Rebooted. Still Graphics stuck in 1024x768.


5a. Post-install hacking - Looked at difference between K45 shuttle and this system and this one using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]/LifeHacker recommendations doesn't have a default DSDT.aml file. But weird that audio was working stock with the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] DVD as the bootloader, and not after using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. I believed this was due to a lot of /Extra/Extensions/ stuff put there as Kexts for all sorts of stuff. So I moved all of them to a backup folder in the root (/) except for fakesmc.kext and rebooted. Still booting, but still no audio and no Quartz graphics. But clearly, I don't need those /Extra/Extensions to boot it seems, including NullCPUPowerManagement.kext, which appeared to have blocking attempts to get my system to sleep.


5b. More Post install - fixed - decided that the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] EFI strings injection just isn't properly passing through HD Audio controller settings. Could be that on-board stuff is passed through in the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] CDROM image that allows the AppleHDA.kext stuff to simply introspect and discover the Codec (Sigmatel 9221 series or something like that on mine). But the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] is a different "beast" and may be obfuscating the pass thru or mapping it to some UEFI spec which Apple may not actually adhere to. Don't know. But decided to try VoodooHDA.kext lastest (which kernel panics my other attempts using it with K45 shuttle for example). Ran kext utility to set perms kosher, and reboot, and voila - audio plays and discovers speakes dynamically,front, rear, etc. Nice. Similar solution with Graphics. quick search on GMA950 on ECS for OSX leads to missing a DSDT.aml definition for GMA950. I downloaded, unpacked and copied verbatim to /Extra/ folder, then rebooted. Voila, smaller pixels and wider screen. Test that VLC 1.1.7, which requires Quartz acceleration has video and it plays.


5c. Stick XXX with Vin Diesel DVD into drive and it plays with default Mac OS X player.


6. Unsolved problem - sleep works if you explicitly go to Apple-Menu and click and select sleep. This appears to power off the system and mouse movement and keyboard still aren't waking it up. But if you push the power button, system comes up in 4 seconds to exact screen where I left off so I know suspend-to-RAM is working. Need to check if something is resetting BIOS since I've enabled wake-on-usb kbd/mouse events. And I can't get the System Prefs - Power Saver to kick in correctly even if I wait for 10 - 15 minutes and it's set to go off in 5 minutes and I've rebooted too just to make sure the setting is in effect. So currently, I can't time out the box automatically if nobody's using it. Still trying to figure this one out. Possibly thinking some DSDT.aml incompatibility.


Not bad for $120 in HW costs.




Edit (2011 Feb 22) - Installed 10.6.6 Combo Update and not only didn't have sleep working, but shutdown and reboot hang. Lost some sleep trying to find a solution. Tried latest SleepEnabler.kext for 10.6.6 and it KPs. You can turn it off at command line luckily during [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]/Chameleon by appending flag 'pmVersion=0". Then found other notes online where we need to set hardware Jumpers USB_PWR_F and USB_PWR_R on the mobo and set them to allow wake from USB properly, then applied RIP3lanNet.app (apple script to watch SysPrefs settings for time since last input and some other load based heuristics) now sleep is forced upon the system at the appropriate times. Not the prettiest of solutions, but I finally got it to work. For some reason, users have a heck of a time with permissions for anything in their own directories or even in the Applications directory. And the sleep would NOT forcibly work because the system reported an issue with permissions based on user session. So my solution was open a root terminal a la UNIX style and go in there and chmod og+rx RIP3lanNet.app plus go inside the directory and manually make things kosher. In order to allow other users to see and use this, I moved this to /Applications and chown -R root:wheel RIP3lanNet.app/. Now system sleeps for Users, but each must still install this into their System Preferences -> Accounts -> Login Items so it starts upon login. I downloaded DSDTSE app and spent some hours perusing DSDT.aml settings provided for the ECS 945GCT version. Looked all kosher, but after some hacking around, my system was suspending, but not rebooting or shutting down fully to BIOS boot. System was halted and filesystems unmounted, but the BIOS appeared to think it was still in suspend. Felt like an ACPI incompatibility in default Apple software with this board. I ended up putting back ElliotForceLegacyRTC.kext and ev0reboot.kext into /Extra/Extensions with fakeSMC.kext to get system to reboot and poweroff correctly. I think I also ended up loading defaults again in BIOS, which sets GMA950 graphics to DVMT mode (not fixed) and I went into Power Management BIOS menu and changed the 4-second delay for SW power button to Instant Off, and checked the Wake on PME was still enabled and turned on S3 Wake from USB again (off by default). Reboot on the first time, still hung. I pulled power cord, hit reset button and power button to dissipate power and replugged. Now magically, and weirdly, the system is sleeping, rebooting, shutting down as would be expected and wake on USB keyboard/mouse is working too.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.