Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Hope for AR5007EG?

81 posts in this topic

Recommended Posts

i have airport but not active and not scanning.

i remember in the past , for atheros ar5005ag i had the same, but if installed a framework from a leopard airport update the card worked.

the update was AirportExtreme of 02-2007, the framework were putted in /system/library/frameworks/kernel.framework/versions/A/

how to find a similar framework for Snow Leopard?

Share this post

Link to post
Share on other sites
Hello. I was comparing linux drivers for AR5006 and AR5007EG. Then I applied the same changes to AirportAtheros. I changed:

-Removed card revision check

-Replaced RfBanks and registry tables

-Changed default radio revision

-Modified channel changing routine

-Never reset PCI Express-core fix

-Removed EEPROM size check

With this fixes driver now loads, I have Airport icon but no scanning or associating. But my card also bugs under linux. So it's possible it has some defect or is buggy. Additionally for me 802.11a would represent some advantages so tomorrow I go to the local stor to buy AR5008E-based abgn card (they work very well according to reports). So I post this work as is and probably won't continue it. But if someone is interested he can continue it.

P.S. @developpers: I wrote a helper application that allows to add data to __DATA__ section. It's ugly but if it could be useful for you say it here.


Thanks worked with Samsung R418 - Atheros ar5007eg (AirPort Extreme (0x168C, 0x7131))

Install, kext permission with Kext Helper, reboot, Airport on, kisMAC scan - profit

Share this post

Link to post
Share on other sites

This is probly a little bit late but I still cannot figgure it out. I insalled the kext on page 1. It detects but it says off and i cant turn it on. kismac wont load the driver says cannot instantiate driver??? help

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.