Jump to content
crazybirdy

Catalina MBR HFS Firmware Check Patch 10.15.x

By crazybirdy ( Find their other files )

1 Screenshot

About This File

Patched OSInstaller.framework to allow macOS 10.15 installation on MBR HFS+ partition.

 

Please read Readme-10.15.pdf first.

 

How to finish the Catalina installation.

1. Use EasyMBR-Installer1015 to make USB Catalina Installer.

2. Boot to USB Catalina Installer, open Utilities -> Disk Utility, format as MBR HFS+. 

    Install Catalina to blank MBR HFS+ "Target" partition.

3. Boot to USB Catalina Installer, open Utilities -> Terminal, run the script command:
    copytempdata

4. Boot to "Target" MBR HFS+ partition on single user mode (-s), run the script command:
    hfsupdatecache

5. Reboot to "Target" MBR HFS+ partition, setup user name and login, finish the installation.

 

Also, you need to setup Clover as BooterConfig=0x28, CsrActiveConfig=0x67

 

----------------------------------------------------------------------------------------------

List of known issues:

1. Some app-pkg-installers can't install to HFS+, but install to APFS fine.

----------------------------------------------------------------------------------------------

 

What is this patched OSInstaller doing?
1. Pass the MBR check, allow macOS 10.15 installation on MBR partition.
2. Pass the Firmware check, bypass the error of "
An error occurred while verifying firmware".
3. Pass auto-convert to APFS , "
ConvertToAPFS=false" is no longer worked with 10.15.
4. This MBR-Manual-Method will never convert to APFS, and will always install as HFS+ partition.
5. This MBR-Manual-Method
works with both MBR HFS+ and GPT HFS+ partition (GPT+recovery).

No longer need to set new SMbiosversion, FirmwareFeatures, and FirmwareFeaturesMask with this MBR-patch.

 

What's the difference between createinstallmedia method, MBR-Manual-Method, and MBR-Automatic-Method?
As the following....
1. createinstallmedia method,

    needs stage 1, stage 2 installation process, which is worked with GUID partition only, always convert to APFS format.
2. MBR-Manual-Method (same as 10.12),

    install via stage 2 manually, which is worked with both MBR HFS+ and GUID HFS+, will never convert the partition format.

    We can manually format as MBR HFS+ or GPT HFS+ on installation screen like as 10.12.

    We can manually select MBR HFS+ partition to install 10.13, 10.14, 10.15 on installation screen now.

    Needn't to update the MBR-Manual-Method files, it will still work on 10.13, 10.14, 10.15 future versions, I think so.

    It can be installed as Fresh installation on formated blank partition only, but can't be installed as update from previous version.

3. MBR-Automatic-Method (new for 10.13+),

    End of MBR and HFS+, there is no more MBR HFS+ patch available for 10.15 native OSInstaller.


How to make 10.15 installer for MBR (MBR-Manual-Method)?

Just use EasyMBR-Installer1015 to make installer, it works with both MBR and GPT.

Read HowTo inside the dmg first, same as 10.12.

Read HowTo Q/A Q4. How to patch to work with CPU SSE4.1 only for Mojave, Catalina?
Read HowTo Q/A Q6. How to download the full installer app via swscan.apple.com, instead of App Store?
Read HowTo Q/A Q7. How to update 10.15.x combo-update to MBR and GPT with installScript directly?

 

And, need a SMBIOS supported with /System/Library/CoreServices/PlatformSupport.plist.

 

EasyMBR-Installer1015.gif.ab373930df1491897bea137258ae8d39.gif

 

Q6. How to download the full installer app via swscan.apple.com, instead of App Store?
A6. Some people download installer app from App Store, and get only 18 MB size, not the complete installer app (5.68 GB). You should boot to 10.12, or 10.13 to download it again from App Store, or use script Q6-DownloadFullApp/installScript_fullapp to download the full installer app via swscan.apple.com.

 

installScript_fullapp.thumb.gif.963b53da652e145e4ef5a4d461859f0a.gif

 


What's New in Version 10.15.x   See changelog

Released

2019.12.09    Update Q3-HFS+UpdateCache/hfsupdatecache with "kextcache -i /"

2019.12.06    Update Q6-DownloadFullApp

2019.11.02    Add Old-macOS-10+11+12/installScript_1012fullapp.

2019.11.01    Update Q7-Update-installScript.

2019.10.23    Update List of known issues:

2019.10.10    Update Q7-Update-installScript.

2019.09.11    Update Q6-DownloadFullApp and Q7-Update-installScript.

2019.07.13    Update support to Catalina with Enoch-r2922-10.15.

2019.07.03    Add Q7-Update-installScript/installScript_1015update

2019.06.27    Update List of known issues:

2019.06.22    Update Q3-HFS+UpdateCache/copytempdata

 




User Feedback

Recommended Comments



1 hour ago, robi62 said:

Hi I just tried to install on gpt hfs but does not install it I get error

 

It works fine here.

How did you install it? 

What is the error?

 

@robi62

Yes, the EasyMBR-Installer1015 script will let you know it's done when it's finished.

So, what's your problem?

Edited by crazybirdy

Share this comment


Link to comment
Share on other sites

Its ok I managed to install it but after I Did everything in guide I get  error pushing respawn out by 5 second and it does not continue anymore

Share this comment


Link to comment
Share on other sites
1 hour ago, robi62 said:

Its ok I managed to install it but after I Did everything in guide I get  error pushing respawn out by 5 second and it does not continue anymore

 

I don't know which step you get error? and what's problem.

 

Share this comment


Link to comment
Share on other sites
56 minutes ago, robi62 said:

That is in final reboot after I update caches

Do you follow all the steps on Readme-10.15.pdf?

If you need help, i think you need to tell me, what's your problem?

I really didn't understand what's your problem?

Edited by crazybirdy

Share this comment


Link to comment
Share on other sites

Thanks for ur job!

1.Create USB installer using EasyMBR-Installer1015 to install Catalina successfully

2.But I can only boot with -x to get to desktop

3.I hv repaired permissions and rebuild the cache

4.I hv replaced the com.apple.telemetry.plugin of 10.13.6

5.After that I tried to boot and got the error and then rebooted automatically

 

WechatIMG29.jpg

Share this comment


Link to comment
Share on other sites

&crazybird I think the error has something to do with boot loader in my case clover I did follow all step in pdf but after rebuilding cache not booting and I get error 

Share this comment


Link to comment
Share on other sites

Remove panic log first.

Clover Find code    = 008a0284 c07447
Clover Replace code = 008a0284 c0EB47

1971260430_kernelpaniclog-rm01.jpg.bd33fcd9018759228f844e99eabf6d62.jpg

 

40 minutes ago, robi62 said:

&crazybird I think the error has something to do with boot loader in my case clover I did follow all step in pdf but after rebuilding cache not booting and I get error 

 

Remove panic log first as above to see what error you get exactly.

 

4 hours ago, HurricaneX said:

Thanks for ur job!

1.Create USB installer using EasyMBR-Installer1015 to install Catalina successfully

2.But I can only boot with -x to get to desktop

3.I hv repaired permissions and rebuild the cache

4.I hv replaced the com.apple.telemetry.plugin of 10.13.6

5.After that I tried to boot and got the error and then rebooted automatically

 

WechatIMG29.jpg

 

Remove panic log first as above to see what error you get exactly.

Remove the /System/Library/Extensions/AppleIntelMCEReporter.kext, and rebuild cache again with hfsupdatecache on single user mode (-s).

Share this comment


Link to comment
Share on other sites
On 10/12/2019 at 1:04 PM, HurricaneX said:

Thanks for ur job!

1.Create USB installer using EasyMBR-Installer1015 to install Catalina successfully

2.But I can only boot with -x to get to desktop

3.I hv repaired permissions and rebuild the cache

4.I hv replaced the com.apple.telemetry.plugin of 10.13.6

5.After that I tried to boot and got the error and then rebooted automatically

 

WechatIMG29.jpg

Everything is fixed and working perfectly now!

Thanks! 

Screenshot 2019-10-14 at 12.06.25 AM.png

Share this comment


Link to comment
Share on other sites

hi, big great news, and about issues:

"

List of known issues:

1. iCloud Drive doesn't work on HFS+, only works on APFS.

2. Some app-pkg-installers can't install to HFS+, but install to APFS fine.

3. If you install to a blank APFS partition, it won't convert to two system, data partitions, and always keeps one APFS partition only, and iCloud Drive works fine, but some app-pkg-installers still can't install to it."

if I using another HDD to Time Machine with hfs+ format, it's will work correctly?

Share this comment


Link to comment
Share on other sites
Just now, oldman20 said:

hi, big great news, and about issues:

"

List of known issues:

1. iCloud Drive doesn't work on HFS+, only works on APFS.

2. Some app-pkg-installers can't install to HFS+, but install to APFS fine.

3. If you install to a blank APFS partition, it won't convert to two system, data partitions, and always keeps one APFS partition only, and iCloud Drive works fine, but some app-pkg-installers still can't install to it."

if I using another HDD to Time Machine with hfs+ format, it's will work correctly?

 

I never use Time Machine, I can't tell you it works or not.

Share this comment


Link to comment
Share on other sites
10 hours ago, oldman20 said:

hi, big great news, and about issues:

"

List of known issues:

1. iCloud Drive doesn't work on HFS+, only works on APFS.

2. Some app-pkg-installers can't install to HFS+, but install to APFS fine.

3. If you install to a blank APFS partition, it won't convert to two system, data partitions, and always keeps one APFS partition only, and iCloud Drive works fine, but some app-pkg-installers still can't install to it."

if I using another HDD to Time Machine with hfs+ format, it's will work correctly?

 

Time Machine is working on HFS+. My all Time Machine HDD's are HFS+. As far as I know, Time Machine doesn't work with APFS;

 

https://support.apple.com/en-gb/guide/mac-help/mh15139/mac

Edited by telepati

Share this comment


Link to comment
Share on other sites

I installed Catalina 10.15 MBR HFS and the installation was OK.
After installing it, I noticed on my desktop that instead of the disk icon, I had a folder icon and all the Catalina file folders in it.

I'm not able to replace that disk folder icon now.
Please help.

Edited by luky35

Share this comment


Link to comment
Share on other sites
On 23/10/2019 at 13:57, luky35 said:

Tôi đã cài đặt Catalina 10.15 MBR HFS và cài đặt vẫn ổn.
Sau khi cài đặt nó, tôi nhận thấy trên máy tính để bàn của mình rằng thay vì biểu tượng đĩa, tôi có một biểu tượng thư mục và tất cả các thư mục tệp Catalina trong đó.

Bây giờ tôi không thể thay thế biểu tượng thư mục đĩa đó.
Xin vui lòng giúp đỡ.

i have same issue, please help! thanks all!

On 23/10/2019 at 10:33, telepati said:

 

Time Machine đang hoạt động trên HFS +. Tất cả ổ cứng thời gian của tôi là HFS +. Theo tôi biết, Time Machine không hoạt động với APFS;

 

https://support.apple.com/en-gb/guide/mac-help/mh15139/mac

thanks a lot!

Share this comment


Link to comment
Share on other sites

After October 25, the previous application expired. How can I download the macOS Sierra 10.12 version through the script in Q6? The minimum version available is the macOS High Sierra version. 

Share this comment


Link to comment
Share on other sites

I just downloaded the file from the link you provided. But it cannot be opened, no matter I use .pkg or rename it as InstallESD.dmg. 

After it was renamed as InstallESD.dmg, I double clicke it, and it shows "Cannot allocate memory". 

Thank you anyway! 
 

Share this comment


Link to comment
Share on other sites
42 minutes ago, phillip521125 said:

I just downloaded the file from the link you provided. But it cannot be opened, no matter I use .pkg or rename it as InstallESD.dmg. 

After it was renamed as InstallESD.dmg, I double clicke it, and it shows "Cannot allocate memory". 

Thank you anyway! 
 

 

This seems works on 10.13, doesn't work on 10.14.

 

10.12.6
https://apps.apple.com/app/id1127487414?mt=12

10.11.6
https://apps.apple.com/app/id1147835434?mt=12

Share this comment


Link to comment
Share on other sites
2 hours ago, crazybirdy said:

 

This seems works on 10.13, doesn't work on 10.14.

 

10.12.6
https://apps.apple.com/app/id1127487414?mt=12

10.11.6
https://apps.apple.com/app/id1147835434?mt=12

 

 

Both of the two links cannot be opened,no mater in 10.13 or 10.14. 

It seems the link should connect to App Store,but when you click the link,the browser just goes blank.

Edited by phillip521125

Share this comment


Link to comment
Share on other sites
1 hour ago, phillip521125 said:

Both of the two links cannot be opened,no mater in 10.13 or 10.14. 

It seems the link should connect to App Store,but when you click the link,the browser just goes blank.

 

Do not use Safari.

Use Firefox to open the link, will connect to App Store, and you can download 10.12 on 10.13.

165652508_ScreenShot2019-10-26at10_44_22PM.thumb.jpg.cdd07085f52272f95651db87ed99a9a2.jpg2001366087_ScreenShot2019-10-26at10_45_00PM.thumb.jpg.d3ba086a8d516c6da97cdf1294c3cd0e.jpg

Edited by crazybirdy

Share this comment


Link to comment
Share on other sites
3 hours ago, crazybirdy said:

 

Do not use Safari.

Use Firefox to open the link, will connect to App Store, and you can download 10.12 on 10.13.

165652508_ScreenShot2019-10-26at10_44_22PM.thumb.jpg.cdd07085f52272f95651db87ed99a9a2.jpg2001366087_ScreenShot2019-10-26at10_45_00PM.thumb.jpg.d3ba086a8d516c6da97cdf1294c3cd0e.jpg

 

I used the Firefox,and had downloaded it successfully.

But when I run the application,it shows “This copy of the Install macOS Sierra application is damaged, and can't be used to install macOS.”

The application still expired.

 

2125578802_QQ20191027011844.jpg.a994415d3929bc134301d03ab8a9b78f.jpg

Edited by phillip521125

Share this comment


Link to comment
Share on other sites
9 hours ago, phillip521125 said:

 

I used the Firefox,and had downloaded it successfully.

But when I run the application,it shows “This copy of the Install macOS Sierra application is damaged, and can't be used to install macOS.”

The application still expired.

 

2125578802_QQ20191027011844.jpg.a994415d3929bc134301d03ab8a9b78f.jpg

 

MD5 (Install macOS Sierra.app/Contents/SharedSupport/InstallESD.dmg) = 174997dd6707873688ef2944e22f0cc2

Check your md5. maybe you need to download it again.

 

It works fine with 10.12 MBR patch method here.

-----

All right. I know what's the problem, you can just change date to be 2017/10/27 after 2017/7/15, it will work fine on 10.12.:thumbsup_anim:

 

 

Edited by crazybirdy

Share this comment


Link to comment
Share on other sites

I'm having a problem attaching things to either a facebook post or an email. As soon as I select the file the system hangs.

I've tried it with Chrome and Safari 

Is this because of using HFS?

When I install using this method I'm not offered the choice of formatting to APFS, how can I do that if I want to give APFS a try?

Share this comment


Link to comment
Share on other sites
11 hours ago, Crabhunter said:

I'm having a problem attaching things to either a facebook post or an email. As soon as I select the file the system hangs.

I've tried it with Chrome and Safari 

Is this because of using HFS?

When I install using this method I'm not offered the choice of formatting to APFS, how can I do that if I want to give APFS a try?

 It works here with Firefox to attach pictures to facebook or gmail web site on MBR HFS+ 10.15.1, I only use Firefox, not test with Chrome and Safari.

 

APFS can  be used on GUID table only, can't be used on MBR table.

 

Share this comment


Link to comment
Share on other sites

Hi all, I installed catalina 10.15.1, but could not use included script

for download. It could not create full install app.

Had to use dosdude macOS Catalina Patcher for that.

Afterwards installaton worked as expected.

One thing is strange - applecsript does not work at all,

can't read any scripts or compile new ones, no matter

how simple.

Has anyone else that issue ?

Or success ?

Thanks for the replies .

P.S. I am going to install "official" way to afps and see if anything changes and report here.

Share this comment


Link to comment
Share on other sites
1 hour ago, audiosource said:

Hi all, I installed catalina 10.15.1, but could not use included script

for download. It could not create full install app.

Had to use dosdude macOS Catalina Patcher for that.

Afterwards installaton worked as expected.

One thing is strange - applecsript does not work at all,

can't read any scripts or compile new ones, no matter

how simple.

Has anyone else that issue ?

Or success ?

Thanks for the replies .

P.S. I am going to install "official" way to afps and see if anything changes and report here.

The FullApp-download scripts work fine here on 10.15.1 MBR HFS+.

 

What's your errors?

 

01.thumb.jpg.bfe1a5fdf819a127ca2eff0bd87ea599.jpg

Share this comment


Link to comment
Share on other sites

×