Jump to content

1 Screenshot

About This File

Open source driver for the Realtek RTL8111/8168 family.

 

New Driver for Realtek RTL8111

 

Anybody who is looking for a add-on network card with Realtek NIC might want to consider the Delock 89357. This card is equipped with a RTL8111E-VL (chipset 16) which is known to work perfectly with my driver because this chipset is my primary test device.


What's New in Version 2.2.2   See changelog

Released

  • Force ASPM state to disabled/enabled according to the config parameter setting.
  • Requires 10.12 or newer



User Feedback

Recommended Comments



This kext so good, stable connection and good speed.

But I have some question, when choose auto-negotiation, network card say that no wire connected at both OS-es. If somebody know why it cannot auto downstream to 100Mb, how to resolve this problem, please tall few words

Share this comment


Link to comment
Share on other sites

Probably a lot of background here, but I'll err on the side of TMI to eliminate a lot of questions. Might seem weird posting here, but you Hackintosh folk seem to be the only tribe that feels my pain and can help fix the problem. Thanks, for your patience with my noobness.

 

I'm running a Mac Pro (Early 2008) Quad Core Tower. The only thing damaged by a lightning strike (about a year ago) was the ethernet port. I was running a USB Ethernet NIC adapter for a while, but it was giving me USB sleep issues, so I changed over to a Realtek based Gigabit PCI-Express ethernet card. 

It worked like a CHAMP until my startup disk started malfunctioning - brought it in to a shop and they tested, etc. - ultimately upgrading me from 10.7 to 10.11. Now, allasudden, my Mac isn't recognizing the ethernet card and I'm trying to drop kext files into the /L/E folder with little to show for it. I downloaded the RTL8111.RAR, unpacked it and transferred over to the MacPro the RTGNICv2.0.6For10.7.mpkg and installation repeatedly fails. Tried Easykext and Kext Utility to load the RealtekRTL8111.kext and both kext installers tell me installation went fine, but 10.11 says "not so much".

 

I just barely passed the basic knowledge exam to get in here, so your replies may need to be a bit more dumbed down for me. Hoping you all can help. 
 

Do I need to do any command line stuff or am I just stuck like Chuck in the muck?

Share this comment


Link to comment
Share on other sites

Working perfectly for me in 10.13.4 with my GA-EP35-DS3L.  Thank you, dear author, for contributing.  The older version I had (1.2.2) was giving me trouble.

Share this comment


Link to comment
Share on other sites

×