Jump to content

1 Screenshot

About This File

Enoch

Latest revision of my Chameleon bootloader branch.

 

Not able to boot AFPS yet....

 

Please don't upload it on other servers and don't repack it, thank you.

- Installer PKG

- Binaries format (Manual install)

Please don't upload it on other servers and don't repack it, thank you.

 

Chameleon bootloader credits goes to Chameleon Team http://forum.voodooprojects.org

 

Changelog: http://forge.voodoop...e/changes/HEAD/

 

This revision of Enoch contain the upcoming FileNVRAM revision 1.1.5 (RC8)

Credits to Micky1979

 

----------------------------------------

Modulo_FileNVRAM.png

All credits go to meklort and cosmo1t.

FileNVRAM copyright © 2013 xZeneu LLC. FileNVRAM is licensed under the Attribution-NonCommercial 3.0 Unported license.

Please see the license file for details

More Info: xZenue

----------------------------------------

 

Language Translation:

lang.png

For on-line Chameleon language package resource edit

>> Pootle

 

 

 

 

Hi all translators,You can help us to translate the Chameleon Project.You need to have gettext utilities installed.You can install them :* With MacPorts or Finkor* With the package http://dl.dropbox.com/u/112112/Chameleon.Dev/gettext-0.18.1.1.dmgYou need to change your ~/.bashrc or ~/.bash_profile to add the path to the utilities:# MacPorts Installer: adding an appropriate PATH variable for use with MacPorts.export PATH=/opt/local/bin:/opt/local/sbin:$PATH# Finished adapting your PATH environment variable for use with MacPorts.# MacPorts Installer: adding an appropriate MANPATH variable for use with MacPorts.export MANPATH=/opt/local/share/man:$MANPATH# Finished adapting your MANPATH environment variable for use with MacPorts.You must also have a PO editor like Poedit: http://www.poedit.net/download.phpThe files to translate are in package/po directory.Open them with your PO editor and translate.If you want to add a new language copy the package/po/chameleon.pot to po/$lang.po where $lang isthe new language you want to add.Example to add belgian language:# cp package/po/chameleon.pot package/po/be.poNow you can start translating the new po file with your PO editor

 

Pls translate/complete it.

 

Link here on InsanelyMac (Italian only): Enoch Bootloader

 

Enjoy

 

ErmaC


What's New in Version r2922   See changelog

Released

  • kernel patchers updated to boot Catalina (credits to: CrazyBirdy)
  • Added Catalina Icons detection.

Enoch-rev.2922.zip




User Feedback

Recommended Comments



@ Ermac

 

v2748 didn't work on current Beta 3

 

" message appears >> this Version's not compatible !

 

tried 2 times

 

greetings

Share this comment


Link to comment
Share on other sites

Thanks for such an excellent boot loader for Mac OS X from 10.11 DB1 to DB3.
Unfortunately both v2737 and v2748 no more working from DB4 to DB5 because FakeSMC.kext fails to load in /System/Library/Extensions with Kernel Panic in my Asus Z77, Z87, Z97 MBs even repaired permission by sudo chown -Rf 0:0 or using InsanelyRepairPermission. Hope it can be fixed as soon as possible. At present I have to boot by Clover 3253 for DB4 & DB5.

Share this comment


Link to comment
Share on other sites

ciao ho installato enoch tutto bene funziona alla perfezione solo che non riesco a trovare il file di configurazione...potresti dirmi dove si trova...?

...poi una curiosità...posso installare prima chamelon e dopo enoch oppure enoch non ha bisogno di chamelon installato...non so se mi sono spiegato bene...grazie

Share this comment


Link to comment
Share on other sites

ciao ho installato enoch tutto bene funziona alla perfezione solo che non riesco a trovare il file di configurazione...potresti dirmi dove si trova...?

...poi una curiosità...posso installare prima chamelon e dopo enoch oppure enoch non ha bisogno di chamelon installato...non so se mi sono spiegato bene...grazie

Enoch è Chameleon! ..ovvero è una versione di Chameleon!

I'org.chameleon.Boot.plist è in /Extra/ ...sulla partizione dove lo hai installato.

Ciao!

Share this comment


Link to comment
Share on other sites

@ Ermac

 

v2748 didn't work on current Beta 3

 

" message appears >> this Version's not compatible !

 

tried 2 times

 

greetings

Thanks for such an excellent boot loader for Mac OS X from 10.11 DB1 to DB3.

Unfortunately both v2737 and v2748 no more working from DB4 to DB5 because FakeSMC.kext fails to load in /System/Library/Extensions with Kernel Panic in my Asus Z77, Z87, Z97 MBs even repaired permission by sudo chown -Rf 0:0 or using InsanelyRepairPermission. Hope it can be fixed as soon as possible. At present I have to boot by Clover 3253 for DB4 & DB5.

Pls try those untested revision http://www.insanelymac.com/forum/topic/231075-chameleon-23svn-official-pkg-installer-binaries/page-164?p=2157370&do=findComment&comment=2157370

 

ErmaC

Share this comment


Link to comment
Share on other sites

Thanks for such an excellent bootloader for Hackintosh.

However I got a booting bug after v.2532.

Loss of GUI=Yes function and abnormal display in text mode for several display cards

such as Intel HD 4600, AMD 6870, AMD 7950, etc.

Hope it can be fixed as soon as possible.

Share this comment


Link to comment
Share on other sites

No options in /Extra/kernel.plist = no kernel patcher. You wil see a log that say [ KERNELPATCHER START ] but this way does nothing if no options are enabled.

Share this comment


Link to comment
Share on other sites

Just need some try and error to find out how to get it work.  It always trigger kernel panic before I choose to apply the kernel patch.  It works great now on my El Capitan (10.11.0 released version) installation which I clone to my hackintosh from my Macbook Pro.

 

Thank you very much.

Share this comment


Link to comment
Share on other sites

Installato rev. 2773 per os 10.11, ma quando riavvio dall'hard disk con 10.11, mi incasina  org.chameleon.Boot.plist e smbios.plist della mia cartelle EXTRA che uso con yosemite;  non si aprono più e non contengono più nulla...

 

enoch non arriva ad arrivare alla schermata con la scelta degli os x dandomi questo messaggio:

 

error parsing plist file...

 

su yosemite enoch fino a versione 2530 non mi ha mai dato questi problemi...

 

 

hardware:

 

notebook

core 2 duo P9500 2,53ghz

Nvidia 9800m GTS 1024Mb

System RAM: 6 MB

Share this comment


Link to comment
Share on other sites

Questo succede quando un .plist è corrotto e non può essere letto.

Puoi postare la cartella di backup fatta dall'installer (che dovresti avere nella root di Yosemite chiamata "Chameleon.Backups") nel topic di supporto?

magari anche quella fatta male. 

Grazie

Share this comment


Link to comment
Share on other sites

I really tried reading up on this bootloader but can't seem to find the info I need.  I installed the bootloader, but can't install El Capitan to the USB the bootloader is installed on.  When I look at the main post (to both Chameleon and Enoch) it shows the instructions to an older version.  Can I get pointed in the right direction?

Share this comment


Link to comment
Share on other sites

Enoch is distributed with an installer that make installation automatically... what has to do the boot loader with a failure making an OS X Installer?

Normally, you have to create the OS X installer first, then you can install the bootloader on it..

Share this comment


Link to comment
Share on other sites

Did Enoch switch its GPU detection to be the same as Clover ? I have an old Geforce GTS 250 that refuse to boot OOB with the latest Clover and Enoch, but it boots with Chameleon r2716

Share this comment


Link to comment
Share on other sites

Ciao I just would like to let you know that thanks to Enoch and the work of the stuff here my super old custom built hackintosh with a P5BW-LA mobo (Basswood-socket 775) is up and running El Capitan (beta 2 update).. Thanks

Share this comment


Link to comment
Share on other sites

×