Jump to content

AppleHDA for ALC1150 - 10.9.3- 2.6.1f2


1 Screenshot

About This File

This is the version of Applehda.Kext Mavericks-GM hope it works for everyone!

Note: It is necessary to change the layout of 12 to 4 in the patch HDEF your DSDT.aml.

Note: Please do not upload it on other servers.

Feedback Please!!!

Codec: Realtek ALC1150

Address: 0

Vendor Id: 0x10ec0900

Subsystem Id: 0x1043855f

Revision Id: 0x100001

credits:

* Kabyl, Taruga.

 

Method (_DSM, 4, NotSerialized)                {                    Store (Package (0x0c)                    {                                                "built-in",                         Buffer (One)                        {                            0x00                        },                         "layout-id",                         Buffer (0x04)                        {                            0x04, 0x00, 0x00, 0x00                        },                        "PinConfigurations",                        Buffer (0x00)                       {                           0x00                       }                    }, Local0)                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                    Return (Local0)                }              }


What's New in Version 2.6.1f2   See changelog

Released

No changelog available for this version.




User Feedback

Recommended Comments

Mirone you are a genius... I've been fighting with my audio for 4 days until this file :))

It works on Maximus VI Gene (C2 stepping board version)

 

Update 1

Unfortunately I spoke too soon... it's gone again... after I tried switching between output audio devices into Digital Out...

 

Update 2

And after restore I can't replicate the issue, it works flawlessly again :)

Share this comment


Link to comment
Share on other sites

Hi Mirone, thank you, yes it's working, although sometimes during the boot the injection can fail (assertions) and I have to turn off the machine and start it again. I wasn't able to identify if there is a reason for that, seems rather random. I've tried deleting the hdaenabler.kext and using the HDAEnabler in chameleon but that doesn't work at all, so I'm happy as it is :)

Share this comment


Link to comment
Share on other sites

@Teq

can make injection applying a patch in DSDT.
as explained above.
If you want you can send me your DSDT, and I can do it for you.

Share this comment


Link to comment
Share on other sites

i am having problems with sound - Z87 Deluxe, no DSDT using Clover Uefi...

 

with iTunes sound is fine for 15 seconds of music then sound get crackly then cuts off then comes back on jerky...

playing from an mp4 with quicktime there is no problem at all...

playing the same song in quicktime that i played in iTunes is perfect and not crackly...  

youtube videos sound is fine for 15 seconds of music then sound get crackly then cuts off then comes back on jerky and out of sync to the video...

Share this comment


Link to comment
Share on other sites

Ahhh! Been having issues with my Z87 Deluxe/Dual having cracky audio with a variety of attempts - plopped this in and everything is crystal clear.  Thanks!

Share this comment


Link to comment
Share on other sites
×