Jump to content

p.H

p.H

Member Since 01 Mar 2012
Offline Last Active Today, 02:54 AM
-----

Posts I've Made

In Topic: Wake reason: RTC (Alarm) - how to deactivate?

23 April 2015 - 12:59 PM

that's a bummer that you suffer from this problem even with a real MBPr. You are sure that this is the RTC alarm wake up and not the power nap feature? I'm afraid I can't help you further here since for my hack it works now...

Maybe consider contacting Apple for help/support since you have a brand new machine...?


disabling bonjour/multicast could cause other services like AirDrop/Airplay/etc to stop working afaik. So this 'solution' might not work for people who need those services.

Maybe I would test a little bit longer. I've seen lots of wake reasons for "ARPT network". What surprises me is that I've turned off every possible wake up option in settings. Bummer and it's  A real one.

In Topic: Wake reason: RTC (Alarm) - how to deactivate?

23 April 2015 - 09:50 AM

yeah, actually, this problem was fixed in 10.10.2. Since then, discoveryd is letting the system sleep just fine for a lot of users. Do you have mDNSResponder deactivated?

Thanks for you feedback. I recently bought the 2015 MBPr and it kept waking itself up along the night ( by checking the log ). To be honest, I was kind of shocked the moment I read your post. Was it fixed in 10.10.2, I said it to myself. I have seen wake reason for RTC since I got the machine. What's worse, upgrading to 10.10.3 doesn't fix it either. So I am quite upset here. :(

 

Just to clean up the mess with the 2 hour wake up issue:

 

There is a use case where a 2 hour wake up issue is normal and intended: 

A 2 hour wake up process is totally fine if you have activated the „wake for network access“ feature in System Settings. This 2 hour wake up procedure has been introduced by Apple in 10.6 Snow Leopard and is the result of the so called „bonjour sleep proxy“. Every 2 hours your mac wakes up (in dark mode = no screen) and advertises its IP address. Once you have unchecked „wake for network access“ there should be no more 2 hour wake ups at all. That was the case until 10.10.0 has been released. There was a bug that woke up most machines even if „wake for network access“ was not checked. This bug seems to be fixed by now (10.10.2/ 10.10.3). So if you still have those 2 hour wake ups although you did not activate „wake for network“ than this is quite unusual.

 

What i am looking for though is a solid way to have „wake for network access“ enabled but still have no 2 hour wake up procedure. That was possible with every release prior to 10.6 Snow Leopard. The only way to wake a machine back then was by using a so called magic packet instead of simply opening the finder on another mac and navigate to the remote mac. Right now i am on 10.10.3 and have mDNSresponder running (the solution advertised in this thread). This works perfectly fine and finally my mac sleeps through the night/day and is perfectly wakeable by a magic packet. Then again i am a little worried as it is not intended to run mDNSresponder anymore as it has been replaced by discoveryd. So if anyone has a good idea on how to modify discoveryd the way that the bonjour sleep proxy gets disabled i would be very happy :)

 

Thanks for your clarification. I'm THE out of luck person who still suffers this nightmare. :(  

In Topic: Wake reason: RTC (Alarm) - how to deactivate?

19 April 2015 - 12:16 AM

@McPants: I attached the mDNSResponder files with the Instructions again.

 

@noreason4: I'm on 10.10.3. Sleep works for me with discoveryd (not using our trick with mDNSResponder) but I had to turn off "wake for network access" to get it to work properly. Since I don't need that I'm fine with my current solution :)

Do you mean that with 10.10.3 you no longer need to bother with Discoveryd waking up system every 2 hours? If so, it's so sad that mine still does.

In Topic: Released final version OS X Yosemite 10.10.3

13 April 2015 - 12:24 AM

 

well it was 1 day 22 hours... update has only been out 3 days...

 09:44am  up 3 days  0:45,  6 users,  load average: 0.64, 0.82, 0.90

To be honest, I was surprised to see 6 users. Did you have multiple accounts set up?

In Topic: Wake reason: RTC (Alarm) - how to deactivate?

28 January 2015 - 12:30 AM

Good point, I updated I signature with my specs. Ya I apologize for the miscategorized post. Originally this was the wake reason I had a few weeks ago where it would go to sleep and wake every few hours, but it seems something has changed now to where it doesnt sleep at all. it sleeps and then wakes up right away. I will try to find a thread for the current I'm facing. Thanks for the help :)

Update: I'm pretty sure the Corsair Link usb cord from my liquid cooler is causing the XHC issue where it wont sleep. I will unplug that when i get home and then try to sleep. Then i will try the solution provided for the waking up every 2 hours due to RTC alarm. Then i need to fix my issue of having no sound after wake from sleep as well, which I'm looking at other forums to figure out. Hopefully after ALL that I can have a normal sleeping hackintosh. Wish me luck! :)

off topic. But a note to the problem of sound loss after sleep issue - google codeccommander

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy