Jump to content

doh.t

doh.t

Member Since 28 Feb 2007
Offline Last Active Jan 13 2009 06:26 PM
-----

Posts I've Made

In Topic: Mac os x Leopard 10.5.1 kalway on ibm thinkpad t42

18 March 2008 - 10:25 PM

Really? you think that? Doesn't the video pretty much suck with acceleration not enabled and never going to be any faster than Vesa? Yuck!


Dysan911 you'll see that QuartzExtreme can be supported, if you'd have had a look on the extensions of 10.4.8 you'd have seen that it works, so what sucks right now huh?

In Topic: Mac os x Leopard 10.5.1 kalway on ibm thinkpad t42

11 March 2008 - 12:49 PM

finally i managed to get wifi working. no need for iwi2200 on google code or things like that. Since the Wireless adapter in the t42 is "ThinkPad 11a/b/g Wireless LAN Mini-PCI Express Adapter" you only have to do the following steps via terminal:

1. open terminal
2. browse to the folder /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/
3. make a ls -ls and look for the kext "AirPortAtheros.kext"
4. browse into the folder AirPortAtheros/Contents/
5. open the file Info.plist as super user with vi --> sudo vi Info.plist
6. and add the text "<string>pci168c,1014</string> " within "IONameMatch" in the key-section "Atheros Wireless LAN PCI"
7. save and close the file --> ": x"
8. be sure to set the right permissions: "sudo chown -R root:wheel /System/Library/Extensions"
9. afterwards clean the cache: "kextcache -k /System/Library/Extensions"
and reboot.

reboot in verbose mode to see the atheros driver load and the wirless card pop up..you should see the mac adress of your wireless card.

Now you can configure it via System->Network as usual.

Have fun!

In Topic: Mac os x Leopard 10.5.1 kalway on ibm thinkpad t42

10 March 2008 - 11:17 PM

alright, so leopard is booting correctly, sound, ethernet and graphics are working correctly! im very happy and next i'll try to install the wireless driver, but that not this night ;)

In Topic: Mac os x Leopard 10.5.1 kalway on ibm thinkpad t42

10 March 2008 - 10:30 PM

okay, installation is done (took me about 30 mins), hoping the reboot works...reboot done, i suppose i installed the wrong graphic card drivers (natit) because screen is switching after running all the commands and changing to loginwindow but i only see a black screen. i know this error from 10.4.11 setup on my t42 machine and had to fix it the same way. so i will redo the setup without choosing any specific graphic card driver. the ethernet adapter is working (could see that in verbose mode, link was up; used driver is AppleIntel8245XEthernet). ill keep you all up to date...

In Topic: Mac os x Leopard 10.5.1 kalway on ibm thinkpad t42

10 March 2008 - 09:50 PM

hi there, i'm running a t42 (2373) and have no success with installing leopard. firstly i killed all partitions on my hdd, so its unpartitioned and all free for the leopard install. then i tried a kalyway 10.5.1 dvd and a iATKOS but i doesn't bring me into the setup. i also tried with both version to load the installation with -x but no success. in verbose mode (-v) on kalyway it says last "dsmos: Starting..." and that's it. i can type characters but no recognition. On iAKTOS it says Extension "com.apple.driver.ACPI_SMC_PlatformPlugin" has immediate dependencies on both com.apple.kernel and com.apple.kpi componentes; use only one style" then it stopps and ich can input characters but nothing happens. it's not like a shell or so, no commands are recognized. somebody ideas what to do? OMG! Kalyway works, i just had to be a bit more patient. im now in the leopard setup...hope it works! :)
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy