Jump to content

mwally

mwally

Member Since 16 Apr 2011
Offline Last Active May 29 2011 03:42 PM
-----

Posts I've Made

In Topic: Alienware m17x r2 with dual mobility 4870s,

09 May 2011 - 08:10 PM

Also wondering what frame buffer to use since it says I have 4 connectors, or how I should edit the frame buffer to make the lvds to work, I'm not really needing the other ports to work.

In Topic: Alienware m17x r2 with dual mobility 4870s,

09 May 2011 - 02:45 AM

i edited ati.c and am now getting an error when i try to use the make command in my kabyl folder.

================= make all for i386 =================
   /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386 /Users/mwally7/Desktop/chameleon/branches/Kabyl/sym/i386 /Users/mwally7/Desktop/chameleon/branches/Kabyl/dst
   ================= make all for util =================
   ================= make all for libsa =================
   ================= make all for libsaio =================
   ================= make all for boot2 =================
   gcc -static -Wl,-preload -Wl,-segaddr,__INIT,20200 \
			   -nostdlib -arch i386 -Wl,-segalign,20 \
		   -o /Users/mwally7/Desktop/chameleon/branches/Kabyl/sym/i386/boot.sys /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/boot2.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/boot.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/graphics.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/drivers.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/prompt.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/options.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/lzss.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/mboot.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/ramdisk.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/picopng.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/resume.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/bmdecompress.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/graphic_utils.o /Users/mwally7/Desktop/chameleon/branches/Kabyl/obj/i386/boot2/gui.o -L/Users/mwally7/Desktop/chameleon/branches/Kabyl/sym/i386 -lsaio -lsa -lcc_kext
   /usr/bin/ld_classic: Undefined symbols:
   ___bzero
   collect2: ld returned 1 exit status
   make[2]: *** [boot] Error 1
   make[1]: *** [all] Error 2
   make: *** [all] Error 2

Any help would be greatly appreciated.

In Topic: Alienware m17x r2 with dual mobility 4870s,

07 May 2011 - 02:26 AM

used radeon bios decoder and got

ATOM BIOS Rom: 
		
	SubsystemVendorID: 0x1028 SubsystemID: 0x043a
		
	IOBaseAddress: 0x0000
		Filename: 13B87610.104
		
	BIOS Bootup Message: 
	QuickSilver MLK															 
	
	PCI ID: 1002:945a
	
	
	Connector at index 0
		Type [@offset 45272]: DisplayPort (10)
		Encoder [@offset 45276]: INTERNAL_UNIPHY (0x1e)
		i2cid [@offset 45368]: 0x93, OSX senseid: 0x4
	
	
	Connector at index 1
		Type [@offset 45282]: DisplayPort (10)
		Encoder [@offset 45286]: INTERNAL_UNIPHY (0x1e)
		i2cid [@offset 45395]: 0x92, OSX senseid: 0x3
	
	
	Connector at index 2
		Type [@offset 45292]: VGA (1)
		Encoder [@offset 45296]: INTERNAL_KLDSCP_DAC1 (0x15)
		i2cid [@offset 45422]: 0x90, OSX senseid: 0x1
	
	
	Connector at index 3
		Type [@offset 45302]: LVDS (7)
		Encoder [@offset 45306]: INTERNAL_KLDSCP_LVTMA (0x1f)
		i2cid [@offset 45445]: 0x94, OSX senseid: 0x5

My computer has of course has its internal screen, but also a hdmi and vga out and a display port. I am confused why it has no hdmi tagged in this.

In Topic: Alienware m17x r2 with dual mobility 4870s,

06 May 2011 - 11:41 PM

I have done a radeondump -i and it outputs:

Found a device of class RadeonPCI: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG3@3/IOPCI2PCIBridge/display@0/RadeonPCI
it matched on name "ATY,MotmotParent"
Detected unknown Card (device id: 0x945a)
It's not in known card list, treat as card with device id: 0x940f
Detect EDID may fail for this card.
Start I2C dump
ATOM BIOS detected
ATOM BIOS Rom:
	 SubsystemVendorID: 0x1028 SubsystemID: 0x043a
	 IOBaseAddress: 0x3000
	 Filename: 13B87610.104
	 BIOS Bootup Message:
QuickSilver MLK															

object id 0013 01
src object id 221e 30
record type 1
  rhdAtomParseI2CRecord:  I2C Record: HW_Line 9 EngineID: 1 I2CAddr: 0
ddc_line from ATOMBIOS: 0x0
record type 2
record type 4

object id 0013 01
src object id 211e 30
record type 1
  rhdAtomParseI2CRecord:  I2C Record: GPIO_ID 9 EngineID: 1 I2CAddr: 0
ddc_line from ATOMBIOS: 0x0
record type 2
record type 4

object id 0005 01
src object id 2115 21
record type 1
  rhdAtomParseI2CRecord:  I2C Record: GPIO_ID 9 EngineID: 0 I2CAddr: 0
ddc_line from ATOMBIOS: 0x0
record type 4

object id 000e 01
src object id 211f 31
record type 1
  rhdAtomParseI2CRecord:  I2C Record: GPIO_ID 9 EngineID: 2 I2CAddr: 0
ddc_line from ATOMBIOS: 0x0
record type 4

object id 000f 00
record type 4

object id 0011 01
src object id 2114 20
record type 4
record type 11


Found a device of class RadeonPCI: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG5@5/IOPCI2PCIBridge/display@0/RadeonPCI
it matched on name "ATY,MotmotParent"
Detected unknown Card (device id: 0x945a)
It's not in known card list, treat as card with device id: 0x940f
Detect EDID may fail for this card.
Start I2C dump
ATOM BIOS detected
ATOM BIOS Rom:
	 SubsystemVendorID: 0x1028 SubsystemID: 0x043a
	 IOBaseAddress: 0x3000
	 Filename: 13B87610.104
	 BIOS Bootup Message:
QuickSilver MLK															

object id 0013 01
src object id 221e 30
record type 1
  rhdAtomParseI2CRecord:  I2C Record: HW_Line 9 EngineID: 1 I2CAddr: 0
ddc_line from ATOMBIOS: 0x0
record type 2
record type 4

object id 0013 01
src object id 211e 30
record type 1
  rhdAtomParseI2CRecord:  I2C Record: GPIO_ID 9 EngineID: 1 I2CAddr: 0
ddc_line from ATOMBIOS: 0x0
record type 2
record type 4

object id 0005 01
src object id 2115 21
record type 1
  rhdAtomParseI2CRecord:  I2C Record: GPIO_ID 9 EngineID: 0 I2CAddr: 0
ddc_line from ATOMBIOS: 0x0
record type 4

object id 000e 01
src object id 211f 31
record type 1
  rhdAtomParseI2CRecord:  I2C Record: GPIO_ID 9 EngineID: 2 I2CAddr: 0
ddc_line from ATOMBIOS: 0x0
record type 4

object id 000f 00
record type 4

object id 0011 01
src object id 2114 20
record type 4
record type 11

In Topic: Install Guide Alienware M17x R2 with ATI Radeon 5870

23 April 2011 - 12:26 AM

I think you need to use a different ATI ROM for the 4870. For my own machine I originally tried dumping my cards ROM under windows and downloading the graphics card ROM update from the Dell site - neither worked for me. The ROM I'm using was posted by someone else with the same graphics card.

During my research I think I read your card may just work. So you could try removing the following setting or setting it to NO:

<key>UseAtiROM</key>
<string>Yes</string>

in your com.apple.boot.plist file.


Had to take out the aticonfig lines too and it boots up without the safe mode. Although in system profiler it has my gfxcards labeled as 5870's instead of 4870's and my resolution is stuck at 1024x768.
© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy