Jump to content

howboutjoe

howboutjoe

Member Since 07 Jun 2010
Offline Last Active Feb 16 2011 12:26 AM
-----

Posts I've Made

In Topic: Support Group for Confused Owners of the GA-X58A-UD3R **rev 2.0**

23 June 2010 - 09:36 PM

I totally missed this too! thanks for the tip - I'm running a full 10º cooler even overclocked to 3.25ghz and under full load! (with geekbench scores of 11640). Woohoo! now I can finally push my OC a bit more...


You're gonna have to tell me how you pulled that off. I've never OC'd before so I wouldn't even know where to start.

I just don't get your difficulties. I always found voodooHDA to be flaky and incomplete. I wish I knew what else was keeping you from fully working audio with my DSDT and AppleHDA.kext and legacy889HDA.kext...


A friend of mine with a rev 1 said that he did the Legacy889HDA.kext and AppleHDA 10.6.2 Rollback from #####, which worked for him. I'll try that tonight.

Try pressing the power button to wake from sleep. if i use keyboard or mouse, the machine awakes but the screen and usb and ethernet doesn't come on...



I've tried that with no success. I may try a fresh install on a second disk this evening. Maybe not use kakewalk at all, and just use ##### with your DSDT.

In Topic: Support Group for Confused Owners of the GA-X58A-UD3R **rev 2.0**

23 June 2010 - 02:41 PM

So, I've got audio with VooDooHDA. It's the best I can get working, but it doesn't support the optical out. I've tried a ton of stuff, even going so far as to try manually setting my PinConfiguration by pulling them from Windows 7.

I've also seen that my display locks up completely when I plug my HDTV into the video card. This happens when I plug it in to the HDMI port or if I use an HDMI-DVI adapter and plug it in to the DVI port.

I also still can't sleep, or rather wake from sleep. This wouldn't be a problem, except that even though I set the machine to never sleep, it still sleeps sometimes.

Still, I've got my GeekBench64 score at 10068 and my CPU idle temps at 39, 39, 34, and 34. You can Squeeze a couple of degrees of coolness out of the proc by turning on Dynamic VCore in the BIOS. I didn't notice that tweak my first time through d00d's power management thread.

nullspot, have you tried hooking yours to an HDTV? I know we have the same graphics card, so just curious.

In Topic: Support Group for Confused Owners of the GA-X58A-UD3R **rev 2.0**

19 June 2010 - 03:06 AM

Looks like you have the *exact* same hardware as me... not sure why you're having so much trouble. I just realized I've actually got sleep working - i just have to wake up the box with the power button (usb devices don't seem to wake everything up).

Only new stuff is the tonymac JMicron36xSATA.kext (so the sata controller doesn't appear as "unknown") and d00d's modded fakesmc.kext in S/L/E simply for its support of temp, fan and voltage monitoring in iStat Menus.

Other than that, everything's just as I've posted earlier, 10.6.4 update and all...

E/E:
- Legacy889HDA.kext
- OrangeIconFix.kext
- JMicron36xSATA.kext

S/L/E:
- AppleHDA.kext (10.6.4 patched)
- fakesmc.kext (d00d 1.8.1 mod) - note: the older fakesmc.kext in E/E works just fine too


I just tried your DSDT and all those kexts, except the OrangeIconFix, whihc I don't have, and still crazy coreaudio. It was literally crackling every second and dumping this to the kernel.log:
Jun 18 19:27:09 hax0r kernel[0]: dependency: com.apple.kext.OSvKernDSPLib(1.3)@0x7ede2000
Jun 18 19:27:10 hax0r kernel[0]: 8b80000->0x88b97fff
Jun 18 19:27:10 hax0r kernel[0]: dependency: com.apple.kext.OSvKernDSPLib(1.3)@0x7ede2000
Jun 18 19:27:11 hax0r kernel[0]: river.DspFuncLib(1.8.7f1)@0x88f71000
Jun 18 19:27:11 hax0r kernel[0]: com.apple.iokit.IOAudioFamily(1.7.6fc2)@0x88b80000->0x88b97fff
Jun 18 19:27:11 hax0r kernel[0]: dependency: com.apple.kext.OSvKernDSPLib(1.3)@0x7ede2000
Jun 18 19:27:12 hax0r kernel[0]: 8b80000->0x88b97fff
Jun 18 19:27:12 hax0r kernel[0]: dependency: com.apple.kext.OSvKernDSPLib(1.3)@0x7ede2000
Jun 18 19:27:13 hax0r kernel[0]: river.DspFuncLib(1.8.7f1)@0x88f71000
Jun 18 19:27:13 hax0r kernel[0]: com.apple.iokit.IOAudioFamily(1.7.6fc2)@0x88b80000->0x88b97fff
Jun 18 19:27:13 hax0r kernel[0]: dependency: com.apple.kext.OSvKernDSPLib(1.3)@0x7ede2000
Jun 18 19:27:14 hax0r kernel[0]: river.DspFuncLib(1.8.7f1)@0x88f71000
Jun 18 19:27:14 hax0r kernel[0]: com.apple.iokit.IOAudioFamily(1.7.6fc2)@0x88b80000->0x88b97fff
Jun 18 19:27:14 hax0r kernel[0]: dependency: com.apple.kext.OSvKernDSPLib(1.3)@0x7ede2000
Jun 18 19:27:15 hax0r kernel[0]: 8b80000->0x88b97fff

Do you mind posting a zip of your whole /Extra folder and the two kexts you've got in /S/L/E?

Thanks

In Topic: Support Group for Confused Owners of the GA-X58A-UD3R **rev 2.0**

18 June 2010 - 03:53 PM

nullspot

What's your kext situation look like now? Which ones are still in /E/E and What's new and/or modified in /S/L/E? I want to try your DSDT again with the right set of extensions and see if that works for me.

In Topic: Support Group for Confused Owners of the GA-X58A-UD3R **rev 2.0**

18 June 2010 - 02:19 AM

I was just looking in my /Extra folder and saw Legacy889HDA.kext, so I'm thinking maybe I was a dumbass and didn't put in in /E/E.

Since I saw it from remote desktop, I'm not going to reboot remotely, but I'll let you guys know if that was my problem when I get home tonight.


Using any Legacy889HDA.kext makes my coreaudiod go crazy and just eat cpu. Yanked it, but still no audio here.
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy