Jump to content

nawcom

nawcom

Member Since 09 Oct 2006
Offline Last Active Oct 16 2017 08:33 PM
*****

Posts I've Made

In Topic: Hackintosh Dell latitude

06 October 2017 - 08:33 PM

You gotta give info on the hardware or else no one is going to be able to help. What Latitude model is this?

In Topic: File Recovery

05 October 2017 - 07:57 PM

The only freebie I know that works well is PhotoRec. It's a console app that supports HFS+ and the other common filesystems but it's limited on what it can recover. See: http://www.cgsecurit...red_By_PhotoRec

 

If what you're trying to recover isn't on there then you might be out of luck.

 

Latest: https://www.cgsecuri...c_intel.tar.bz2

 

Instructions to use: http://www.cgsecurit...ec_Step_By_Step

 

You need to launch this from Terminal, for example after downloading and unpacking:

sudo ~/Downloads/testdisk-7.1-WIP/photorec

In Topic: VMware can't connect iPhone

27 August 2017 - 06:12 PM

Shut down the VM and under Virtual Machine Settings, Select the USB controller on the Hardware tab and there should be an option for USB compatibility. Set that to USB 2.0 and see if that makes a difference

In Topic: VMware can't connect iPhone

27 August 2017 - 04:30 PM

It would help if you shared what Linux distro you're using as I can't tell you if this solution will fix things. Let me know. I'm assuming yours is some Debian variant.
 
Have just tried unmounting your iPhone from Nautilus right before attaching it to your VM? You should always try the basics first.
 
If you never plan on communicating with your iPhone on your Linux host machine and will just be doing it through your macOS VM then you can prevent usbmuxd from loading, which is what is preventing VMware from accessing the device. usbmuxd is a service specific to iOS devices in Linux. Run this in terminal: 
sudo touch /etc/udev/rules.d/39-usbmuxd.rules
sudo udevadm control --reload-rules
This blank file should prevent usbmuxd from launching when you plug in your iPhone from now on.
 
As for the second error, that's the Nautilus file manager automatically mounting your iPhone for photo access. If you don't care about that, you can run this:
sudo chmod a-x /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
that will take away executable permissions for all users so the next time it automatically tries to run it when you plug in your iPhone or any kind of camera plugged into USB, it will fail to mount. There is also an option in Nautlius gconf settings to disable automounting in general, but I think this is the easier way to do it.
 
To undo what you just did in case you want to re-enable it for whatever reason:

sudo rm /etc/udev/rules.d/39-usbmuxd.rules
sudo udevadm control --reload-rules
sudo chmod a+x /usr/lib/gvfs/gvfs-gphoto2-volume-monitor

In Topic: GA-Z97x-ud7 - i7-4790k - Restarting issue without cpus=1(4)

17 August 2017 - 11:28 PM

here's a pretty bare config.plist you can start out with and go from there:

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy