Jump to content

Ukr55

Ukr55

Member Since 17 Mar 2010
Offline Last Active Today, 03:12 AM
****-

Posts I've Made

In Topic: Patch for AppleTyMCEDriver.kext not working

01 September 2016 - 11:45 AM

 

Ehh, panic :(

Clover config:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Debug</key>
			<false/>
			<key>DropOEM_DSM</key>
			<false/>
			<key>Fixes</key>
			<dict>
				<key>FixSATA_0400</key>
				<true/>
			</dict>
			<key>Name</key>
			<string>DSDT.aml</string>
			<key>ReuseFFFF</key>
			<true/>
		</dict>
		<key>DropTables</key>
		<array>
			<dict>
				<key>Signature</key>
				<string>DMAR</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>SSDT</string>
				<key>TableId</key>
				<string>CpuPm</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>SSDT</string>
				<key>TableId</key>
				<string>Cpu0Ist</string>
			</dict>
		</array>
		<key>SSDT</key>
		<dict>
			<key>DropOem</key>
			<false/>
			<key>Generate</key>
			<true/>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>npci=0x2000 nv_disable=1</string>
		<key>Debug</key>
		<false/>
		<key>DefaultVolume</key>
		<string>Server HD</string>
		<key>Secure</key>
		<false/>
		<key>Timeout</key>
		<integer>5</integer>
		<key>XMPDetection</key>
		<false/>
	</dict>
	<key>CPU</key>
	<dict>
		<key>UseARTFrequency</key>
		<false/>
	</dict>
	<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>No</string>
		</dict>
		<key>USB</key>
		<dict>
			<key>FixOwnership</key>
			<false/>
			<key>Inject</key>
			<false/>
		</dict>
	</dict>
	<key>GUI</key>
	<dict>
		<key>Language</key>
		<string>pl:0</string>
		<key>Mouse</key>
		<dict>
			<key>DoubleClick</key>
			<integer>500</integer>
			<key>Enabled</key>
			<false/>
			<key>Mirror</key>
			<false/>
			<key>Speed</key>
			<integer>8</integer>
		</dict>
		<key>Scan</key>
		<true/>
		<key>ScreenResolution</key>
		<string>1280x1024</string>
		<key>Theme</key>
		<string>bootcamp</string>
	</dict>
	<key>Graphics</key>
	<dict>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<false/>
			<key>NVidia</key>
			<false/>
		</dict>
		<key>NvidiaSingle</key>
		<false/>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		<key>AppleRTC</key>
		<true/>
		<key>AsusAICPUPM</key>
		<false/>
		<key>Debug</key>
		<false/>
		<key>ForceKextsToLoad</key>
		<array>
			<string>/EFI/CLOVER/kexts/Other/Disabler.kext</string>
		</array>
		<key>KernelCpu</key>
		<false/>
		<key>KernelHaswellE</key>
		<false/>
		<key>KernelLapic</key>
		<false/>
		<key>KernelPm</key>
		<false/>
		<key>KextsToPatch</key>
		<array>
        ss<dict>
			<key>Comment</key>
			<string>MacPro4,1 MacPro5,1 no ECC #1</string>
			<key>Disabled</key>
			<false/>
			<key>Find</key>
			<data>
			TWFjUHJv
			</data>
			<key>MatchOS</key>
			<string>10.11.x</string>
			<key>Name</key>
			<string>AppleTyMCEDriver</string>
			<key>Replace</key>
			<data>
			ICAgICAg
			</data>
		</dict>
		<dict>
			<key>Comment</key>
			<string>MacPro4,1 MacPro5,1 no ECC #2</string>
			<key>Disabled</key>
			<false/>
			<key>Find</key>
			<data>
			AE1hY1BybzQsMQBNYWNQcm81LDEA
			</data>
			<key>MatchOS</key>
			<string>10.10.x,10.12.x</string>
			<key>Name</key>
			<string>AppleTyMCEDriver</string>
			<key>Replace</key>
			<data>
			AE1hY1BybzksMQBNYWNQcm85LDEA
			</data>
		</dict>
		</array>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>BooterConfig</key>
		<string>0x28</string>
		<key>CsrActiveConfig</key>
		<string>0x67</string>
		<key>ROM</key>
		<string>UseMacAddr0</string>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>BiosReleaseDate</key>
		<string>10/07/10</string>
		<key>BiosVendor</key>
		<string>Apple Inc.</string>
		<key>BiosVersion</key>
		<string>MP51.88Z.007F.B03.1010071432</string>
		<key>Board-ID</key>
		<string>Mac-F221BEC8</string>
		<key>BoardManufacturer</key>
		<string>Apple Inc.</string>
		<key>BoardType</key>
		<integer>11</integer>
		<key>ChassisAssetTag</key>
		<string>Pro-Enclosure</string>
		<key>ChassisManufacturer</key>
		<string>Apple Inc.</string>
		<key>ChassisType</key>
		<string>06</string>
		<key>Family</key>
		<string>Mac Pro</string>
		<key>Manufacturer</key>
		<string>Apple Inc.</string>
		<key>ProductName</key>
		<string>MacPro5,1</string>
		<key>SerialNumber</key>
		<string>XXXX</string>
		<key>Trust</key>
		<true/>
		<key>Version</key>
		<string>1.0</string>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>InjectKexts</key>
		<string>Yes</string>
		<key>InjectSystemID</key>
		<true/>
	</dict>
</dict>
</plist>

Ok will try to make working patch for 10.11


Now I created usb flash drive with ElCapitan for verified patch.

In Topic: Patch for AppleTyMCEDriver.kext not working

01 September 2016 - 11:03 AM

Thanks but still installer gave me a kernel panics. :(

What about this variant 

                  <dict>
			<key>Comment</key>
			<string>MacPro4,1 MacPro5,1 no ECC #1</string>
			<key>Disabled</key>
			<false/>
			<key>Find</key>
			<data>
			TWFjUHJv
			</data>
			<key>MatchOS</key>
			<string>10.11.x</string>
			<key>Name</key>
			<string>AppleTyMCEDriver</string>
			<key>Replace</key>
			<data>
			ICAgICAg
			</data>
		</dict>
		<dict>
			<key>Comment</key>
			<string>MacPro4,1 MacPro5,1 no ECC #2</string>
			<key>Disabled</key>
			<false/>
			<key>Find</key>
			<data>
			AE1hY1BybzQsMQBNYWNQcm81LDEA
			</data>
			<key>MatchOS</key>
			<string>10.10.x,10.12.x</string>
			<key>Name</key>
			<string>AppleTyMCEDriver</string>
			<key>Replace</key>
			<data>
			AE1hY1BybzksMQBNYWNQcm85LDEA
			</data>
		</dict>

In Topic: Patch for AppleTyMCEDriver.kext not working

01 September 2016 - 10:46 AM

Hey Ukr55, i tried this on 10.11.5 installer and still panics :E

Ok I will try to make a patch for now 10.11 


Check this patch

                  <dict>
			<key>Comment</key>
			<string>MacPro4,1 MacPro5,1 no ECC #1</string>
			<key>Disabled</key>
			<false/>
			<key>Find</key>
			<data>
			CgBNYWNQcm80LDEATWFjUHJvNSwxAA==
			</data>
			<key>MatchOS</key>
			<string>10.11.x</string>
			<key>Name</key>
			<string>AppleTyMCEDriver</string>
			<key>Replace</key>
			<data>
			CgAAAAAAAAAAAAAAAAAAAAAAAAAAAA==
			</data>
		</dict>
		<dict>
			<key>Comment</key>
			<string>MacPro4,1 MacPro5,1 no ECC #2</string>
			<key>Disabled</key>
			<false/>
			<key>Find</key>
			<data>
			AE1hY1BybzQsMQBNYWNQcm81LDEA
			</data>
			<key>MatchOS</key>
			<string>10.10.x,10.12.x</string>
			<key>Name</key>
			<string>AppleTyMCEDriver</string>
			<key>Replace</key>
			<data>
			AE1hY1BybzksMQBNYWNQcm85LDEA
			</data>
		</dict>

In Topic: Patch for AppleTyMCEDriver.kext not working

01 September 2016 - 10:22 AM

Nice, the patch works great on Sierra but no on El Capitan ;/

 

I tested this patch in 10.10.5 and 10.12 DP8. I do not have 10.11. You can try old patch with  MatchOS 10.11.x

Something like this

                  <dict>
			<key>Comment</key>
			<string>Allow booting with a MacPro4,1 or MacPro5,1 SMBIOS definition without ECC Memory</string>
			<key>Disabled</key>
			<false/>
			<key>Find</key>
			<data>
			cgoATWFjUHJvNCwxAE1hY1BybzUsMQBY
			</data>
			<key>MatchOS</key>
			<string>10.11.x</string>
			<key>Name</key>
			<string>AppleTyMCEDriver</string>
			<key>Replace</key>
			<data>
			cgoAAAAAAAAAAAAAAAAAAAAAAAAAAABY
			</data>
		</dict>
		<dict>
			<key>Comment</key>
			<string>MacPro4,1 MacPro5,1 no ECC</string>
			<key>Disabled</key>
			<false/>
			<key>Find</key>
			<data>
			AE1hY1BybzQsMQBNYWNQcm81LDEA
			</data>
			<key>MatchOS</key>
			<string>10.10.x,10.12.x</string>
			<key>Name</key>
			<string>AppleTyMCEDriver</string>
			<key>Replace</key>
			<data>
			AE1hY1BybzksMQBNYWNQcm85LDEA
			</data>
		</dict>

In Topic: Patch for AppleTyMCEDriver.kext not working

31 August 2016 - 06:49 AM

Hey spakk,

I searching working method for patching this on the fly.

You can try this patch. I test this patch with macOS 10.12 and this work very well

                         <dict>
				<key>Comment</key>
				<string>MacPro4,1 MacPro5,1 no ECC</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AE1hY1BybzQsMQBNYWNQcm81LDEA
				</data>
				<key>MatchOS</key>
				<string>10.10.x,10.12.x</string>
				<key>Name</key>
				<string>AppleTyMCEDriver</string>
				<key>Replace</key>
				<data>
				AE1hY1BybzksMQBNYWNQcm85LDEA
				</data>
			</dict>
© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy