Jump to content

Cristiano Possa

Cristiano Possa

Member Since 06 Nov 2009
Offline Last Active Nov 07 2014 03:16 PM
-----

Posts I've Made

In Topic: Yosemite: Audio - Realtek ALC AppleHDA

06 November 2014 - 07:14 PM

Hardware problem; case/front panel/HD Audio?

Hi toleda, I don't think it's a hardware problem, since in Windows it works.

 

Yes, I'm talking about front panel conectors.

And yep, it's setted HD Audio (checked on BIOS).

In Topic: Yosemite: Audio - Realtek ALC AppleHDA

05 November 2014 - 07:52 PM

"Add native KextsToPatch/ 2 patches to config.plist" is opposite of delete.  Made it worse, config.plist is damaged.  Rename and install the repaired config.plist, restart and run the script again.  Reply with Terminal Output, new config.plist and IOReg.

 

Much thank you toleda. I'm a newbie with Clover, sorry for the mess...

 

Made the reparation in config.plist, rerun the script and, all works!

 

Now, the front panel audio don't work on this ALC887 (888b)?

 

Thanks!

In Topic: Yosemite: Audio - Realtek ALC AppleHDA

05 November 2014 - 04:26 PM

Patch failed because the native config.plist/KernelAndKextPatches/KextsToPatch/ patches have been removed.  Add native KextsToPatch/ 2 patches to config.plist.

 

toleda, I deleted the "KextsToPatch" from KernelAndKextPatches in config.plist and rerun the script, the output:

File: audio_cloverALC-100.command_v1.0.1
Verify EFI partition mounted, Finder/Devices/EFI
Password:
Confirm Realtek ALC887 (y/n): y
ALC887 Current_v..0302 (y/n): y
Clover Audio ID Injection (y/n): y
Use Audio ID: 1 (y/n): y

Download ALC887 files ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 24502  100 24502    0     0  16643      0  0:00:01  0:00:01 --:--:-- 16634
Edit config.plist/Devices/Audio/Inject
Edit config.plist/KernelAndKextPatches/KextsToPatch
Download kext patches and merge to config.plist ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1268  100  1268    0     0   1211      0  0:00:01  0:00:01 --:--:--  1212
Edit config.plist/SystemParameters/InjectKexts/YES
Edit config.plist/Boot/Arguments/kext-dev-mode=1
Print: Entry, ":KernelAndKextPatches:KextsToPatch:", Does Not Exist
Add: ":KernelAndKextPatches:KextsToPatch:0" Entry Already Exists
Add: ":KernelAndKextPatches:KextsToPatch:0:Comment" Entry Already Exists
Add: ":KernelAndKextPatches:KextsToPatch:0:Find" Entry Already Exists
Add: ":KernelAndKextPatches:KextsToPatch:0:Name" Entry Already Exists
Add: ":KernelAndKextPatches:KextsToPatch:0:Replace" Entry Already Exists
Install /EFI/CLOVER/kexts/10.10/realtekALC.kext
Download config kext and install ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  3322  100  3322    0     0   3175      0  0:00:01  0:00:01 --:--:--  3175
/EFI/CLOVER/kexts/10.10/realtekALC.kext deleted
Install System/Library/Extensions/AppleHDA.kext/ALC887 zml files
Fix permissions ...
Kernel cache...
rebuilding //System/Library/Caches/com.apple.kext.caches/Startup/kernelcache
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AppleRTL8169Ethernet.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleHDA.kext

Install finished, restart required.
To save a Copy to this Terminal session: Terminal/Shell/Export Text As ...
logout

And the config.plist became this:

 

https://www.dropbox.....22.57.png?dl=0

 

Is this right? I don't understand what u say with "Add native KextsToPatch/ 2 patches to config.plist."... which 2 patches?

 

Thanks.

In Topic: Yosemite: Audio - Realtek ALC AppleHDA

04 November 2014 - 10:11 PM

What script did you use? Attach Terminal Saved Output (rerun, if necessary).  Attach Post #1, Problem Reporting, Items 5 and 8-2.

 

Here's the output:

 

https://www.dropbox....ommand.txt?dl=1

 

Thank you toleda.

In Topic: Yosemite: Audio - Realtek ALC AppleHDA

04 November 2014 - 05:45 PM

Toleda, first of all, thank you for all the work making this guides!

 

So, I'm trying to make my ALC887 (ALC888b) work, but I'm having no luck!

 

Here's the debug info:

 

Yosemite 10.10 / ASUS P8H61M LE BR Rev3 / Core i5 2400 / GeForce GT220 1GB

CLOVER: Devices/Audio/Inject/1 (tried 2 and 3 too)

IOREG DUMP

LAST BOOT LOG

AppleHDA.kext Yosemite Native since Install.

No other related kext installed

CONFIG.PLIST

 

Just a quick edit:

 

On System Information i got:

 

https://www.dropbox.....01.14.png?dl=0

 

On System Preferences:

 

https://www.dropbox.....01.34.png?dl=0

 

Thanks!

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy