Jump to content

LuckyLuck

LuckyLuck

Member Since 17 Sep 2009
Offline Last Active Today, 01:06 PM
-----

Posts I've Made

In Topic: {Guide} DELL INSPIRON N5110

27 February 2017 - 10:18 AM

That didn't really help. I managed to get sound working, but for that i had to copy entire DSDT provided in Pre_Install.zip (both intel and nvidia provided working sound). I have of course also used aDummyHDA.kext and Clover patches as well.

 

Anyway, my problem was i got myself AzureWave AW-CE123H card, hoping it would get me handoff features working (it didn't) and original DSDT was killing my wifi.

I've compared DTGP method, hoping that it also needs patching, but it was not the issue, so i don't know what else is missing but using original DSDT with wifi replacement got me running with both wifi and sound.

 

I also got sound working on Sierra, but had to drop it, since there is no scrolling on two fingers, and smartTrackpad kext is just awful.

Even VoodooPS2Controller we're using on El Capitan is awful, but to discover that i had to try VoodooPS2Controller from RehabMan on Lenovo laptop - two fingers scrolling there is as smooth as on macbook.

Unfortunately VoodooPS2Controller from RehabMan doesn't get Trackpad working on N5110 (or at least it didn't for me)

Also, instead of editing dsdt.aml you can add to clover config (Devices/Audio/Inject) layout for audio codec
 

...
<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>12</string>
		</dict>
...

In Topic: {Guide} DELL INSPIRON N5110

26 February 2017 - 12:26 PM

I keep failing setting up sound on 10.11.6

Should i install 10.11.4 or what version works best?

Btw i don't see any mention of AppleALC. IDT 92HD87B1/3 is on the list of supported codecs, but it didn't work for me, anyone tried it?

I managed to get sound working on 10.11.6 with AppleALC but i'm loosing it on most reboots

If you are using clover you should have to add in your dsdt.aml in Device (HDEF) this code (if you do not have it)
 

Device (HDEF)
        {
            Name (_ADR, 0x001B0000)
            OperationRegion (HDAR, PCI_Config, 0x4C, 0x10)
            Field (HDAR, WordAcc, NoLock, Preserve)
            {
                DCKA,   1, 
                        Offset (0x01), 
                DCKM,   1, 
                    ,   6, 
                DCKS,   1, 
                        Offset (0x08), 
                    ,   15, 
                PMES,   1
            }

            Method (_PRW, 0, NotSerialized)
            {
                Return (GPRW (0x0D, 0x04))
            }

            Method (_DSM, 4, NotSerialized)
            {
                Store (Package (0x04)
                    {
                        "layout-id", 
                        Buffer (0x04)
                        {
                            0x0C, 0x00, 0x00, 0x00
                        }, 

                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }
        }

add to clover config AppleHDA patches (KernelAndKextPatches/KextsToPatch) and install aDummyHDA.kext (special for IDT 92HD87B1/3) to System/Library/Extensions (do not use clover kext folder for this kext)
I also have 10.11.6 and sound is working fine

patches and kext in zip file

In Topic: Tiger 10.4.1 in VirtualBox!

07 April 2016 - 11:12 PM

Cool!!
I have 10.4.11 on parallels,all works (sound,usb,network) but no 3d acceleration for virtual video
For graphics resolution i was set "Graphics Mode"to 1366x768x32  in org.chameleon.Boot.plist

Attached File  Снимок экрана 2016-04-08 в 2.05.52.png   1.25MB   4 downloads

In Topic: {Guide} DELL INSPIRON N5110

23 March 2016 - 09:43 PM

Audio works!!!  :w00t: 
Here is a working aDummyHDA.kext for El Capitan 10.11.4 (must be insalled to S/L/E !!! ) + necessary clover patches

Attached File  IDT 92HD87B1 for El Capitan 10.11.4.zip   15.96KB   91 downloads

In Topic: New AppleHDA Patcher

23 March 2016 - 04:15 PM

Was before?

Yes,on 10.11.3 sound was working (but with layout 0X0C,patched layout12.xml.zlib,Platforms.xml.zlib and clover patches,on 10.11.4 this not working)
And patched AppleHDA 274.7  with AppleHDA Patcher doesn't work too

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy