Jump to content

roboprez

roboprez

Member Since 27 May 2009
Offline Last Active Jul 22 2009 10:40 AM
-----

Topics I've Started

Time changing between Leopard and XP

31 May 2009 - 08:48 AM

When I boot into leopard it changes the system clock to UTC so when I boot back into windows it's wrong. I found this (below) on the forums and wiki but im a real noob at this kind of thing. Can someone give me clear step by step intructions on what to do?

I experienced the same problem in Leopard with /etc/rc.local and /etc/rc.shutdown.local being ignored. Studying the Leopard documentation reveals that both /etc/rc* and StartupItems startup/shutdown mechanisms are deprecated. Consequently, I devised the following Leopard-friendly solution to toggle the clock between local time and UTC at start-up and shut-down times. You will need Administrator privileges when performing this procedure.

  • Create new file /sbin/localtime-toggle with the following contents:
    #!/bin/sh
    	 
    	 to_utc() {
    	 echo "localtime-toggle: Toggling to UTC."
    	 date `date -u +%m%d%H%M%Y`
    	 }
    	 
    	 to_localtime() {
    	 echo "localtime-toggle: Toggling to localtime."
    	 date -u `date +%m%d%H%M%Y`
    	 }
    	 
    	 trap 'to_localtime; exit' term
    	 to_utc
    	 { while true; do sleep 86400; done; } &
    	 wait
  • Ensure that localtime-toggle is executable:
    chmod +x /sbin/localtime-toggle
  • Create new file /System/Library/LaunchDaemons/org.osx86.localtime-toggle.plist with the following contents:
    <?xml version="1.0" encoding="UTF-8"?>
    	 <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    	 <plist version="1.0">
    	 <dict>
    		 <key>Label</key>
    		 <string>org.osx86.localtime-toggle</string>
    		 <key>Program</key>
    		 <string>/sbin/localtime-toggle</string>
    		 <key>KeepAlive</key>
    		 <true/>
    		 <key>RunAtLoad</key>
    		 <true/>
    		 <key>HopefullyExitsFirst</key>
    		 <true/>
    	 </dict>
    	 </plist>
  • Reboot.
At this point, your computer's clock should correctly be set to UTC as Leopard boots, and reset back to local time as Leopard shuts down.

Mac not booting - bad update

30 May 2009 - 06:00 AM

I installed Leopard with kallyway on a external hard drive. It's been set up with drivers and works fine.
Now I made Mac update but when it got to 11% it stayed on it for 2 hours. I restarted the computer thinking it hadn't got to far but unfortunately it had. Now when i try to boot to it it tells me to restart every time.

I tried repairing the disk with the Kalyway boot-dvd but no help. Now I'm really regretting not setting up time-machine.

is there anyway I can either repair the install or easily restore all my programs, drivers and settings to a new install?
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy